• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Game needs graphics optimization?

Domingo_Chavez

FNG / Fresh Meat
Dec 30, 2008
85
26
0
Roswell, Ga
I thought I had a pretty capable machine with my quad core @ 3.0 and 4 gigs DDR2 800 and my 4870x2. But even on medium-high settings (no AA) the game seems laggy.

Shouldn't my specs be able to crush UR3?
 

[DH]Chris89

FNG / Fresh Meat
Dec 4, 2006
266
2
0
England - West Midlands
What resolution are you running at and what exact quad core?

Im using two 4870s (1GB verisons) And can run the game fine on ultra, rest of spec is Phenom II 965, 8GB ram.

Yet at 1920x1200 was at a mixture of high and medium, knocking it to 1680x1050 works fine.
 

Qweets

FNG / Fresh Meat
Jul 13, 2007
443
221
0
turn off crossfire for now, it runs better with crossfire off. I have 2 x 5850's and I get WAY better framerate with crossfire turned off, Tripwire is in contact with AMD to try and get the crossfire issue fixed. But for now the best thing to do is disable it.
 

Qweets

FNG / Fresh Meat
Jul 13, 2007
443
221
0
I personally left depth of field on because I love the way it looks and still get 60-80 fps with crossfire turned off.
 

teemu92

FNG / Fresh Meat
May 31, 2011
1,050
140
0
Finland
www.youtube.com
Yeah definitely needs optimization, i got a i7 920 @ 2.67ghz 3gb ram & gtx 295 card, i get 30-40 fps in fallen fighters & other maps, ALL low in game settings + ini tweaks, and settings on off & performance on nvidia control panel.

D:
 

Krazyxazn

FNG / Fresh Meat
Mar 23, 2009
407
117
0
It does need optimization. From the posts I see and specs of rigs and their performances, its just doesn't seem right.

I on the other hand have been good good performances, not so much for other users.
 

Gyarados

FNG / Fresh Meat
Sep 6, 2011
6
0
0
I get a solid 60 FPS.

i5-2400 3.1GHz, AMD 6850 1GB, 8GB DDR3 1600.
 
Last edited by a moderator:

MrLebanon

FNG / Fresh Meat
Jun 6, 2011
439
179
0
on a forum
AMD Phenom II x6 1100T overclockedto 3.8ghz
EVGA GTX570 superclocked

on ultra in a 64 person server I get 30-40 fps running ultra
hardly 60 on high :/
mind you im used to it after having horrible FPS for years on my laptop
but
pulling up stat fps and checking made me :(
will try the depth of field trick (although depth of field looks awesome IMO)
 

Domingo_Chavez

FNG / Fresh Meat
Dec 30, 2008
85
26
0
Roswell, Ga
What resolution are you running at and what exact quad core?

Im using two 4870s (1GB verisons) And can run the game fine on ultra, rest of spec is Phenom II 965, 8GB ram.

Yet at 1920x1200 was at a mixture of high and medium, knocking it to 1680x1050 works fine.
Running at 1920x1080. I have the kentsfield Q6600? I believe that is the one. Bought it in '07.

My ram is only DDR2 800 so that may be slowing me down but I feel like my card isn't being used to full capacity. Does the 48070x2 run in crossfire? (its only one card). I'll look into disabling it.

I still feel like my specs should crush this game..
 

mr71mb0

FNG / Fresh Meat
Aug 16, 2011
48
21
0
Running at 1920x1080. I have the kentsfield Q6600? I believe that is the one. Bought it in '07.

My ram is only DDR2 800 so that may be slowing me down but I feel like my card isn't being used to full capacity. Does the 48070x2 run in crossfire? (its only one card). I'll look into disabling it.

I still feel like my specs should crush this game..
You're assumption though is that just because it's based on UE3 that you have run at high fps in some games in the past that you should be getting the same out of this title. RO2 sure is based on the UE3 engine, but it's been customsied and extended to suite TWI's needs and having 64 players in a server also causes additional strain.

That's not to say they don't have some performance issues that can be resolved, just don't compare this title to other UE3 games that ran well and expect the same out of what is now pretty old hardware.
 

Domingo_Chavez

FNG / Fresh Meat
Dec 30, 2008
85
26
0
Roswell, Ga
You're assumption though is that just because it's based on UE3 that you have run at high fps in some games in the past that you should be getting the same out of this title. RO2 sure is based on the UE3 engine, but it's been customsied and extended to suite TWI's needs and having 64 players in a server also causes additional strain.

That's not to say they don't have some performance issues that can be resolved, just don't compare this title to other UE3 games that ran well and expect the same out of what is now pretty old hardware.
Very valid point, my hardware is slowly being outdated. I could use a mobo and some DDR3. I feel like the cpu and graphics card should be able to handle this game just fine. Either way, it still look pretty good on medium settings.
 

wikchi

FNG / Fresh Meat
Aug 22, 2011
69
5
0
i7 920 @ 2.8ghz+
12gb
1gb gtx 460 oc

Runs great with Shadows on Medium and everything else at ultra (30-60fps+) but as soon as i turn the shadows up to high or ultra it lags like a mofo (30fps at the most), shadows need optimization for sure, because no other setting drags fps down as much as high or ultra shadows.
 

Domingo_Chavez

FNG / Fresh Meat
Dec 30, 2008
85
26
0
Roswell, Ga
I'll start tweaking around with settings. I love running AA on my games. What settings should I leave completely off to save on some frames? I have no idea what ocular occlusion and any of those other settings do?
 

mr71mb0

FNG / Fresh Meat
Aug 16, 2011
48
21
0
Very valid point, my hardware is slowly being outdated. I could use a mobo and some DDR3. I feel like the cpu and graphics card should be able to handle this game just fine. Either way, it still look pretty good on medium settings.
I wouldn't do anything untill a while after the full release hits. Give them time. Just know it will get better. Perhaps try and stick to 32 player servers for a bit as that's supposed to make things run smoother.

I have a Q6600 and a 5870, run everything on High and it's 40-60fps. I have tried dropping to medium but doesn't make a huge difference and the graphics look bad. Medium textures look horrid.

I don't think DDR3 is the answer to your issues. IMO it wouldn't make any difference at all to you and you'd be looking at a new Mobo, RAM and CPU

I've checked taskman while the game is running and all 4 cores on my q6600 are ~60% so it's by no means the bottleneck here.

Remember it's early days, TWI are working flat out but they can only do so much in 7 days. Just be patient and they will get there.
 

mr71mb0

FNG / Fresh Meat
Aug 16, 2011
48
21
0
i7 920 @ 2.8ghz+
12gb
1gb gtx 460 oc

Runs great with Shadows on Medium and everything else at ultra (30-60fps+) but as soon as i turn the shadows up to high or ultra it lags like a mofo (30fps at the most), shadows need optimization for sure, because no other setting drags fps down as much as high or ultra shadows.
Other peeps have dire performance when shadows set to medium and it actually improves when they set shadows to high. There are odd issues for sure, but they are being worked on.
 

Domingo_Chavez

FNG / Fresh Meat
Dec 30, 2008
85
26
0
Roswell, Ga
I wouldn't do anything untill a while after the full release hits. Give them time. Just know it will get better. Perhaps try and stick to 32 player servers for a bit as that's supposed to make things run smoother.

I have a Q6600 and a 5870, run everything on High and it's 40-60fps. I have tried dropping to medium but doesn't make a huge difference and the graphics look bad. Medium textures look horrid.

I don't think DDR3 is the answer to your issues. IMO it wouldn't make any difference at all to you and you'd be looking at a new Mobo, RAM and CPU

I've checked taskman while the game is running and all 4 cores on my q6600 are ~60% so it's by no means the bottleneck here.

Remember it's early days, TWI are working flat out but they can only do so much in 7 days. Just be patient and they will get there.
I also hear my video card running at about 60% as well (the fan speed anyway) so I guess we will just have to wait and see. Oh well. I agree that medium textures look terrible.
 

Vegard

FNG / Fresh Meat
Jan 28, 2006
113
36
0
Call of Duty RO:HOS
I have a laptop with 2.66ghz i7, 8gb ddr3 and a 512mb 330m.
The games runs at the exact same framerate wether I use low, medium or high settings; 30-40fps depending on where I am on the map.

:crash: