In Game Voice Chat Investigation

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Syndicato

FNG / Fresh Meat
Oct 15, 2020
2
0
1
Currently able to hear squad over voice but not team. I can seemingly transmit voice (the indicator comes up but have no clue if it's actually going through).

This is since at least 1.5.2, but I didn't play for the 1.5 or 1.5.1 updates.
 

Attachments

  • DxDiag.txt
    91.2 KB · Views: 0
  • RSAudio1.png
    RSAudio1.png
    15.2 KB · Views: 2
  • RSAudio2.png
    RSAudio2.png
    18.4 KB · Views: 1
  • RSAudio3.png
    RSAudio3.png
    18.8 KB · Views: 1
  • RSAudio4.png
    RSAudio4.png
    70.9 KB · Views: 1
  • RSAudio5.png
    RSAudio5.png
    395.5 KB · Views: 1

Syndicato

FNG / Fresh Meat
Oct 15, 2020
2
0
1
Alright, so apparently the game just cycled my voice channel after the new update and that's the source of the problem. I just cycled back to team and it works.
 

DocSnyder

FNG / Fresh Meat
Oct 16, 2020
2
0
1
cant hear any ingame voicechat not sure if they can hear me ?
 

Attachments

  • DxDiag.txt
    88.1 KB · Views: 1
  • rs2 audio 1.png
    rs2 audio 1.png
    49.3 KB · Views: 1
  • rs2 audio 2.png
    rs2 audio 2.png
    32.6 KB · Views: 0
  • rs2 audio 3.png
    rs2 audio 3.png
    28.9 KB · Views: 0

Kittenmittens

Tripwire Interactive Community Team
Staff member
Mar 11, 2016
1,367
338
83
Killing Floor Discord :)
For these issues, additional logs would help.


A little manual how to make logs unsupressed.
  1. To do so user has to change DefaultEngine.ini file in ROGame\Config directory: put ";" symbol in lines Suppress=DevOnlineStats and Suppress=DevOnlineSpam.
  2. Then after the match take logs from Steam client: \Documents\My Games\Rising Storm 2\ROGame\Logs Or EGS client: Documents\My Games\Rising Storm 2 EGS\ROGame\Logs
Don't forget to revert changes in DefaultEngine.ini after getting this logs!
 
Last edited:

RedWolfxD

FNG / Fresh Meat
Oct 16, 2020
1
0
1
Hi so just reporting this: the in game mic is not working at all any more. Used to work before the latest updates. The talk icon comes up when I press to talk, but the needle doesn't move or appear at all when I speak. I've checked my mic configuration and tested it and my actual mic IS working, the game is picking up the input levels when I talk (when I run the test in the settings) but when I try it during game play there is no needle. I also do not hear any other people's mics. When I pressed F4 and asked through type chat if mics aren't working? People typed back saying "no". This really sucks because half the fun and immersion in this game is the mics. Hope you guys can fix this asap!
 

Guthkeled Keled

FNG / Fresh Meat
Oct 16, 2020
2
0
1
I've played 600+ hours in RS2 and RO/RO2 without VOIP problems. I now cannot hear or transmit any voice chat, despite making no changes at my end. If I use any channel in-game, the voice meter on the screen appears but the needle doesn't move. I am in voice chat with a friend on a Steam Chat window with no problems throughout a session, which is how we have always played the game. Skype and other programmes that need microphone input work as expected. I have a microphone plugged into a front panel socket, and headphones into a rear panel socket.

The problem seems common across the game as there have been many typed comments in each round I've played asking if anyone can hear anything.

I'll get the logs and post when I next play.
 

Slider

FNG / Fresh Meat
Oct 17, 2020
2
1
3
so ...after 6 hours of cursing and swearing, I discovered this post...
I'll list all the things I tried:
-Reinstalled the game 4 times, 2 times on the same SSD and 2 times on 2 different NVME
--every uninstall I deleted the whole RS2:V folder under "C:\Users\*User*\Documents\My Games\..."
-Windows update are up to date (miracle that this didn't destroyed my PC beyond imagination)
-Updated Nvidia driver
-Port Forwarded Steam the section "Steamworks P2P Networking and Steam Voice Chat" as described here https://support.steampowered.com/kb_article.php?ref=8571-GLVN-8711
-Port Forwarded RS2:V *the following ports ->" https://portforward.com/rising-storm-2-vietnam/ "and these too ->" 7777 (default used by RO2) , 7779 (default used by RO2) , 27015 (used to contact the steam master server) , 8080 (default used for the RO2 web-admin)
--Restarted even my router to be sure the ports were actually applied
-white listed RS2:V on my anti virus "Avast", then joined the game
--disabled totally Avast, then joined the game
-white listed in my firewall RS2:V, then joined the game
--disabled totally windows firewall, then joined the game
-I tried every USB port in my computer with my headset
*Image "RS2Audio1"*
-I enabled and disabled every single "Playback" device
--Tried different combination with Default & Default Communication
!!_weird bug_!! that happens only with this game: once I open the game setting -> "Configure my Mic" and steam voicechat option opens, and I test my mic: after testing mic (and works) if I have set on my headset both "Default device" & "Default Communication device" the volume lowers a lot and there's no way to raise it, only way is restart the PC or set "Default Communication device" on the speakers, so the headset gains volume again.
*Image "RS2Audio4"*
-I tried swapping devices when I enabled them there, and troubleshooted when the game was opened
*Image "RS2Audio5"*
(before telling you what I did, let me point out 2 things: when you voice chat in steam what takes microphone control is "Steam Client WebHelper" and the image is not showing the game because at the moment of the screenshot I had it closed)
-I tried swapping from default to my mic/speakers from the headset, did this for: master volume, steam client webhelper, RS2V, steam
-even resetted (the button "Reset" below)
*Image "RS2Audio6"*
-I disabled and enabled the microphone multiple times for all apps
-The thing is that, as the picture shows, discord has the mic in use. When I test the mic with steam voice chat "steam client webhelper" becomes in use with the mic, but the game never got the mic in use
*Image "RS2Audio7"*
(because microsoft never stops to surprise....)
-I opened the Xbox Console Companion, and it was detecting RS2:V , once I was in game it has his own overlay; hotkey "Windows key" + G
--In the overlay I applied in every audio option my mic & headset

Nothing of the above did work, but ... let me point out what/where I believe the problem might be:
When I installed the game multiple times on different hard disks (I have 5.. don't ask why) if it wasn't where I had it first installed, the game icon under the mic permission in the *Image "RS2Audio5"* was not even showing, like the game is not even installed/recognized by windows.
At this point I thinking there's some "left over" after uninstalling that gets stuck with the first install patch for the microphone permission that doesn't get refreshed with the new path.

I really hope all this helps in any way
 

Attachments

  • RS2Audio1.png
    RS2Audio1.png
    24.6 KB · Views: 1
  • RS2Audio2.png
    RS2Audio2.png
    24.2 KB · Views: 1
  • RS2Audio3.png
    RS2Audio3.png
    12.3 KB · Views: 1
  • RS2Audio4.png
    RS2Audio4.png
    394.2 KB · Views: 1
  • RS2Audio5.png
    RS2Audio5.png
    33 KB · Views: 1
  • RS2Audio6.png
    RS2Audio6.png
    240.8 KB · Views: 1
  • RS2Audio7.png
    RS2Audio7.png
    70.2 KB · Views: 1
  • DxDiag.txt
    120.2 KB · Views: 1
  • DefaultEngine.txt
    23.8 KB · Views: 1
  • Launch.txt
    48.8 KB · Views: 1
  • Like
Reactions: Kittenmittens

Slider

FNG / Fresh Meat
Oct 17, 2020
2
1
3
Attaching the remaining files
 

Attachments

  • RS2Audio9.png
    RS2Audio9.png
    68.8 KB · Views: 1
  • Launch-backup-2020.10.17-18.32.31.txt
    78.3 KB · Views: 1
  • RS2Audio8.png
    RS2Audio8.png
    969.4 KB · Views: 1

MauveineDev

FNG / Fresh Meat
Oct 18, 2020
2
1
3
I had the same issue reported by several, that is, being able to see people using comms but being unable to listen or speak. After a couple hours of testing with my unique setup (btw i got the game from EPIC), i have found interesting results

PARTIAL SOLUTION: for some reason P2P comms were disabled on my configs; enabling them got them working again but only for 1 of my ISP, not all of them.

To change the config i went to C:\Users\[your_user]\Documents\my games\Rising Storm 2 EGS\ROGame\Config\ROEngine.ini and there i changed AllowPeerVoice=False to AllowPeerVoice=True

I tested this in several servers both custom and officials, getting mixed results. Most of the time my "TELMEX" line started working again but given the fact that it has 400+ ping to every server, i cant use that to play any frontline. That line has an ARRIS router, from CLARO CHILE, and has 50Mbs of band, and its only an internet connection. Also, sometimes i saw a squad member talking but couldnt hear him, despite being able to hear TEAM and COMMANDER. Im not sure about PUBLIC.

Changing to my other line, comms die, even in the same server (to which i have to exit and reconnect). I did not make an exhaustive testing of this because of the loading times and few people using their comms, but i have not been able to get them working, even with the config change. I have not tried changing AllowPeerConnections to true because that might be a dangerous thing to do, but still. This line is fast but narrow, being MOVISTAR, 1Mbps. This line has phone + internet.

I have made no changes to my firewall settings, nor i have a complex setup on audio. I have set my speakers to main comms on windows, and tested with an usb headset, but no dice. I have the feeling that is has to do with the way the router handles VOIP but i have no idea about how that works. Im currently tryng to get access to the MOVISTAR router config but the password has been set by a tech and overrides the default one on the back of the case (so useful).

A good indicator that you got your comms working is that when you try to speak, the needle moves, if you feel like testing yourself.

Hope it helps yall.
 

MauveineDev

FNG / Fresh Meat
Oct 18, 2020
2
1
3
CONFIRMED: the router was setup to refuse VOIP connections. The setting was arcane (firewall > WAN_DEFAULT, ppp0.1), just enabled all incoming data and it worked.
 
  • Like
Reactions: Kittenmittens

Kittenmittens

Tripwire Interactive Community Team
Staff member
Mar 11, 2016
1,367
338
83
Killing Floor Discord :)
Hi so just reporting this: the in game mic is not working at all any more. Used to work before the latest updates. The talk icon comes up when I press to talk, but the needle doesn't move or appear at all when I speak. I've checked my mic configuration and tested it and my actual mic IS working, the game is picking up the input levels when I talk (when I run the test in the settings) but when I try it during game play there is no needle. I also do not hear any other people's mics. When I pressed F4 and asked through type chat if mics aren't working? People typed back saying "no". This really sucks because half the fun and immersion in this game is the mics. Hope you guys can fix this asap!
Please see the original post for information on what details, settings, and logs to provide. Thank you.
 

notevenclosebaby

FNG / Fresh Meat
Sep 17, 2011
3
0
1
What exactly is the issue you are experiencing?

- Can't hear anyone and no one can hear me during entire matches. Wasn't having this issue until today, but it seems random because sometimes my friend has the same issue. Neither of us had this issue prior to the epic game store update. I will say, when voice chat was working, i remember leaving a server and i could still hear players in the main menu which is somewhat concerning.

I have attached log with following commands enabled. The log features me playing on a campaign server for a few rounds with no working viop
;+Suppress=DevOnlineStats
;+Suppress=DevOnlineSpam
 

Attachments

  • audiosteam.png
    audiosteam.png
    129.2 KB · Views: 1
  • audiowindows10.png
    audiowindows10.png
    42.1 KB · Views: 1
  • DxDiag.txt
    93.4 KB · Views: 1
  • rs2audio.png
    rs2audio.png
    587.8 KB · Views: 1
  • Launch.txt
    338 KB · Views: 1

Tawngs

FNG / Fresh Meat
Oct 19, 2020
1
0
1
Just played for about an hour to generate this log with a friend of mine who also experienced strange voice issues on the same server, like other people I am experiencing the following, names appearing with no voice, voice being heard with no names being displayed on screen, microphone will intermittently not be detected on the in game indicator, sometimes being fixed mid round (perhaps after death?) or sometimes not being fixed at all until I switch servers, sometimes I can hear the voices of what sounds like someone on the enemy team in the distance, and sometimes I'll just have entire matches where I hear no one at all.

I have attached logs using ;+Suppress=DevOnlineStats and ;+Suppress=DevOnlineSpam and converted them to .txt

Thanks for opening up the game to a larger community and thanks for the hard work and time.
 

Attachments

  • CONTROLPANEL1.png
    CONTROLPANEL1.png
    25.1 KB · Views: 2
  • CONTROLPANEL2.png
    CONTROLPANEL2.png
    24.6 KB · Views: 2
  • CONTROLPANEL3.png
    CONTROLPANEL3.png
    28.3 KB · Views: 2
  • WINDOWS1.png
    WINDOWS1.png
    298.6 KB · Views: 2
  • RS21.png
    RS21.png
    385.7 KB · Views: 2
  • RS22.png
    RS22.png
    506.1 KB · Views: 2
  • STEAM1.png
    STEAM1.png
    157.6 KB · Views: 2
  • STEAM2.png
    STEAM2.png
    152.5 KB · Views: 2
  • DxDiag.txt
    86.1 KB · Views: 1
  • Launch.txt
    319.4 KB · Views: 1

Kittenmittens

Tripwire Interactive Community Team
Staff member
Mar 11, 2016
1,367
338
83
Killing Floor Discord :)
Update:
We are working with Vivox to investigate these reports further. They have asked for the following information.
  • Locale
  • IP Address
  • Username Steam or Epic
Feel free to private message me the info.
 
  • Like
Reactions: MauveineDev

Guthkeled Keled

FNG / Fresh Meat
Oct 16, 2020
2
0
1
Symptoms:
  • some matches VOIP works, but only with certain channels (only squad for example)
  • The symptoms can vary from map to map on the same server, without leaving the game
  • Other players are audible but there is no on-screen indication who is speaking (this is team-wide, not an example of local chat)
  • The transmit meter needle doesn't move
  • if it does, the transmit meter needle moves much more jerkily than before the Epic update
  • It is unclear if VOIP is being received whether the needle is moving or not. It appears intermittent.
  • No matter what is happening in the game, throughout I am in conversation in a Steam Group Chat voice channel without any issues.
  • Nothing my end has changed since before the update; neither hardware nor software.
  • My in-game settings have not changed.
  • Microphone and headphones work fine in Skype, Steam Chat, other Steam games, Audacity etc.
It's important to stress that the in-game symptoms can be present in a random selection. Sometimes all, sometimes none.

The log appears to have been overwritten when I opened the game just now to screenshot the RS2 audio settings. This 'backup' log may retain the information from the last time I played.
 

Attachments

  • Sound Settings.PNG
    Sound Settings.PNG
    26.8 KB · Views: 0
  • Steam settings.PNG
    Steam settings.PNG
    68.5 KB · Views: 0
  • DxDiag.txt
    93.6 KB · Views: 0
  • 20201028134646_1.jpg
    20201028134646_1.jpg
    255.2 KB · Views: 0