• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

{How To} Install a Mod

someguy123

FNG / Fresh Meat
Nov 1, 2012
6
0
0
hey make a video or make a post showing how to add custome guns and no bullcrap like the colt python show us what code to take i never get the right one and it never adds to the trader when using server perks or custome trader mut so just help!!!!!!!!!!!



skype:jerrywhite542
 

halbridious

FNG / Fresh Meat
Jan 6, 2011
1,770
211
0
Michigan (USA)
hey make a video or make a post showing how to add custome guns and no bullcrap like the colt python show us what code to take i never get the right one and it never adds to the trader when using server perks or custome trader mut so just help!!!!!!!!!!!



skype:jerrywhite542
A) what is with people dropping skype names? Theres a pm system in steam and this forum, isn't that enough?
B) Gartleys python is a wonderful weapon
C) I haven't updated this in ages, but for christ sakes man, your questions have been answered a million times on both custom trader threads and serverperks thread...

D)The actual answer - find the mod's ucl file. open it up and look for the line that reads (gunname)package.gunnamePickup and then add that. A little effort on your part will get you the answer you seek...
Also, I think gartley's serverperks video contained the answer.
 

gunslingor

FNG / Fresh Meat
Jan 11, 2011
232
56
0
Does anyone know how to remove muts? A friend made a bunch of custom muts for my map, but it crashes servers.... I want them out of my map so I can play the map without the .u file... he really kind of left me hanging as I don't know or want to know anything about muts... I just want them all removed from my map so I can release this bad boy. Please help, here are the files... again, I just want all the muts gone at this point... they are probably going to be too hard to fix and I got to release this map already. Thanks

https://docs.google.com/file/d/0B71fEvZJKoXBQjdoSW9JSE1jajg/edit?usp=sharing
 

halbridious

FNG / Fresh Meat
Jan 6, 2011
1,770
211
0
Michigan (USA)
Do you have the WebAdmin set up? that will allow you to disable any mutators. Otherwise, it's a question of going into the servers "system" folder, and deleting the system files for mutators you don't want, and then deleting the animation/texture/ect. I haven't run a server in months, I don't remember if theres an easy way to "validate files" like you can for a game in steam or anything.
 

gunslingor

FNG / Fresh Meat
Jan 11, 2011
232
56
0
Do you have the WebAdmin set up? that will allow you to disable any mutators. Otherwise, it's a question of going into the servers "system" folder, and deleting the system files for mutators you don't want, and then deleting the animation/texture/ect. I haven't run a server in months, I don't remember if theres an easy way to "validate files" like you can for a game in steam or anything.
I do have a server with web admin, but this is kind of unrelated. I understand that on a dedicated server, you can enable/disable muts for a map and I'm familiar with these controls. But there appears to be some other way of doing mutators becasuse now my map won't even open in KFed if the .u file isn't in the system folder... it just crashes before it loads. Someone suggested digging thru all the actors looking for muts to delete, but I don't even know how to spot them or the best way to remove them. Another person suggested I simply remove the .u file, open the map, recompile, and all those .u links will be set to null... I think this would've been ideal, but I've tried it multiple times in multiple ways and still, KFed just crashes before the map is loaded. Some of the muts are really cool, I wish I knew how to isolate the one that crashes servers and just remove that one... dam, I really need some expert help here... maybe someone is willing to trade? If someone can help with this, I can make some models for them?

Can or has someone looked at my actual files yet? The link should be 2 posts up.
 
Last edited:

TimeTricks

FNG / Fresh Meat
Sep 14, 2014
9
0
0
The Netherlands
Killing floor server

Killing floor server

Hello,
Im new to the KF server thing.
I have "my own" server (and I can enable/disable whenever I want to)
I use TCADMIN and Webadmin/Serveradmin, and have a question.
How do I add those mutators to my server?
Because when I go to the webadmin mutators list, I have a predefined ones, and that's it.
Can someone help?
Thanks, TT
 

darkslash

FNG / Fresh Meat
Oct 19, 2014
2
0
0
just downloaded a mod and got a file with .u extension.. i cant seem to extract it it always says its corrupt either unknown format blah blah blah... can someone help please?? the file name is system_scrnbalance.u. thx
 

G~Tech

FNG / Fresh Meat
Jul 6, 2015
4
0
0
no idea where i went wrong.....

no idea where i went wrong.....

the back story: im A+, Net+, Sec+ certified & im not new to the gaming world... gifted my son my extra copy of the game. we played lots of LAN games & even a few net games. after a while, decided that we wanted to stick to LAN so we can make our own rules & custom games. i started setting up mods. we started playing with new classes & a few mods. we wanted more guns, added the guns and now he cant connect to me. just sits at killing floor "ip" index.rom. when I restore the back-up copy of the game folder, he connects with no issues but not when mods are enabled. restored modded folder and tested running a basic no mod game & he was able to connect. tested if he could connect via a net game, but same thing. index.rom. cant find any thing definitive on this issue...

no for the question: is there some kind of line or command i would need to add to one of the .ini files that would allow him to connect to the modded games? plz help

fyi: running server perks with scrn balance v8
 

Guardiannknight

FNG / Fresh Meat
Mar 24, 2012
420
0
0
www.guardiansworlds.com
the back story: im A+, Net+, Sec+ certified & im not new to the gaming world... gifted my son my extra copy of the game. we played lots of LAN games & even a few net games. after a while, decided that we wanted to stick to LAN so we can make our own rules & custom games. i started setting up mods. we started playing with new classes & a few mods. we wanted more guns, added the guns and now he cant connect to me. just sits at killing floor "ip" index.rom. when I restore the back-up copy of the game folder, he connects with no issues but not when mods are enabled. restored modded folder and tested running a basic no mod game & he was able to connect. tested if he could connect via a net game, but same thing. index.rom. cant find any thing definitive on this issue...

no for the question: is there some kind of line or command i would need to add to one of the .ini files that would allow him to connect to the modded games? plz help

fyi: running server perks with scrn balance v8



Sounds like you have hit the max limit on what the game can load. There is a limit to how many files can be loaded by the game. This means, animation, static mesh, sounds, textures, and the system .u and other files etc etc.

Try running this mod made by Marco, should help you run more mods and/or at least the mods you're trying to run. Link below.

http://forums.tripwireinteractive.com/showthread.php?t=100703
 

G~Tech

FNG / Fresh Meat
Jul 6, 2015
4
0
0
Sounds like you have hit the max limit on what the game can load. There is a limit to how many files can be loaded by the game. This means, animation, static mesh, sounds, textures, and the system .u and other files etc etc.

Try running this mod made by Marco, should help you run more mods and/or at least the mods you're trying to run. Link below.

http://forums.tripwireinteractive.com/showthread.php?t=100703
here's the odd thing about it. i can play solo & everything runs & looks just fine. but ill try removing some things & see what the brings. will post again some time later today.
 

G~Tech

FNG / Fresh Meat
Jul 6, 2015
4
0
0
the thing is, i can play every & all maps + mods in solo mode. i just cant fugue out why he cant join or what changed so much that would prevent him from joining...

ill give that De-serverpackage listing a try. will post back later.
 

DMN666

Active member
Jun 14, 2012
2,601
10
38
Brooklyn, NY
Of course you can play that all in solo, cause it doesn't have to send anything to anyone.
This error only occurs when the server is sending packages to clients.
 

G~Tech

FNG / Fresh Meat
Jul 6, 2015
4
0
0
Of course you can play that all in solo, cause it doesn't have to send anything to anyone.
This error only occurs when the server is sending packages to clients.
ok so i removed all the weapons i added, but now it says "killing floor//ip/(map name)" instead of index.rom. he cant connect to a game that he was able to connect to before. i restored my back up that had at least the new perks working & he was still unable to connect.

exp: he was able to connect to me hosting a scrn objective, legacy mode or a survival game, but now he cant connect to any of them. any tips???