For Poeple That Can't Start the Game - Part 2

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
Status
Not open for further replies.

Yoshiro

Senior Community Manager
Staff member
Oct 10, 2005
13,329
4,054
113
I would actually complain more about the ram, not the graphics (and that is an odd ammount of ram)

Which fixes have you run through. This will give us a better idea on what to suggest.
 

Antagonist

FNG / Fresh Meat
Apr 9, 2006
15
0
0
I'm having the general protection fault error...

Code:
 Build RedOrchestra_Build_[2005-11-27_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 2308 MHz with 1023MB RAM
Video: RADEON X800 PRO (6614)

General protection fault!

History: RenderLevel <- RO-HedgeHog.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level 'Hedgehog': Ukraine, 28th June 1944 <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 4C576C61 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free


Please help me I've been suffering this problem since I've installed RO and it's driving me Crazy! I've done most things recommended to repair the problem, deleting and re-DLing RO, nothing's worked.

The problem only happens when I am in game, not in the menus, and generally happens after a few minutes. Can't say for sure what starts it.

Thank you so much.
 

Attachments

  • Antagonist Minidump and log.zip
    28.1 KB · Views: 0

lu31605

FNG / Fresh Meat
Jun 20, 2006
472
3
0
31
In a tank
Yoshiro said:
I would actually complain more about the ram, not the graphics (and that is an odd ammount of ram)

Which fixes have you run through. This will give us a better idea on what to suggest.

well i have done the reinstalling red and steam. no luck
tryed deleteing the game files and then restarting steam and play..no luck

about the ram-
the computer brings 512 ram..i then install 256 more..=768.
but the onboard graphics card shares memory with the cpu meaning it takes 128 away..
equals 640..
btw im updateing red now hopefully that will be the anwser...:rolleyes:
 

lu31605

FNG / Fresh Meat
Jun 20, 2006
472
3
0
31
In a tank
nope...i still get the same thing everytime..
why did this game have to be soo complicated?
i think this is the last time i buy something from tipwire or whatever.
 

Yoshiro

Senior Community Manager
Staff member
Oct 10, 2005
13,329
4,054
113
Read the front page news (one down from the latest )
 

lu31605

FNG / Fresh Meat
Jun 20, 2006
472
3
0
31
In a tank
@Yoshiro

I have try everything i can to make the game work..
but nothing has happened..
I did the file thing that you sayed but it doesnt solve my problem..

ummm I am gonna put my other graphics card that was in my other computer (it ran it well and maybe the 6100 is wack or something) and see if i can play red..
until then...:)
 

Monkwarrior

FNG / Fresh Meat
Nov 21, 2005
1,144
2
0
lu31605 said:
o.....m....g..
it STILL DOESNT WORK!!!!!!!

ok im pretty screwed here soo im gonna stop trying..

Hey Lu, keep up your hopes :)
I have a final suggestion, it will take a lot of time, but sometimes windows is the cause. I suggest you reformat everything on your pc (backup the most important stuff first of course) and put a brand "new" version of windows on it. Upgrade it with all security patches and install the latest directX version too. Install all latest drivers of your hardware and install steam and RO again.

I know it's a lot of work, but if you really want to play this game: try it.
Your system will be fast again.

Make sure you know what you'r doing or ask a friend to help you with reinstalling. Don't forget to save your steamaccount data (loginname + password).

GL, Monk.
 

BoZZ

FNG / Fresh Meat
Mar 17, 2006
13
0
0
I like the fact that I submitted a post with my problem a week ago and no one has gotten back to me yet the new patch hasn't done anything for me Iam still crashing. :mad:
 

Yoshiro

Senior Community Manager
Staff member
Oct 10, 2005
13,329
4,054
113
For people with the C++ error. Please do the following. We now have several confirmed casses of this working.

Delete all RO content on the PC. Right click RO and delete local content in there, delete all RO folders in steam that aren't deleted. Delete any GFC's related to RO that are still around.

Delete all prefetch files related to RO can be found in C:Windows/Prefetch (they start with redorchestra).
Run a registry cleaner like Crap Cleaner to remove old reigstry keys (and clean up other crap on your computer. Make sure to select specific things that you wan't or you might loose something you are trying to save)

Use the new filesystem beta for Steam
Right click steam, go to propeties in target add after steam.exe" -clientbeta newfs –beta fs
Save

Run Steam
Redownload RO

Run RO through steam
 

father_obvious

FNG / Fresh Meat
Jun 6, 2006
6
0
0
ok...

ok...

Hope you didn't forget about me.... here's some more things i've noticed in trying to get RO to run...

As I mentioned earlier, in steam it will say "100% - Ready" in the my games list until I try to launch... then it says "download paused" for a few seconds before the splash screen. My other game does not do this.

Also... I tried to launch RO from ...steamapps/yourname/red orchestra/system/RedOrchestra.exe ...when I do that it says:"This application has failed to start because Steam.dll was not found." I CAN launch Day of Defeat by opening the HalfLife launcher from explorer... I don't know what that means, but it seems odd to me that DOD works, but RO can't find Steam.dll

I have re-installed RO twice now, and re-installed Steam with no luck. I hope I didn't waist my money. :(
 

Yoshiro

Senior Community Manager
Staff member
Oct 10, 2005
13,329
4,054
113
Father Obvious start a steam support ticket. Something is up with your steam and we can not correct that. Steam Support will have to help you. But you can try using our new file system as well and see if that helps.
 

BoZZ

FNG / Fresh Meat
Mar 17, 2006
13
0
0
Ok iam pissed I tried the new file system and Iam still crashing after like 5min of playing I will post my RO log file from the new file system and PRAY Tripwire WILL TAKE A LOOK AT IT. :p
 

Attachments

  • RedOrchestra.zip
    2.5 KB · Views: 0

lu31605

FNG / Fresh Meat
Jun 20, 2006
472
3
0
31
In a tank
Monkwarrior said:
Hey Lu, keep up your hopes :)
I have a final suggestion, it will take a lot of time, but sometimes windows is the cause. I suggest you reformat everything on your pc (backup the most important stuff first of course) and put a brand "new" version of windows on it. Upgrade it with all security patches and install the latest directX version too. Install all latest drivers of your hardware and install steam and RO again.

I know it's a lot of work, but if you really want to play this game: try it.
Your system will be fast again.

Make sure you know what you'r doing or ask a friend to help you with reinstalling. Don't forget to save your steamaccount data (loginname + password).

GL, Monk.

do you mean using the disc that restores the computer back to factory settings?
one question before i do it..
if i restore it back wont i lose every file/data in my computer?
i know theres a backup but like when its back to factory settings or w/e ....can i get the data thats in the backup and move it to my desktop?

meaning can i get the data from the backup directly into the factory settings computer?

if you dont understand i explain more..
 
Last edited:

Patch

FNG / Fresh Meat
Jun 26, 2006
1
0
0
I was having a BSOD everytime I ran Ostfront, I deleted my RO folder, the RO prefetch file in windows/prefetch and tried the new file system that was posted, and im happy to say that it has WORKED. Good job devs! :D
 

Yoshiro

Senior Community Manager
Staff member
Oct 10, 2005
13,329
4,054
113
I've uploaded all the latest logs and minidumps.
 
Status
Not open for further replies.