• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

For Poeple That Can't Start the Game - Part 2

Status
Not open for further replies.

father_obvious

FNG / Fresh Meat
Jun 6, 2006
6
0
0
well, I submitted a question to steam... we'll see what they have to say. I also tried the new file system... It still doesn't work, but hey, I get the Runtime error a lot quicker! ;)
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
If you get a runtime error, can you try a clean install of RO on the new file sytem? Removeing all traces of RO from your system (both old and new system) as well as running a registry cleaner like crap cleaner to clean up the prefetch and registry data (be careful about what you tell crap cleaner to clean). Then with steam still set to use the new file system, install RO.
 

lu31605

FNG / Fresh Meat
Jun 20, 2006
472
3
0
30
In a tank
YAYAYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYYY!!!!!!!!!!!!!!11
IM SOOO HAPPY!!!!!!11
IT WORKS!! IT WORKS!~!!
i did the system restore thing and now it works fine.
:) :) :) :) :) :) :) :D :D :D
 

charger

FNG / Fresh Meat
Jun 1, 2006
4
0
0
RO reboots my computer at the splash screen, no RO log file or RO minidump are being created.

heres a copy of the windows mini dump after reboot

Asus P4P800
P4 3.0
1024ram
ATI 800 pro

need any other system info?
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
Charger can you switch over to our beta file system?
 

Thyrker

FNG / Fresh Meat
Mar 28, 2006
14
0
0
Newfoundland
For the past few days I've been getting GPFs


Build RedOrchestra_Build_[2005-11-27_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 2090 MHz with 1023MB RAM
Video: RADEON X700 Series (6614)

General protection fault!

History: UModel::LineCheck <- CheckWithLevel <- ULevel::MultiLineCheck <- ULevel::SingleLineCheck <- LightVisibility <- GetRelevantLights <- RenderLevel <- RO-KrasnyiOktyabr.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Stalingrad, 29th September 1942: Krasnyi Oktyabr' Steelworks <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 4C576C61 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free
 

Attachments

[{Domino}]

FNG / Fresh Meat
Jul 4, 2006
21
0
0
34
NSW Australia
Im having a strange problem with red orchestra. Firstly I have had RO since it was realesed and have played for months and it worked fine. I then started to use the SDK and still worked fine. I went to play it 2 nights ago and it rebooted my PC it did the next time and time after that. I then fired up the SDK and ran it through the play button in the editor it worked but i decided to remove all local content in an effort to get it running without editor. I downloaded it and the SDK tried running it again and it rebooted but this time when windows started it verified game files by itself and all files in my RO folder are gone. Then I tried running it through the editor but it didnt work either I guess because of the lack of files. I was looking for my mididump folder in C:\windows but i do not have one. My other steam games work what should I do?
I didnt see a RO splash screen or any type of error message.

Pc Specs
AMD athlon
2gb ddr ram
Nivida 256mb 128 bit 6600
220gb hard drive space
1.5mb broadband plan
 
Last edited:

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
Have you tried with today's steam update?
 

[{Domino}]

FNG / Fresh Meat
Jul 4, 2006
21
0
0
34
NSW Australia
When it rebooted my computer it had the steam update icon in the tray then it did the verify game files thing i just removed local content again it is downloding now ill get back 2 u. Ohh congrats on the most exciting game ive played yet.
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
If you are doing a clean install, I might also suggest you delete your old prefetch data manually in C:windows/prefetch/stufstartingwith redorchestra.pf

or using a program called crapcleaner and have it remove old prefetch and registry data.
 

KiTchMe

FNG / Fresh Meat
Mar 5, 2006
27
0
0
AppName: redorchestra.exe ModName: wrap_oal.dll CRASH at Game's Main Menu

AppName: redorchestra.exe ModName: wrap_oal.dll CRASH at Game's Main Menu

I am having problems with starting the game. When I click on RO in steam client, it all starts how it should, I see screen splash (Tripwire) and I get the main menu. Now if I don't move the mouse, it takes anywhere between 5 and 15 seconds for me to get RedOrchestra.exe crash window. (I attached a snapshot of that window). Also, if I try to click on any of the options on the main menu, I instantly get the same error (RedOrchestra.exe crash) without any delay. I took a snapshot of that window as it wouldn't create any reports of the crash. I looked in the 'Temp' folder for the log report, but it never creates any.

Also, note that I've been playing ROO since day 1 and never had any problems until that last big update. I had one other time this error after the major ROO update (June 22 or so), and I thought that problem was with my USB headphones, since after I disconnected it never reappeared. But, after checking some sound options in Windows, I was able to use my headphones again (USB, Plantronics DSP 500) and my speakers through Audigy2 ZS card.

Now, after today's steam/ROO update, I couldn't get the game running. I've done file verification, and right now I am redownloading the whole game from steam. I haven't changed any drivers recently. There is a new driver for Nvidia card (9x.xx), but I heard that it causes problems, so I stuck with my trustworthy 84.21. Also, all other games run fine through steam.

So, I deleted RO local content, and then deleted common/RO/ folder and all remains of it in Registry (searched 'orchestra'). I also deleted Red Orch*.*... in Prefetch folder. I will let you know after it downloads if it solves the problem. Please let me know if you had others with the same problem and if you know how they've resolved it. Thanks so much for your help and for the greatest WWII game.

My computer: Xp Pro SP2, AMD64 3200+ Venice, Thermaltake 500 W PSU, Corsair Twinx3200C2 2x512 Mb (1Gig total), XFX 6800 GS XxX PCIe, 3 HDDs (2 int+1 ext, total >550 Gb), Audigy2 ZS, also USB standalone headphones+mic (Plantronics DSP 500 - used mostly for ROO), 3 megs connection. Thanks again. Attached RedOrchestra.exe error snapshot (sorry that's all of the info available).

EDIT: Just reinstalled the game after removing it and after cleaning out remaining registry lines and prefetch files, and it works like a charm now. I don't know what happened to it after last update, but I am happy again that I'm abale to play ROO. If you know what that error was, I'd still like to know in case it happens again. Thanks
 

Attachments

Last edited:

bart

FNG / Fresh Meat
Jul 3, 2006
4
0
0
BELGIUM ,
Hi guys , got a problem.
when I fire up RO everything goes fine , but when I want to join a server it just holds at" (enter IP address here)/index.rom"


hope u guys will have an answer :)


 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
wrong thread bart, but two things.

1) run in windows mode and see a firewall program is asking for RO to have permission to go through (and make sure the ports ro needs to run are open on that program)

or

2) make a copy of steam.dll out of the base steam folder and overwrite the steam.dll in the common/redorchestra/system folder.
 

huudoo

FNG / Fresh Meat
Jul 12, 2006
1
0
0
download paused

download paused

Hello, I uninstalled RO - DOD and Steam, did a reinstall on both RO Steam only , when i launch steam it logs in, I go to my games RO is their, 100% ready when i hit launch nuttin happins, then i get the download paused!, it worked fine 2 days ago.
i also went to local files - and verify integirity of game cache it completed @ 100% -- tried to re launch RO 100% ready , it says preparing to launch, then now game currently unavailable.
 

Tellerian

FNG / Fresh Meat
Jul 18, 2006
1
0
0
Runtime Error

Runtime Error

I recently had the runtime error as well. It reads:


Runtime Error!
Program: ...m\steamapps\common\red orchestra\RedOrchestra.exe


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


I googled it on the internet, and I came across the following forum post. The forum is located at URL: http://support.softartisans.com/kbview_577.aspx

==================================================
Error Explanation

This error is caused by a known bug in the Microsoft C++ compiler for .NET version 1.0.

Assemblies produced with this compiler do not properly handle the AppDomainUnload event. Essentially, when the AppDomain is reloaded, the unmanaged code still holds on to a reference to the previous AppDomain, and when calls are made into the unmanaged code, it fails since the AppDomain it is referencing is out of date. The AppDomain is reloaded whenever the app has to be jitted.

This issue is an acknowledged Microsoft problem when you are going from Unmanaged to Managed C++ code in .NET. Here is a Microsoft KB article that explains the issue in depth:

http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q309694

Resolution
  1. While running the 1.0 version of the framework, upgrade to package version 4.02 of FileUp (DLL version 4.0.2.0). Microsoft's recommended work-around has been implemented in this version of FileUp. Uninstall your current version of FileUp and upgrade to 4.02+.
======================================================

I started having the problem immediately after downloading a microsoft windows update.

I tried deleting the red orchestra folder and allowing steam to re-download it. It worked fine, ONCE. The second time I tried to run the game, I once again recieved the runtime error.

On the link included on the microsoft work-around page, I found a lot of programming gibberish. I am not a programmer. And since this "FileUp" program seems to be part of windows itself, I have no idea how to uninstall it. It's not like a regular program. Can anyone help me?

Tellerian Hawke
aka Colonel Hawke
Rough & Ready
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,393
3,505
113
First things first, read the Runtime error sticky in this forum as well as the known error/fix list. If those don't help you, please post a new thread.
 
Status
Not open for further replies.