• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Random Screen Pauses During Gameplay - Work Around

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,162
3,395
113
We've had several users complain recently about screen pauses during gameplay. This has been tracked down to the no longer in use Massive Ad system. It will be addressed in the next patch, but if this happens to you please use the following work around found by user Twyrix:

Add this lines to your hosts file (c:\WIndows\system32\drivers\etc\)

127.0.0.1 media.madserver.net
127.0.0.1 imp.madserver.net
127.0.0.1 ad.madserver.net
127.0.0.1 locate.madserver.net
 
  • Like
Reactions: masteriamamind

Woulfe

FNG / Fresh Meat
Jan 5, 2011
8
0
0
Or open notepad (or whatever text editor you use) in administrator mode and then navigate to the hosts file from within file>open and it should work too, just make sure when you click to save make sure it saves as all files and not a .txt file. If done correctly it should ask wether you want to overwrite or not (of course click yes).
 
Last edited:

sathenzar

FNG / Fresh Meat
Jul 5, 2011
137
0
0
does this refer to the lag? Where you are running and nothing happens for a few seconds?
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
Screen Pause is still killing me!

Screen Pause is still killing me!

I have tried this solution and many more and I still get the the random screen pause. I know the patch has come out to fix this problem, but that didnt work either.

I run an Intel Quad Core Q6700 with a Ati Radeon HD 6870 and have over 8 megs of ram on Windows Vista Ultimate 64. This is a Monolith that can play Crysis on Ultra and have 30-60 fps! From what I have seen on multiple forums 64-bit systems have this issue more often than 32-bit.
 

Luckz

FNG / Fresh Meat
Jul 31, 2007
81
23
0
I have tried this solution and many more and I still get the the random screen pause. I know the patch has come out to fix this problem, but that didnt work either.

I run an Intel Quad Core Q6700 with a Ati Radeon HD 6870 and have over 8 megs of ram on Windows Vista Ultimate 64. This is a Monolith that can play Crysis on Ultra and have 30-60 fps! From what I have seen on multiple forums 64-bit systems have this issue more often than 32-bit.
If you mean the lags every time a new enemy type is loaded, I presume that is due to the Christmas enemies. Your 'monolith' does not affect it.
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
The screen pause actually has been going on well over half a year for me, even before the christmas event, so there something going on in my version of killing floor that is making it do that.
 

shadowwill

FNG / Fresh Meat
Jun 14, 2007
535
78
0
Just thought id post in here, a few weeks ago i noticed these screen pauses in all games, perhaps 10-20 mins apart for about 2 seconds. I cant be sure but this might have started after i updated my ATI drivers. Out of curiosity, who here who is having this issue an ATI user?

Cheers
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
I have a similar problem you have, random screen pauses throught a multiplayer match, I started sitting in the middle of a room not moving becuase of this and play long range support.

I also use an ATI card HD 6870 and wonder if the drivers for this card are screwing up my game. I used to have a Readeon 4870 and it never lagged before, gonna update the card tonight, but I am not getting my hopes up for that fixing my problem.

Try uninstalling the drivers, if that doesnt work hope someone on here will fix the problem.
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
I also use an Ati card and this is the only game out of a closet full of modern and old pc games that does this to me. I use to have an older Ati card that worked fine with no pauses, so I dont know if it's the new hardware or software that is messing everything up. Try putting an old card in or get old driver, hope that idea helps.
 

Luckz

FNG / Fresh Meat
Jul 31, 2007
81
23
0
Even I use an ATI card, but for me the pauses happen when a "new" type of enemy is spawned the first time on that map.
 

Lady Serena Kitty

FNG / Fresh Meat
Dec 14, 2011
7
0
0
On Mac OS X and FreeBSD (which is what my KF servers run on) the hosts file is /etc/hosts

Unfortunately this system modification does not fix the pausing issue for me.
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
Sorry for double post, didnt know of the first one went through. It might be the same problem I have. Tried joining a listening server last night. I got less screen pauses then a dedicated server, but I still got then nonetheless. I hope there some kind of patch that just loads all the enemy types or something because I am really hating these pauses.
 

Blazkowicz

FNG / Fresh Meat
Dec 13, 2011
8
0
0
After playing quite a few more rounds I think my screen pauses are more then just lag and loading zeds.
I run 20-80 latency which runs very smooth and I also think zeds spawning in isnt the problem.
The screen pauses happens even when there is 1 zed left and even when there all dead and everyone is running to the trader!
I dont know why this problem is happening, but im Stuck Playing as Medic the whole time becuase the armor save my life when a screen pause warps me into a mob of zeds.
 

jimthorne73

FNG / Fresh Meat
Jan 5, 2012
1
0
0
new video card

new video card

today i installed a new radeon hd6790 video card from a radeon 4600.

now the game pauses might be what this post is abou but I need more detailed info on how to do the fix. Thank you
 

aphocus

FNG / Fresh Meat
Dec 17, 2011
19
0
0
List of things to try:

update soundcard drivers I believe onboard drivers with EAX enabled can be buggy specially when loading sounds off on disk, you can also try disabling EAX since onboard usually doesn't add any value to EAX (poor or non existant implementation of effects)

Clean out dust and crap in your GPU/CPU fans your system could be over heating, this fixed my 1s pause every few seconds as well as my flat mates computer.

make sure you have at least one case fan to pull the hot air out, newer 80plus power supplies have very low powered fans because they don't need it yet a fewer older cases require the PSU to extract air.

trivia: back in the day ('98~) the PSU was the only extraction fan needed/used
 

s1n905

FNG / Fresh Meat
Jul 15, 2012
1
0
0
Still happening

Still happening

The game used to run 100% fine. I forget when the patch was that made this occur. For me and a friend, it happens every start of a wave. Very rarely during.

I've tried different things, like stopping my anti-virus, but nothing has worked so far. Any news on if a patch is being worked for this. Love this game, but this bug is a little annoying (not enough to make me stop playing though :p)
 

vealck

FNG / Fresh Meat
Aug 19, 2009
2,836
233
0
First, I had these 'pauses' described here when I had NV GTX260 card. Game would literally freeze for 2-3 seconds and then resume to normal... often resulting in my death in game.

Now, for about a year I have GTX560... and it got even worse. Whole system system was freezing, I was getting a black screen with a sound loop, and PC didn't respond to anything, the only way was to hard reset it.

It became unbearable, as it statistically happened once per 1 hour of playing. Crash dump analysis told me that it were TDR (driver response time) errors. I spent many, many hours on system stability testing and researching TDR errors online. I was sure this is KF issue, as no other application gave similar errors, but searching this forums for 'black screen' or 'TDR' never got any relevant results. I was literally on the verge of buying another video card, as I play mostly in KF these days.

Without much hope, I accidentally stumbled upon this thread and gave it a try. No freezes for 3 days now, fingers crossed.

I dont get it, how even an advertisement server negotiation can halt main program loop, and create such critical errors? And how this never been hotfixed for over a year now? This bug gave me several gray hairs, I'm telling you.
 

vealck

FNG / Fresh Meat
Aug 19, 2009
2,836
233
0
Okay, it worked like a charm since my last post, and today it's back, with a vengeance. What happened? Any other IP's I should block to be able to play the damn game without crashing every hour?