• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

KF Doom I / II

NeedlesKane

FNG / Fresh Meat
Jan 18, 2012
151
1
0
Big D
Actually I am not alt+tabbing at all. I set up the vote configuration to handle everything that I wanted to select maps and mutators-wise. I am thinking about redoing my KF.ini file from scratch to see if I have any problems with this, WTF mod, or any other mutators. If not, then I will continue to add a little bit here and there until I hopefully figure out what the problem is. I hope that I don't have the problems right away with a fresh ini file. Anyway, I think that is a good place to begin.
 

Marco

Active member
May 23, 2009
644
230
43
Finland
I am not sure why, but when I run my server and play the game with this mutator I always crash, but that is not the case for everyone else who is connected.

Here is my Critical Error message:

Spoiler!


One strange thing that stands out to me immediately is that it says that I have 4095MB RAM, but I have 8GB. I am running 2 servers on my system while playing the game which keeps me close to 4GB of memory usage.
That sound crash is an old Engine bug for specific sound quality... From what I understand the crash is triggered by "LowQualitySound" option, so go to KillingFloor.ini and make sure it is False:
[ALAudio.ALAudioSubsystem]
...
LowQualitySound=False
As for the memory, Killing Floor is a 32-bit application, thus it can only use 4 GB of memory at the max.
 
Last edited:

NeedlesKane

FNG / Fresh Meat
Jan 18, 2012
151
1
0
Big D
That sound crash is an old Engine bug for specific sound quality... From what I understand the crash is triggered by "LowQualitySound" option, so go to KillingFloor.ini and make sure it is False
I checked my KillingFloor.ini file in my Steam\steamapps\common\killingfloor\System directory, and it was already set to "False" for "LowQualitySound." Thanks for the recommendation.
 

NeedlesKane

FNG / Fresh Meat
Jan 18, 2012
151
1
0
Big D
I had not really played the game for a while, and I just played it again. I tried the mutator again, and it worked. I realized that the one map it had trouble with was KF-Doom2-Final-V7.rom. It works with all of the other maps I have tested. In fact, I was having problems with WTF mut as well... because I only tested it on KF-Doom2-Final-V7.rom. I feel pretty bad about that. haha

Actually it wasn't even the map that caused the problem after all. After further troubleshooting it was the Server Side Perks v5.10 that was causing the problem for me.
 
Last edited:

Wolf619

FNG / Fresh Meat
Jul 13, 2012
3
0
0
in a cave
installation problems

installation problems

Ok so i put everything were its supposed to go according to the directions. I do not see the maps in the game under map list i do have the modifiers for doom weapons and monsters. I have both mutators on but in game i only get the doom guns the monsters stay as the summer sideshow monsters. Is this to do with the summer sideshow event? i read somewhere that you are unable to change monsters until the event ends? do i have to wait for the end of the event? any idea why the levels wouldnt be showing up?
 

Cowguy666

FNG / Fresh Meat
Dec 21, 2011
36
0
0
Sorry for the Necro-bump

Sorry for the Necro-bump

Sorry for necrobumping but i found out it crashes around map 3 if you dont start it up using Open KF-BeginDoom?Game=DoomPawnsKF.DoomGameType
In solo, in multiplayer i get a GPF as soon as i try and load the map using the webadmin Doom singleplayer gametype with doom weapons and doom monsters muts on. any help please? Ty