• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

How to run Red Orchestra when logged on as a user with the limited account type.

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
Problem:

When running Red Orchestra as a user with the limited account type, I get the "Steam - Error This game is currently unavailable. Please try again at another time."

Explanation:

Red Orchestra needs a device driver called Steamdvr.sys to read gcf files. When you run Red Orchestra by say double clicking the Red Orchestra icon, steam.exe loads Steamdvr.sys by calling the function OpenSCManager. The OpenSCManager function requires the calling process in this case, steam.exe, to be running with administrator privileges. If not, the OpenSCManager function will fail and Steamdvr.sys will fail to load too.

Solution:

You will need to edit your registry. But first you need to backup your registry. Please refer to this link http://support.microsoft.com/default.aspx?scid=kb;en-us;Q322756 for information on how to backup and edit your registry. Note: You need to have administrative privileges to edit the registry successfully.
  1. Locate the following subkey in the registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\STEAMDVR.
  2. In the right pane of the Registry Editor window, double-click Start.
  3. In the Value data box, type 2, and then click OK. Note: Start key can have a value of 0 (Boot), 1 (System), 2 (Auto), 3 (Manual) and 4 (Disabled).
  4. Quit Registry Editor.
  5. Reboot computer.
 
Last edited:

SkunK

FNG / Fresh Meat
Mar 14, 2006
29
0
0
THAT solved my problem. Thank you! :) And moderators, please put this thread in the stickies. :rolleyes:
 

Rah!

FNG / Fresh Meat
Mar 25, 2006
19
0
0
Kamikaze, I went into the registry, and found
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
but there's no STEAMDVR in there...that can't be right can it?
 

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
If it is not there, it means you have not yet run Red Orchestra successfully. You must run Red Orchestra successfully at least once to enable Steam to update the registry and write the information for the Steamdvr.sys device driver. Only then will you be able to see it and edit it.

Run Red Orchestra as an admin. Then edit the registry. Next time you run Red Orchestra you don't need to be admin because Steamdvr.sys already gets loaded at boot time.
 
Last edited:

|:CNTZ:|V|Sharon Osbourne

FNG / Fresh Meat
Mar 27, 2006
5
0
0
I had not run RO successfully at all. Yet that STEAMDVR was there.:confused:

I did as suggested and changed the value from 3 to 2 and exited. Tried to run RO. Same error. Game unavailable, try later. :(

I Ctrl+Alt+Del to task Manager and shut down the Redochestra.exe process again.
I shut steam down, then re-launched steam and had another go at launching RO. Success.

I appreciate your help.
Thanks.
Not so hot under the frock now.:)
 

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
The "Steam - Error This game is currently unavailable. Please try again at another time." is a general error that is caused by many things as this link will attest http://support.steampowered.com/cgi-bin/steampowered.cfg/php/enduser/std_adp.php?p_faqid=80&p_created=1092609531&p_sid=JVSN7C3i&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MjYwJnBfcHJvZHM9MCZwX2NhdHM9MCZwX3B2PSZwX2N2PSZwX3NlYXJjaF90eXBlPWFuc3dlcnMuc2VhcmNoX25sJnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9Z2FtZSB1bmF2YWlsYWJsZQ**&p_li=&p_topview=1. I only found out that in my case this error was caused by Steamdvr.sys when I configured my computers for kernel-mode debugging.
 

Rah!

FNG / Fresh Meat
Mar 25, 2006
19
0
0
kAMIKAZE said:
Run Red Orchestra as an admin. Then edit the registry. Next time you run Red Orchestra you don't need to be admin because Steamdvr.sys already gets loaded at boot time.
I'm already an administrator, and I still can't run the game unfortunately. I created a second administrator account just to see if it would work, and it didn't.

I went through the potential problems on the Steam website:

I have a Linksys wireless router, which supposedly has trouble with Steam, but I get the same results whether going through that, or connecting directly to my modem.

I'm pretty sure I don't have a firewall up. I checked my internet connections, and the windows firewall is off.
I have Norton Antivirus installed, but I don't think it has a firewall included. I disabled Norton anyways though, just to be sure.

I renamed clientregistry.blob to ~clientregistry.blob, which caused steam to update, confirming that I in fact have no firewall up.

I checked, and found that all my ports are open. (i'm pretty sure I did that right)

I ran Spybot and Ad-aware, getting rid of all spyware and crap that was loaded up on my computer.

I have enough diskspace.

I've varified my files over and over.

I reinstalled Red Orchestra.

I don't have windowblinds or Zone Alarm, and no files are marked read-only.

In short, I don't appear to have any (as of yet) known thing conflicting with Red Orchestra. Maybe I'll just have to wait for a patch or something:(
 

Mister-T

FNG / Fresh Meat
Mar 28, 2006
2
0
0
Very usefull, I will try this later.
But there is another method that I use. It's tricky but that work fine for me

1) launch your computer and use an admin session
2) launch steam then RO
3) close RO, Steam, and your admin session
4) Open you limited user account, steam
5) RO should launch

This trick will work until you restart your computer
 

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
The default is Steam.exe manually loads Steamdvr.sys. Manual loading of device drivers requires admin privileges. Once a device driver is loaded it stays loaded in memory even if you logoff. The only way to purge the device driver from memory is to reboot. What we're trying to do here is to change the way the device driver gets loaded from manual to auto. Meaning once we bootup the computer the device driver is loaded in memory already so it doesn't matter if we login as admin or not because Steam.exe will no longer load Steamdvr.sys since it it loaded already. End result we don't need to be admin anymore to play the game.
 

SkunK

FNG / Fresh Meat
Mar 14, 2006
29
0
0
Mister-T said:
Very usefull, I will try this later.
But there is another method that I use. It's tricky but that work fine for me

1) launch your computer and use an admin session
2) launch steam then RO
3) close RO, Steam, and your admin session
4) Open you limited user account, steam
5) RO should launch

This trick will work until you restart your computer
Or, you could have created a RO shortcut on your desktop, Shift+Right-click on the RO icon and choose Run As to run the program as Administrator instead of going to the trouble of openning two sessions. But I still prefer Kamikaze's solution.
 

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
Hi Rah!,

I just want to make sure are you still getting the "Steam - Error This game is currently unavailable..."?

Inorder for me to help you I need you to do me a favor. Try to run the game again. When the "Steam - Error This game is currently unavailable..." appears, note the date and time you tried to run the game and open Windows Explorer. Navigate to C:\Program Files\Steam. Inside the Steam folder look for the MDMP file type whose date modified attribute matches the date and time you tried to run the game. Post it here.
 

Rah!

FNG / Fresh Meat
Mar 25, 2006
19
0
0
hey, thanks for all the help kAMIKAZE.

Yes, i am still getting the unavailable error, unfortunately, but hopefully I'll get to the bottom of this.

Here's that mdmp file.
 

Attachments

Mister-T

FNG / Fresh Meat
Mar 28, 2006
2
0
0
I do the change and the registry modification work perfectly for me. Thanks for the help !

BTW Launching steam under LUA with Run As Admin... make RO crash. ( I have a Visual C++ error exception or something like that)

But I didn't tried with a shortcut and run as.
 

kAMIKAZE

FNG / Fresh Meat
Mar 16, 2006
165
0
0
Hi Rah!,

According to the mdmp dump file you posted, you are getting the Steam error because Steamdvr.sys failed to load. I can only think of three things why this would happen.
  1. You're not logged on to Windows as an Administrator.
  2. Your copy of Steamdvr.sys is corrupt.
  3. You are missing the Steamdvr.sys file. Note: There are two versions of the file. The 32 bit version located in C:\Program Files\Steam\bin\x86 and the 64 bit version located in C:\Program Files\Steam\bin\x64.
Edit:

4. Conflict with another application (e.g. Norton Antivirus). (Courtesy of Rah!)
 
Last edited:

Rah!

FNG / Fresh Meat
Mar 25, 2006
19
0
0
I have both the SteamDvr.sys files, so i guess one or both of them is corrupted? Would I have to reinstall Steam, or can I just replace those two files?
 

Rah!

FNG / Fresh Meat
Mar 25, 2006
19
0
0
Well, the problem turned out to be Norton Antivirus, which I just uninstalled (Don't know why I didn't do that to begin with). The game starts now, but then...surprise!
...I get another error. Hopefully this one will be easier to take care of.

edit: wait, the problem's fixed now, and the game works! now its time for some fun...
 
Last edited: