Crash on change to 1920x1080 resolution

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Sickboy

FNG / Fresh Meat
May 14, 2009
7
0
0
Build KillingFloor_Build_[2009-02-09_10.82]

OS: Windows NT 6.0 (Build: 6001)
CPU: GenuineIntel PentiumPro-class processor @ 3178 MHz with 2047MB RAM
Video: ATI Radeon HD 4800 Series (647)

Error setting display mode: CreateDevice failed (80004005). Please delete your KillingFloor.ini file if this error prevents you from starting the game.

History: UD3D9RenderDevice::UnSetRes <- CreateDevice <- UD3D9RenderDevice::SetRes <- UWindowsViewport::Exec <- APlayerController::execConsoleCommand <- (UT2K4VideoChangeOK Package.UT2K4VideoChangeOK @ Function GUI2K4.UT2K4VideoChangeOK.ChangeResolution : 02AF) <- UObject::execDelegateFunction <- (moComboBox Package.moComboBox @ Function XInterface.GUIMenuOption.InternalOnChange : 0035) <- UObject::execDelegateFunction <- (GUIComboBox Package.GUIComboBox @ Function XInterface.GUIComboBox.TextChanged : 0055) <- UObject::execDelegateFunction <- (GUIEditBox Package.GUIEditBox @ Function XInterface.GUIEditBox.TextChanged : 000B) <- UObject::execDelegateFunction <- (GUIList Package.GUIList @ Function XInterface.GUIListBase.IndexChanged : 0018) <- UObject::processEvent <- (GUIComboBox Package.GUIComboBox, Function XInterface.GUIComboBox.InternalListClick) <- UObject::processDelegate <- UGUIComponent::MouseReleased <- (GUIList Package.GUIList) <- UGUIController::MouseReleased <- UGUIController::NativeKeyEvent::LeftMouseClick <- UGUIController::NativeKeyEvent <- UInteractionMaster::MasterProcessKeyEvent <- UEngine::InputEvent <- UWindowsViewport::CauseInputEvent <- UWindowsViewport::UpdateInput <- UViewport::ReadInput <- APlayerController::Tick <- TickAllActors <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 4C576C61 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

I run all games in 1920x1080, this is the first I've had issues with. All other tested resolutions are fine and work beautifully (and the game is fantastic, by the way), but this issue is bugging me.

I use Vista 32bit, fully updated.

To replicate error:

Start application
Go to settings
Change resolution to 1920x1080
Change will cause screen to go black, which then normally changes back to the menu, but instead it crashes.

Tried manually adjusting the resolution with the console command, same outcome.


Comp specs are:

OS: Vista Home Premium (32bit) Service Pack 1 (totally updated)
CPU: Intel Core 2 Duo E8500, @3.16 3.16 (factory settings, no oc)
GPU: ATI HD4850 (latest catalyst drivers, v9.4, no custom settings, no oc)
RAM: 4gb (no oc)
 
Last edited:

Peter.Steele

FNG / Fresh Meat
Sep 6, 2006
2,128
779
0
Chambers of the Grand Council
Same thing here.


I can change - briefly - to 1920x1080 while still in the menu screen, but then when I attempt to back out and go into the game, it goes black. Alt-Tab to quit, restart game ... and it's still black once I get past the splash screen.



Vista Ultimate x64
AMD x4 9840 @ 2.7 gHz
Radeon 4870
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,947
3,879
113
Deleting your killingfloor.ini file should reset your resolutions. Let me check that resolution. I currently run on an HD tv myself.

Edit: I have no problem at that resolution. But I am using Xp. Will see if somebody with a vista machine can replicate.
 

Sickboy

FNG / Fresh Meat
May 14, 2009
7
0
0
Deleting your killingfloor.ini file should reset your resolutions. Let me check that resolution. I currently run on an HD tv myself.

Edit: I have no problem at that resolution. But I am using Xp. Will see if somebody with a vista machine can replicate.


Deleting the file didn't do anything. Still crashes on the change, and when I reload the application it goes back to using whatever I had it saved to *prior* to trying to change to 1920x1080.
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
32
Falmouth UK
that error happends when you try to run that res at an unsupported refreshrate. Make sure you set in the ini file the refreshrate the same as your desktop refreshrate otherwise you get that error.
 

herostyle

FNG / Fresh Meat
May 14, 2009
4
0
0
Deleting your killingfloor.ini file should reset your resolutions. Let me check that resolution. I currently run on an HD tv myself.

Edit: I have no problem at that resolution. But I am using Xp. Will see if somebody with a vista machine can replicate.

I'm currently running Windows 7 RC1 and play in 1920x1080. I can't verify for Vista right now, but I wanted to put that out there.
 

Sickboy

FNG / Fresh Meat
May 14, 2009
7
0
0
Doing all of what was suggested only causes further errors:

Build KillingFloor_Build_[2009-02-09_10.82]

OS: Windows NT 6.0 (Build: 6001)
CPU: GenuineIntel PentiumPro-class processor @ 3177 MHz with 2047MB RAM
Video: ATI Radeon HD 4800 Series (647)

Error setting display mode: CreateDevice failed (80004005). Please delete your KillingFloor.ini file if this error prevents you from starting the game.

History: UD3D9RenderDevice::UnSetRes <- CreateDevice <- UD3D9RenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

I've tried changing the refresh rate (which I shouldn't have needed), I've tried enabling the override. The error above shows up if I attempt to manually change the resolution withing the ini file, and it occurs after the very VERY beginning mini-splash that says "Killing Floor" on it prior to the app going fullscreen.
 

Sickboy

FNG / Fresh Meat
May 14, 2009
7
0
0
Stealth edited in my settings in OP.

Comp specs are:

OS: Vista Home Premium (32bit) Service Pack 1 (totally updated)
CPU: Intel Core 2 Duo E8500, @3.16 3.16 (factory settings, no oc)
GPU: ATI HD4850 (latest catalyst drivers, v9.4, no custom settings, no oc)
RAM: 4gb (no oc)

I tried reinstalling my graphics drivers, no luck there either. Refresh is at 60, but even changing to 75 doesn't do anything. I can run both fine at other resolutions, it's just the 1920x1080 that's giving me flak. I run all my other games at that setting with no problem (TF2, L4D, CoD4, M&B, Fallout 3, DoW2, Garry's Mod, Bioshock, UT3, EVE, etc etc.)
 

Razza

FNG / Fresh Meat
Jun 9, 2009
1
0
0
ok, i've solved it! my windows update has just downloaded the monitor driver(i have samsung so it's called samsung2243 update) and it worked for me!
so here is the deal - click to update your windows and install ALL the updates (neccesary and not neccesary)
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
32
Falmouth UK
Sick boy for that last error try deleting your entire killingfloor system folder and verifying the game cache on steam.