• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Playing Ostfront using Cedega on Linux

Cabbage

FNG / Fresh Meat
Nov 20, 2006
1
0
0
I had RO running perfectly through cedega up until I updated my ati drivers to the latest 8.31.5...(I believe I was running the 8.28.x drivers before the update) Now it lags ferociously before locking up my whole system if I don't close out of it after a few moments. I am running Ubuntu Edgy 6.10. Just wondering if anyone else has had problems with these drivers.
as far as I can tell, the problem only occurs in RO, warcraft 3 runs flawlessly through cedega, as it had before my driver upgrade.
(my card is a 9600xt btw)

edit-I fixed it (deleted my system dir and re-downloaded it) :rolleyes:
 
Last edited:

cornes

FNG / Fresh Meat
Mar 9, 2006
35
0
0
Works fine in Mandriva 2007, Powerpack version includes a full Cedega 2.5.6.


.
 

[WOLF]Biskit

FNG / Fresh Meat
Mar 15, 2006
28
0
0
Cedega and RO open gl mode flashing mouse cursor.

Cedega and RO open gl mode flashing mouse cursor.

Running Cedega and RO on ubuntu linux open gl mode , it runs fine except i get a flashing mouse curser in the middle of the screen.
Does anyone know how to get of it ? I saw a solution some where but cant remember where.
 

blitze

FNG / Fresh Meat
Nov 23, 2005
194
6
0
Running Cedega and RO on ubuntu linux open gl mode , it runs fine except i get a flashing mouse curser in the middle of the screen.
Does anyone know how to get of it ? I saw a solution some where but cant remember where.
I had that with RO and WINE.

Now run RO under Cedega with GL 1.4 setting and DirectX 9 ingame. Looks as great as under Windows with Blur and HDR Bloom. Run it at 1024 x 768 on my 17" LCD just fine.

Ubuntu Feisty 64 Testing
Nvida 7600GT :D
 

Borat

FNG / Fresh Meat
Nov 21, 2005
127
0
0
Co. Antrim, Ireland
ez25.org.uk
I am having a new problem with both WINE and Cedega since upgrading my hardware:

was - AMD 3200, GF6800GT
now - Core2Duo, GF7950GT

Now, both Cedega and WINE refuse to capture the mouse. The game plays brilliantly but the damn mouse refuses in BOTH programs, to remain in the game window. I even tried downloading Codeweavers Crossover but it suffers from the mouse-stuck-in-the-middle problem. Any ideas?
 

Fu. Svedberg

FNG / Fresh Meat
Nov 21, 2005
1,413
16
0
Sweden
Ok I have to ask has anyone here tried to run Windows under VMWare and if so how did RO work?

(maybe a way out of the dual boot mess)
 

Borat

FNG / Fresh Meat
Nov 21, 2005
127
0
0
Co. Antrim, Ireland
ez25.org.uk
WOW Sved, nice to see you're following the path of the wise men and going for Linux :p

Well, back to my question ;) anyone either experienced this mouse problem or found a solution for it?
 

LordKhaine

FNG / Fresh Meat
Dec 19, 2005
1,008
120
0
UK
As far as I know, VMware doesn't support 3D acceleration at all.
VMWare server doesn't support it. I think there may be experimental support in Player though? Regardless, performance would be awful running it in VMWare anyway.

As for myself. I setup RO and Steam using the latest Wine. No problems a quick search didn't fix. Only problem is RO is running shockingly bad (unplayable, I'd guess about 2fps at most with distorted sound). So I guess I have some tweaks left to do.
 

Fu. Svedberg

FNG / Fresh Meat
Nov 21, 2005
1,413
16
0
Sweden
WOW Sved, nice to see you're following the path of the wise men and going for Linux :p

I've been using Linux on and off for many years Borat it's just that I have had a ATi card for most of the time (back to ATi again after my Nvidia burned (no OC at all on it >.< )) buy it's not untill now I consider it as a viable option after Ubuntu brought extreme ease of use to it.

Oh and yeah sorry for the stupid question I selectivly decided to skip the line that clearly says "VMWare currently does not support heavy 3D acc." >.<
 

LordKhaine

FNG / Fresh Meat
Dec 19, 2005
1,008
120
0
UK
Well I can't seem to fix performance in RO under Wine. Running the latest Wine, on Ubuntu 6.06. The Steam installation worked fine, and the installation of RO also worked fine. The game starts fine.. but that's when things go downhill. Performance ingame is awful, as in literally 1-2fps displayed using stat fps. This happens both in D3D and OpenGL. I'm at a loss as to what to tweak. I'm pretty certain the problem lies with Wine running RO, and not the Steam client itself. I've tried a few different OS's under Wine, no change. Also tried some of the various video/audio options in Wine.

Any ideas regarding RO ini tweaks or Wine settings?
 

mat69

FNG / Fresh Meat
Aug 1, 2006
826
0
0
Do you actually have the correct drivers installed (nvidia, or ATI drivers)? Otherwise you'r 3D acceleration ****s for sure.
 

/linuX/gitano

FNG / Fresh Meat
Nov 22, 2005
316
3
0
germany
Heyho,

Finally gave it a try again with the latest wine (0.9.33), and it seems to work.

Setup:

- gentoo with e17 wm (turn off the autoscroll virtual desktop feature by mouse if u you're using this wm)
- wine 0.9.33
- latest nvidia drivers (1.0.9755)
- usual settings in the RedOrchestra.ini (OpenGL render etc.)
- in winecfg, disable "allow windowmanager to control windows", if u want a fullscreen without borders

What works:
- roost starts in fullscreen mode, mouse/ kbd is recognized, connects to servers, lets u join 'em, lets u play :D

What does not work:
- all the OpenGL issues mentioned before (white menus, no Gamma etc.)
- on some servers it just wont load the map...dunno what this is, maybe some mutator stuff
- sound sometimes is messing around, got some kinda stuttering echo of the menu sounds etc, cheap fix: changing Configuration->Audio->"audio mode" to another one and back to the default one fixes this.

Seems quite usable, allthough not very stable, at least for me.
Map loading takes some time, dont have to forget i'm running pretty old hardware. Frames seem to be the same i have on my windoze roost installation.

Post your experiences.

greetz,
gitano
 
Last edited:

billrad

FNG / Fresh Meat
Feb 15, 2007
3
0
0
I am runnung Steam / red orchestra under cedega, and it works great. It never misses a beat, runs pretty much as good as in windows.

Even with an unedited redorchestra.ini, it ran well.

One issue though, I cannot get the mic to work ingame. It works fine in Ubuntu 6.10 edgy, and records fine (onboard AC97 chip) and it seems to try to work in the game (I can hear it dampen other sounds) , but I cannot ever get an answer.

Anyone have their mic working ingame? Anyone care to share their settings?

thanks

Bill
 
Last edited:

BobCobb

FNG / Fresh Meat
Mar 24, 2006
289
0
0
I am getting a critical error when trying to run RO through cedega. Any ideas?

Code:
 Build RedOrchestra_Build_[2005-11-27_10.48]

OS: Windows 98 4.10 (Build: 67766223)
CPU: AuthenticAMD Unknown processor @ 2653 MHz with 2027MB RAM
Video: No Video

Failed to enter Entry: Can't find file 'Entry'

History: UGameEngine::Init <- InitEngine <- FMallocWindows::Free
I installed cedega specifically to play RO, so I don't have much experience with it. Steam runs ok, and updated RO. Before you ask, direct rendering is enabled in linux, and appears to run in cedega.
 

PUTZ

FNG / Fresh Meat
Nov 21, 2005
4,564
634
0
Baltimore, MD, USA
...it runs fine except i get a flashing mouse curser in the middle of the screen.
Does anyone know how to get of it ? I saw a solution some where but cant remember where.


I'm getting this bug in Windows. I swear my computer has esp, I was thinking about it after reading this thread earlier yesterday afternoon, then last evening, is started happening. wth?
 

billrad

FNG / Fresh Meat
Feb 15, 2007
3
0
0
BobCobb,

how are you starting RO?

I go to Cedega, select steam, and run that. I run RO from inside it.

I don't run RO directly from Cedega.

a longshot I know, but thought I'd mention it.


Bill
 

blitze

FNG / Fresh Meat
Nov 23, 2005
194
6
0
WINE 0.97 plays well but stil has mouse capture issues that hamper play.

I find WINE handles Steam better than Cedega and Direct3D under WINE seems fine, some little anomolies with rendering the odd texture but nothing smashing the game visuals.

Wish we could get the WINE devs to pay attention to the mouse capture issues but they have ignored it for quite a while.
 

Borat

FNG / Fresh Meat
Nov 21, 2005
127
0
0
Co. Antrim, Ireland
ez25.org.uk
Agreed. I can play the game just fine with WINE but as you say, it has problems with mouse capture (in that it doesn't capture it). The same thing happens in Cedega also (for me).

It's kinda weird because it used to work fine in both (albeit with a large performance hit). I wonder was there a recent update that has caused this mouse capture problem?

If only we could play this game without Steam (or get a native Steam client).
 

blitze

FNG / Fresh Meat
Nov 23, 2005
194
6
0
HAve to say I don't have mouse capture issues in Cedega. WINE on the other hand ain't that great but I have not used recent builds.

Would really like native clients for Linux of this but, hmm, looks like I'm dreaming. Don't suffer any slowdowns and it plays as well if not better under Linux/Cedega as it does on Vista x64. Oneday game developers will wake up and realise that Windows is what holds peoples hardware back and move away from the PoS OS that has been forced onto us.