• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Killing Floor Slow Loading Screens - FIXED

SniperJunkie

FNG / Fresh Meat
I hope this helps as I signed up just to help others!!!

Dead simple on my 2 PC's & my friends PC...

Right-Click
"C:\Program Files (x86)\Steam\steamapps\common\killingfloor\System\killingfloor.exe"
Select Properties / Compatibility Tab
Tick "Run this program in Compatibility mode for:"
Select "Windows XP (Service Pack 3)" in the Drop-Down Menu
Tick "Run this program as an administrator"
Click Apply
Click OK

This solution worked on 3 PC's...


1st Machine
Windows Vista Ultimate (x64)
Pentium Celeron 2.4Ghz
4GB Ram
160GB Seagate HDD


2nd Machine
Windows Vista Home Premium (x86)
AMD Athlon64 3200+ 2.8Ghz OC
2GB Ram
80GB Maxtor HDD


3rd Machine
Windows 7 Ultimate (x64)
AMD Athlon64 X2 6000+ 3.1Ghz
4GB Ram
500GB Maxtor HDD
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,162
3,395
113
If anybody else could try this and say if it worked for them or not while posting their specs, that would be great.
 

mamoo

FNG / Fresh Meat
Jun 19, 2009
2,466
542
0
27
East Sussex, England
Didn't work for me, I just got this message:
Build UT2004_Build_[2004-11-11_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel PentiumPro-class processor @ 2093 MHz with 1023MB RAM
Video: Mobile Intel(R) 4 Series Express Chipset Family (1883)

General protection fault!

History: CheckTag <- LoadSummary <- ULinkerLoad::ULinkerLoad <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

Computer specs:
Windows 7 64 bit OS
Pentium dual core T4300 2.10GHz processor
4GB RAM
Mobile Intel 4-series chipset graphics
 

Maronji

FNG / Fresh Meat
May 22, 2009
17
0
0
I personally haven't tried the above suggested fix, but I did try something else that has had some success (I say some because I've only tested it in a limited manner, so to speak). I'm not sure if it's necessary to do it after each wave (probably would be to have the best results), but after remembering a suggestion someone else in another thread said to try (can't remember which thread), I decided to do a little test.

Originally, my test was going to see if a vanilla System folder was going to work. For this, I verified using the Atlanta content server. No dice. So I tried the files linked in another one of the threads. I don't hang at the connecting screen much (haven't tested it much), but still no dice.

Then, today, I decided to mess with my cache settings. I set it to the recommended amount (in my case, the maximum recommended amount since I have 4GB of memory). That didn't work. Of course, I had a bit of fun testing it anyway since I turned on cheats and played some solo to pass the time (with enough practice, it could be a viable way to attempt to invent strategies for certain maps or weapon usage; needs more testing, though).

Then, I remembered about another thread I read the other day. Something about using "obj garbage" after visiting the trader or something. I decided to use that in tandem with the "flush" command after every wave (though after a point, I stopped visiting the trader because, like I mentioned above, I had cheats on to make it a little easier to pass the time), and after I took down the Patriarch, lo and behold, the next map loaded like a charm. I have not disabled my pagefile or any other possible fixes that I didn't already mention before this worked.

This requires some more testing, of course, but I think I might be on to something.

On an unrelated note, on my first initial test today (setting cachesize and changing one precache setting), when I made it to the Patriarch (BioticsLab), I went into the U-room and welded the door next to the trader, waiting around a corner on the other side. The Patriarch spawned, and he appeared to be on the floor above, next to the other trader. To my surprise, however, no more than three to five seconds later, despite not even moving in the right direction to reach my location, I hear something banging on my welded door. I poke my head outside, and sure enough, there he was, banging on my door with rockets. Now, mind you, this is the first time I've seen this happen, but it was pretty screwy nonetheless. I just thought I'd mention it in case it gets to be a problem sometime later or maybe to try to get a few laughs out of it.

EDIT 1: Just ran another test (BioticsLab through Manor (was too tired to play Manor though)) with some help from my brother (console cheats are disabled in multi-player; bummer). For best results, doing a flush/obj garbage combo between each wave is recommended. The longer you wait, the longer obj garbage takes (haven't tried either by themselves yet; trying that tomorrow). This is especially important if you don't want to lag out or are hosting a listen server. Anyway, it's working for both myself and my brother, so I think I'm on to something here.

EDIT 2: Getting ready for my second batch of tests. Thinking about making my own thread with my findings, though. We'll see once I get started.
 
Last edited:

zYnthetic

FNG / Fresh Meat
Mar 20, 2009
1,077
171
0
Atlanta-ish
www.zynthetic.com
Running in compatibility for XP if you're running XP obviously isn't a resolution.
I would also suggest testing before posting. This fix doesn't stand up to running several consecutive games.
 

Avenger256

FNG / Fresh Meat
Jun 25, 2010
3
0
0
I tried this, and on any server i tried to join i got the message. "An Unknown Steam error has stopped you from connecting." Or something along those lines.

Windows Vista x64
Quad core 2.5ghz
4GB RAM
nVidia GT230
1 TB Hard Drive.
 

sharpp

FNG / Fresh Meat
May 29, 2010
9
0
0
i have with my notebook no load problem i have always load times under 1 minute.

w7 ultimate N(europe version)
Intel Core i7-980X Extreme Edition
6GB RAM
GeForce GTX 480M
 

broli95

FNG / Fresh Meat
May 26, 2011
5
0
0
Servers download is very slow and i don't have glados!! WHY??? i have the old trader(i ve bought the game today)
 

Jonzo

FNG / Fresh Meat
Jul 7, 2011
3
0
0
after doing what the thread told me i moved up from simple killingfloor.exe is not responding to
critical errors and run time errors
which sucks because all i want to do it play the game ever since this new update its be screwing up for me

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows NT 6.0 (Build: 6002)
CPU: GenuineIntel PentiumPro-class processor @ 2528 MHz with 2047MB RAM
Video: No Video

General protection fault!

History: FMallocWindows::Free <- FMallocWindows::Free
 
Last edited:

aphocus

FNG / Fresh Meat
Dec 17, 2011
19
0
0
people should really avoid running as admin at all costs.

XP runs apps by default as admin and Unix/Linux hasn't defaulted to using admin since the 80's.

there's a reason they don't run as admin on Vista and 7.

Just think what would happen if someone wrote a malicious mutator that deleted windows/system32?

consider instead making sure you have write permissions to your entire Steam folder this may in fact help people that still having trouble as well since all the files could be set to read-only even for an admin.