Can't run hldsupdatetool.bin

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Phlex

FNG / Fresh Meat
May 20, 2009
13
0
0
I am rather new to Linux and I've just installed Ubuntu 9.04 on my notebook. I've created kfserver directory in my home directory. /home/username/kfserver/

I've downloaded the file hldsupdatetool.bin in the /home/username/kfserver/ dir and I used chmod to set the file to be excutable with chmod +x command.

When I use the ls -la command to look at the file the file is set for excutable. The file attributes are -rwxr-xr-x and the ownership is set to my name.

The problem is when I try to run the binary installation file by typing ./hldsupdatetool.bin it gives me an error message of "bash: ./hldsupdatetool.bin: No such file or directory" I am trying to excute the bin file in the /home/username/kfserver directory.

Anyone know what the problem is?
 

Phlex

FNG / Fresh Meat
May 20, 2009
13
0
0
I found the solution from another board. Some 32 bit libraries need to be installed if you're running 64 bit Linux. Run this command from a terminal as root.

apt-get install lib32gcc1
 

ddenton

FNG / Fresh Meat
May 17, 2009
26
1
0
Well i wanted to ask this, because i hade the same error some while ago,when i reinstalled my root server with debian Lenny

But i see no need to tell you that you have to install the 32bit libs.
But nice that you found the answer yourself :)
 
Last edited: