• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Workshop Upload tool issues

geotavros

Member
Aug 4, 2015
127
3
18
The beta upload tool doesn't crash but if you don't specify a preview image it shows a dialog box that it can't work without preview image and still uploads an empty item to workshop without title and description. here is the log
[Uploading to Steam] Mar 16, 7:09 PM
[Building SDK file path.] Mar 16, 7:09 PM
[Creating SDK file path: C:\Users\Dmitriy\Documents\My Games\KillingFloor2] Mar 16, 7:09 PM
[Creating staging directory: C:\Users\Dmitriy\Documents\My Games\KillingFloor2\rhkggvz5.jqh] Mar 16, 7:09 PM
[Copying to staging directory.] Mar 16, 7:09 PM
[Building settings file path.] Mar 16, 7:09 PM
[Config file write was successful.] Mar 16, 7:09 PM
[Copying image file.] Mar 16, 7:09 PM
[FILE WRITE TO 'C:\Users\Dmitriy\Documents\My Games\KillingFloor2\wsinfo_mod.txt' FAILED] Mar 16, 7:09 PM
System.ArgumentException: Empty file name is not legal.
Parameter name: sourceFileName
at System.IO.File.Copy(String sourceFileName, String destFileName, Boolean overwrite)
at SDKFrontend.Pipeline.WorkshopUpload.Execute(IProcessManager ProcessManager, Profile InProfile)
[Starting upload process.] Mar 16, 7:09 PM
[COMMANDLET 'WorkshopUserTool.exe wsinfo_mod.txt' STARTED IN 'E:\Games\Steam\steamapps\common\killingfloor2\Binaries'] Mar 16, 7:09 PM
[Upload process started.] Mar 16, 7:09 PM
WSTOOL: Initializing Steam client
Looking for $Tags
Found $Tags
Looking for $MicroTxItem
Found $MicroTxItem
Waiting for Steam task to finish.
WSTOOL: Creating workshop item for file: "C:\Users\Dmitriy\Documents\My Games\KillingFloor2\rhkggvz5.jqh"
Waiting for Steam task to finish.
Waiting for Steam task to finish.
WSTOOL:
OnShareFile failed with error code 2
Error uploading file. Make sure you got a valid connection to Steam.
[Mar 16, 7:09 PM] COMMANDLET 'WorkshopUserTool.exe wsinfo_mod.txt' SUCCEEDED
I simply added a KFM file and pressed Upload to Workshop button

When I added the preview image it still uploaded an empty workshop item. Log
SDK Frontend started 3/16/2016 7:14:55 PM...
WSTOOL: Initializing Steam client
Steam API initialized
Waiting for Steam task to finish.
[Uploading to Steam] Mar 16, 7:16 PM
[Building SDK file path.] Mar 16, 7:16 PM
[Creating SDK file path: C:\Users\Dmitriy\Documents\My Games\KillingFloor2] Mar 16, 7:16 PM
[Creating staging directory: C:\Users\Dmitriy\Documents\My Games\KillingFloor2\s05zlbec.g3h] Mar 16, 7:16 PM
[Copying to staging directory.] Mar 16, 7:16 PM
[Building settings file path.] Mar 16, 7:16 PM
[Config file write was successful.] Mar 16, 7:16 PM
[Copying image file.] Mar 16, 7:16 PM
[Starting upload process.] Mar 16, 7:16 PM
[COMMANDLET 'WorkshopUserTool.exe wsinfo_mod.txt' STARTED IN 'E:\Games\Steam\steamapps\common\killingfloor2\Binaries'] Mar 16, 7:16 PM
[Upload process started.] Mar 16, 7:16 PM
WSTOOL: Initializing Steam client
Looking for $Tags
Found $Tags
Looking for $MicroTxItem
Found $MicroTxItem
Waiting for Steam task to finish.
WSTOOL: Creating workshop item for file: "C:\Users\Dmitriy\Documents\My Games\KillingFloor2\s05zlbec.g3h"
Waiting for Steam task to finish.
WSTOOL:
OnShareFile failed with error code 2
Error uploading file. Make sure you got a valid connection to Steam.
[Mar 16, 7:16 PM] COMMANDLET 'WorkshopUserTool.exe wsinfo_mod.txt' SUCCEEDED
 
Last edited:

geotavros

Member
Aug 4, 2015
127
3
18
If I press the Start button with specified preview file it works fine. I can upload the map and update it. But there are several questions.
1. Do we need to rename map file to update it?
2. How to upload an update to a map if I don't have a profile for it in the Upload Tool?
3. How do we set Tags in the Upload Tool? Specifically the Map tag
 
Last edited:

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,698
3,714
113
The last beta build should now be the live default build of the tool. We are continuing to look into other issues and any error codes and information you can provide will help us dig into them.
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,698
3,714
113
For anybody who has had an issue with uploading workshop items with an attached picture please try again, we've made a change to the steam back-end that may have addressed this case and would like confirmation.
 

Fel

FNG / Fresh Meat
Aug 9, 2009
1,991
487
0
In Mission Mode
When i load the tool now, before it launches it says;

"Steam API initialization failed. Please ensure you have Steam running and are logged in before starting the SDK Frontend"

Then when the front end loads and i try and upload it says steam is required to play the game.
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,698
3,714
113
When i load the tool now, before it launches it says;

"Steam API initialization failed. Please ensure you have Steam running and are logged in before starting the SDK Frontend"

Then when the front end loads and i try and upload it says steam is required to play the game.
For the record this was a case of Steam corruption and refreshing the Steam install fixed it.
 

tygrion

FNG / Fresh Meat
Mar 21, 2016
7
1
0
21
Czech republic
little solution

little solution

Hello i think i found little solution

Go to your sdk install folder in binaries and delete profile file from folder called SDKFrontend.Profiles and it should work,for me it works.. ;)
 

KillMaster

Member
Jun 16, 2014
175
21
18
24
Saskatchewan, Canada
Getting onShareFile failed with error code 2

Can you give us give us a screen cap of what you are trying to upload in the tool?
I have the exact same problem.


After a bit of testing I did figure out that if I upload one of my test maps that is just over 1MB it had no problem, however when I tried to upload a file that was ~100ish MB it would fail with error code 2. Is there some sort of size restriction I'm not aware of or something?

P.S. the first map I uploaded went without a hitch, but ever since then I haven't been able to upload anything else. (Except for very small files)