What causes the "Zombie Bug?"

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Six_Ten

FNG / Fresh Meat
Mar 12, 2006
1,382
400
0
aztecmod.darkesthourgame.com
In my custom roles I now have the zombie bug: in earlier versions this sometimes did not occur; what code error causes this?

Solved.

Searching forum led to this answer from KHReese:

The zombie bug is caused by the files not being in the main "texture" and "system" folders. If they are in subfolders anywhere besides the main RO folder you will get the bug.
Easy fix is to download from maporchestra and manually place the texture and system files where they belong.
 
Last edited:

Fennich_FJR6

FNG / Fresh Meat
Mar 17, 2006
83
0
0
www.fjr6.co.uk
The zombie bug isn't a code error, its due to the fact that ragdoll info is in a .upl file and these files cannot be downloaded from servers - you have to manually install them. this is an engine limitation. there is a way around this, and that is to creat a set of MOD.u files which contain the info in the .upl - these can be got from server, but the server needs to have its .ini edited to include them.
 

Deeival

FNG / Fresh Meat
Sep 4, 2006
674
1
0
An even easier fix is for the server admin to instal the required files properly.
 

EvilHobo

Grizzled Veteran
Dec 22, 2005
2,613
192
63
Germany, NRW
Well for your mod, you may as well do it all in a .upl file to save you the hassle of setting up your skins via several tiny script packages. Your .upl is located in System/RedOrchestra.upl. It will contain all of the information for setting up new classes.

What you will see are things like "G_Heer1," for instance. Now provided that you actually have your classes set up and have script files equivalent to those in RO, "G_Heer1" would be found in RORoles/ROGE_Standard_Heer. In this script you should see the following

Code:
class ROGE_Standard_Heer extends ROGE_Heer_Units
    abstract;

defaultproperties
{
    Models(0)="G_Heer1"
    Models(1)="G_Heer2"
    Models(2)="G_Heer3"
    Models(3)="G_Heer4"
    Models(4)="G_Heer5"
    Models(5)="G_Heer6"
    Models(6)="G_Heer7"

    RolePawnClass="RORoles.GERiflemanPawn"
}
And of course you can see "G_Heer1" there again. This class -- ROGE_Standard_Heer -- is what the Heer units we have in RO are currently based off of, as it is their parent class. The models stated are how we get variations in the faces (or so I imagine, a more experienced coder can correct me but that is what I was able to gather from things like the .upl)

Anyway, back to the .upl. Let's go to where it said "G_Heer1." Now it's a long line, but it contains everything you need to implement a new character. Anyway, I'll break it up for you:

Code:
Species=ROEngine.ROSPECIES_Human
Mesh=Characters_anm.ger_rifleman_tunic
BodySkin=Characters_tex.ger_uniforms.ger_rifleman_tunic
FaceSkin=Characters_tex.ger_heads.ger_face01
Portrait=Characters_tex.ger_heads.ger_face01
Text=ROPlayers.HeerStandardSoldier
Sex=Male
Menu="ROSP"
[I]Tactics=0.3 The italicized values are mainly for bots, not important
CombatStyle=1
StrafingAbility=-2.0
Accuracy=.5,[/I]
RagDoll=German_tunic
BotUse=1
Race="German"
The things you are going to want to tamper with for your mod are Mesh, BodySkin, and FaceSkin. Everything else can virtually be left the same (experienced codes please correct if I am wrong). The values for Mesh, BodySkin, and FaceSkin are self-explanatory, so there you go. The RagDoll=German_tunic is what you need for fighting the Zombie Bug, but for your new characters I don't know if it will still apply (Soviet models use German_tunic for their ragdoll values, just for reference).

This is the easy way.
 

worluk

FNG / Fresh Meat
Nov 21, 2005
2,226
85
0
With a new character, as mentioned in that other thread, i would suggest you try to stay with the RO skeleton or at least a modified version of it.
I'd say you have 2 options then for the ragdolls:
-make sure all bones referenced in the Karmafile are still on your model (especially mind the spade ;) )
-create a new KA file or alter the existing

Did both and both works :)

As for the variations EH mentioned, yeah, i think in vanilla RO its main purpose is to change stuff like faces etc. Basically each of those entries describes a new model though, where one is randomly chosen. So basically you could have a wider variety of models too for one class. Keep in mind that every model has to be cached and loaded though, same with the textures for it.
 

7-CLOWN-7

Active member
Jan 20, 2007
743
64
28
53
Pittsburgh
www.cellar-dweller.com
How does and admin fix???

How does and admin fix???

I was wondering how does an admin fix the zombie bug problem on their server?

If you download the map with all the proper files and they are all placed in the proper locations then what is causing the zombie bug?

What items would be missing and what would need to be done by the admin to fix? I'd like to fix my server from having them on a few of the customs I have running on our server.

TIA
 

Deeival

FNG / Fresh Meat
Sep 4, 2006
674
1
0
Something like this
Code:
ServerPackages=EH-M43Uniforms
ServerPackages=G_Late1StandardMod
ServerPackages=G_Late2StandardMod
ServerPackages=G_Late3StandardMod
ServerPackages=G_Late4StandardMod
ServerPackages=G_Late5StandardMod
ServerPackages=G_M43OakCamo1SSMod
ServerPackages=G_M43OakCamo2SSMod
ServerPackages=G_M43OakCamo3SSMod
ServerPackages=G_M43OakCamo4SSMod
ServerPackages=G_M43OakCamo5SSMod
ServerPackages=G_M43Standard1SSMod
ServerPackages=G_M43Standard2SSMod
ServerPackages=G_M43Standard3SSMod
ServerPackages=G_M43Standard4SSMod
ServerPackages=G_M43Standard5SSMod
ServerPackages=R_Late1GreatcoatMod
ServerPackages=R_Late2GreatcoatMod
ServerPackages=R_Late3GreatcoatMod
ServerPackages=R_Late4GreatcoatMod
ServerPackages=R_Late5GreatcoatMod
ServerPackages=R_Late1StandardMod
ServerPackages=R_Late2StandardMod
ServerPackages=R_Late3StandardMod
ServerPackages=R_Late4StandardMod
ServerPackages=R_Late5StandardMod

under

Code:
[Engine.GameEngine]

in the RedOrchestra.ini on the server.
Also make sure all those files (with .u ending) are in the /system directory.
 

7-CLOWN-7

Active member
Jan 20, 2007
743
64
28
53
Pittsburgh
www.cellar-dweller.com
Great...

Great...

Thanks Deeival. I actually found what I needed to do but I only added a bunch of other skins but thanks for your reply to let me know that I missed quit a few others. I saw your replies yesterday in game and when you said it was server side I went out looking and found the way to fix but as I said I ended up putting a ton of other mod ones and now with the ones you mentioned all should be fixed now.

Thanks for stopping by the server yesterday also, great playing with you guys. I'm hoping to keep our server filled and one of the best to come to again - like the old days.

That patch and IP change when they went to 40 players killed our server from folks stopping by but recently there either is much more interest in the game or a lot of the old regulars are coming by once again. See you on the battlefield and hopefully without zombies.

Thanks again...