Unable To Start KF + FPS-lowered Post Update

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
Hi, I've stumbled upon a couple of frustrating problems that has occoured since the latest update.

First of, I hadn't played the game for a couple of days pre the update that came in Friday I think? It ran fine, nice and smooth FPS and so on; but when I wanted to play it 1-2 days after the update I noticed that the overall FPS had been reduced by an unknown reason... The mous-movements feels very slow and unresponsive as opposed pre the update when everything was responsive. Same goes while playing the game, I notice that the quality of the FPS has been reduced there aswell... It got me to think that maybe the update has something to do with it?

This leads me to my second problem; I went on the display-settings to hopefully find a solution to the problem by 'tweeking' and experimenting with the settings and I might've pressed the wrong button so to speak... I think I changed the render-device from Direct 3D 9.0 to Software; this resulted with that when I tried to start up the game after the setting-chenge I got this error-message:

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows NT 6.1 (Build: 7600)
CPU: AuthenticAMD Unknown processor @ 2700 MHz with 4094MB RAM
Video: No Video

General protection fault!

History: UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free


So I've tried to verify the game-cache and defrag with no success...

So I need help to start up the game and to fix the reduced FPS!

Thanks in advance, SpitzerYB
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
Open up your KF system directory - by default in c:\program files\steam\steamapps\common\killingfloor\system - and delete the killingfloor.ini file - it has a cog on the icon. This will clear all the settings and start you from scratch, which might also help with the low fps. Make sure that the mouse smoothing options are turned off.
 
Last edited:

starxpilot

FNG / Fresh Meat
Jul 30, 2010
610
48
0
TF Industries
www.tfcgaschamber.net
I've had the problem before, maybe something in the config was changed? I saw this helped when I had that problem, especially the vid error you're having.

I don't think using the Software is a good idea, maybe at least just D3D9.
Yoshiro said:
First up some people are reporting flickering and a black screen on launch. Also if your system seems to be having graphical lag you will also want to try this.

To fix open up your killingfloor.ini file (located in steam/steamapps/common/killingfloor/system)

find

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice

and change it to

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=D3DDrv.D3DRenderDevice

You will also want to change your resolution to your desired. In the same ini file look for:

[WinDrv.WindowsClient]
WindowedViewportX=800
WindowedViewportY=600
FullscreenViewportX=800
FullscreenViewportY=600

And change the Full Screen and windowed to your desired resolution for full screen and windowed mode.

Save the file and launch KF again.

Source : Known Issues and Fixes

Hope this helps.
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
Open up your KF system directory - by default in c:\program files\steam\steamapps\common\killingfloor\system - and delete the killingfloor.ini file - it has a cog on the icon. This will clear all the settings and start you from scratch, which might also help with the low fps. Make sure that the mouse smoothing options are turned off.

I couldn't find the Killing Floor.ini-file you're talking about.. :/
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
In that case it will either be called just killingfloor and have a cog icon on it, or else it won't be there because of Windows folder settings. If it isn't there and you don't know how to change your folder options to show system files in Windows then the easiest thing is to delete the killingfloor\system folder which will force Steam to re-download it the next time you try to start the game.
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
In that case it will either be called just killingfloor and have a cog icon on it, or else it won't be there because of Windows folder settings. If it isn't there and you don't know how to change your folder options to show system files in Windows then the easiest thing is to delete the killingfloor\system folder which will force Steam to re-download it the next time you try to start the game.

And that will re-set the setting to default?
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
:/ Sorry, but I'm bit of a novice for when it comes to these things; just deleted the KF/systems-folder and when I try to launch KF it says it's unavailable.. I'll try to re-install it now and hopefully that'll work!
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
I managed to get the game to work again, but I haven't been able to get rid of the reduced FPS...
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
I've played a couple of games with no improvement what-so-ever.. :/ Still having problems with the jarating mouse-movement, which still feels "slippery" like ice or something like that. And then there's the overall reduced FPS, sometimes it goes down to 15...

Everything was good before the update :(
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
Only thing I can suggest is to make sure that VSync is off, mouse smoothing is off, and if that doesn't improve things set the video settings to low temporarily to see if that does, and work your way up the settings until you find where you are getting a performance hit.
 

SpitzerYB

FNG / Fresh Meat
Apr 19, 2011
10
0
0
I'd just like to say that I've appreciated all the help you guys have given me, even though most of it didn't fix the problem, I appreciate it anyway.

I went from fullscreen to window-mode which "fixed" the "slippery mouse"-problem. Just to an extent... And I still experience an overall reduced FPS and it's very frustrating.. :( It ran perfectly pre-update.. What I'm trying to say is that I'm starting to get pissed off; I've bought a product, which worked just fine, then Tripwire releases an update that just totally messes up the game.. So I know it's a problem made from their end of the line.

Will there be any more updates in the future?
 
Last edited: