• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Unable to enter game menu (Black Screen)

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Hi there. I'm having problems starting up Killing Floor. I am able to start up the game to the loading before the menu, but the loading takes ages. After 5 minutes or so, the game closes by itself, and nothing happens.

I've tried changing 'killingfloor.ini' file as said, but it still doesn't work, the black screen still shows. I've also tried re-installing the game as well, but to no avail.

However, there are very rare times whereby I am actually able to enter the game menu, and play after countless times of random clicking. But other times, I am unable to even enter the game menu.

Now I am totally unable to play Killing Floor. Can somebody bring up a solution ASAP?
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
Try updating DX

And edit the killingfloor.ini file check if you have the refreshrate set ok, and check the resolution maybe its not supported by your monitor.

Turn off anti aliasing and stuff in the ini as well just incase its conflicting.
 

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Try updating DX
It's already the latest.

And edit the killingfloor.ini file check if you have the refreshrate set ok, and check the resolution maybe its not supported by your monitor.
Refresh rate is the same, and the resolution is the same as I'm currently using. No conflicts in that.

Turn off anti aliasing and stuff in the ini as well just incase its conflicting.
Turned it off, but to no avail.

Any other help? =(
 

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Okay I've tried something very strange and indeed, it worked.

Instead of launching the game via steam, I decided to create a shortcut of the game launcher 'KillingFloor' from 'Program Files/Steam/Steamapps/common/killingfloor/System/KillingFloor . I then launched the game from my Desktop.

Guess what? My game actually worked!

At first for the first few seconds I doubted that this would worked, but it did.

Bad thing is, I can't communicate with my friends through steam while I'm playing, but this'll do for now.

Thanks for the help.
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
Do you run mumble?

Anyway check and double check if steam or kf is not somewhat firewall / routerblocked, as starting the exe directly starts kf in offline mode.
 

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Nope, my firewall does not block the game. Even the patch does not work for me.

I also do not run mumble.
 
Last edited:

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Surprisingly, when I install KF into my lower specs laptop.

1.9Ghz Dual Core
2GB RAM
Windows XP Home Edition

The game works like a breeze.

However, when I install KF into my higher specs laptop, which I'm currently using.

2.4Ghz Dual Core
3GB RAM
Nvidia Geforce 8600
Windows Vista Home Premium

I still get the black screen.

Any ideas?
 

Supremacy

FNG / Fresh Meat
May 15, 2009
14
0
0
Guess what? I found a so called 'cheat' way to start up the game.

It could be my processor problem, COULD BE.

I start the game in Windowed mode. It works, I can access the menu from there on. Then, I go to settings and enable Full Screen mode. Then voila! I am able to play. When I exit, I just remember to exit Full Screen mode.

But still it's troublesome =/
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
if you get a black screen can you try openening killingfloor.ini in the killingfloor system folder with notepad or something. And then trying to set refreshrates to what it should be and forcing that refreshrate on your game.