Tree "Lines"

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

Deek

FNG / Fresh Meat
May 28, 2008
218
12
0
No pun intended.

Seriously though, the tree line has lines:

treelines.jpg


It doesn't show up as well as I'd like in the shot, but each and every "treeline" mesh from the HedgehogSM package has an actual line running across the top, levitating where the transparency and the mesh terminate. It either an issue with the texture, a flaw that you cannot see on a dark map like KF-Farm, but one that pops against lighter backdrops. Or, it's something my computer is generating for some odd reason.

I've attempted to export, correct and import the texture and reapply it as a different skin, but no luck. No surprise. It was a shot in the dark.

Thoughts?
 
Last edited:

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,458
1,433
0
33
Falmouth UK
Do you have an ATI graphics card?
Do you have anti aliasing on?

btw the original map is in the daylight :p
 
Last edited:

Deek

FNG / Fresh Meat
May 28, 2008
218
12
0
Nope. Nvidia. But I do have AA enabled. I'll disable it and see if that fixes the problem.

Is the mesh featured in a map other than Farm ...? Not that it matters, but that simply means the issue is likely something on my end.

EDIT: Yup. Disabling AA fixes the issue. That's a shame. I'm not gonna sacrifice my AA, but it does create a less than pleasant result with regard to the treeline mesh.

Cheers.
 
Last edited:

[TW]DrGuppy

Tripwire Interactive Staff
Nov 22, 2005
1,039
36
0
36
Atlanta, Georgia
This is an example of pixel bleeding. To fix this you can do one of the following;

- Move the top UVs of the model down a little or delete a 1-2 pixel line from the base of your texture. This prevents the bottom pixels from bleeding into the top.
- When you save the texture out as a .dds in the Nvidia option box that pops up go to Image Options and check the Alpha Zero Border (1 texel) box. This will automatically remove a 1 pixel border around the whole image and fix the problem.

The only way to solve this within the editor is to create a BSP sheet, with the texture slightly shifted away from the borders and then convert that into your own static mesh.
 

Deek

FNG / Fresh Meat
May 28, 2008
218
12
0
Perfect! Exported the treeline texture, saved it as "treeline_mod" with Alpha Zero Border (1 texel) box selected, imported it to myLevel and applied the modded skin to the treeline mesh and presto: no more line even with 8x AA.

I had attempted to delete several pixels from the top of the texture, that was my original fix attempt. Failed. I never would of guessed removing them from the bottom would've solved the prob.

Big thanks, DrG! That was bothering me to no end. :D
 
Last edited:

[TW]DrGuppy

Tripwire Interactive Staff
Nov 22, 2005
1,039
36
0
36
Atlanta, Georgia
Just be careful with the Alpha Zero Border option for smaller textures such as bushes or leaves because taking off one pixel from each side can eventually make your entire texture disappear after a number of MIP levels. Not really something to worry about with a large forest facade texture such as this though.

There is actually one other way to fix this within the editor. From the Texture Browser > Right Click on the Texture and Select Properties > Surface > change UClampMode and VClampMode from TC_Wrap to TC_Clamp. This will stop the texture from repeating. As you can see in this shot of a tree facade when the texture repeats above itself the bottom pixels will bleed into the top.
 

Attachments

  • TreePixelBleeding.jpg
    TreePixelBleeding.jpg
    57.3 KB · Views: 0

Deek

FNG / Fresh Meat
May 28, 2008
218
12
0
There is actually one other way to fix this within the editor. From the Texture Browser > Right Click on the Texture and Select Properties > Surface > change UClampMode and VClampMode from TC_Wrap to TC_Clamp. This will stop the texture from repeating. As you can see in this shot of a tree facade when the texture repeats above itself the bottom pixels will bleed into the top.
Tried this one, but changing the VClamp (actually found under Properties > Textures) made the mesh disappear altogether. Not sure why. Regardless, the Alpha Zero Border method yielded excellent results, but I'll keep in mind that it's not ideal for every instance of pixel bleeding.

Thanks for the education, Dr!
 

flo0tz

FNG / Fresh Meat
May 21, 2009
11
1
0
You also could've used a texscaler to shift the texture up or increase the vscale.