• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

To decrease loadtimes, turn off precaching and change game cache size

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
Disclaimer: all of these are suggestions that shouldn't cause any harm to your computer. However everything stated in here is at your own risk and I will not take responsibility when anything goes wrong.

First try out things in these 2 threads:
The tweaks in this thread can help the game run better for systems that either experience jerky split second freezes or extreme long load times. Option 1 can always be good to make use of, Option 2 goes together with a possible tradeoff but can gain the biggest benefits. Option 3 is always safe to do.

Note: Turning off precaching can give you a lot of benefits in loading time and in performance, as it means the game only loads things when it needs them. It also means that you must have a properly defragmented harddisc or otherwise you could get big freezes once the first specimen dies or spawns for example, as that would be the moment when they would be loaded.

Note: For general better performance on pc's make sure that in the KF setting menu "Reduce Mouselag" is turned off as it costs a lot of cpu cycles (its a feature to reduce the mouse lag when vsync is being used i believe).

for different variations on the options be sure to read this post below in this thread: http://forums.tripwireinteractive.com/showpost.php?p=540347&postcount=17

Option1: Change Cache size
1) Find your KillingFloor.ini file located in the steam/steamapps/common/KillingFLoor/system folder (hint it looks like a notpad icon with a cog)
2) Change the cache size to better match your ram size
Listed under [Engine.GameEngine].

256 Megabytes of RAM or less
CacheSizeMegs=32

512 Megabytes of RAM
CacheSizeMegs=64

768 Megabytes of RAM
CacheSizeMegs=128

1 Gigabyte of RAM or more
CacheSizeMegs=256

Note: making CacheSizeMegs bigger than 256 is not recommended as it can create your system to crash on some maps (createxture failed error), even if you have plenty of memory.

Option2: Turn of PreCaching
1) Find your KillingFloor.ini file located in the steam/steamapps/common/KillingFLoor/system folder (hint it looks like a notpad icon with a cog)
2) Change the values listed below:

under [ALAudio.ALAudioSubsystem]
Change UsePrecache=True to UsePrecache=False

and under [Engine.LevelInfo]
Change bNeverPrecache=false to bNeverPrecache=true

and under [Engine.NullRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [D3DDrv.D3DRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [D3D9Drv.D3D9RenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [OpenGLDrv.OpenGLRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [PixoDrv.PixoRenderDevice]
Change UsePrecaching=True to UsePrecaching=False
Option 3: for windows 7/Vista users turn off Superfetch

Superfetch is generally used to load often used programs early into your memory so when you use it, that it can be started up quicker.

Finally if you use windows 7 or windows vista and make use of SuperFetch for your memory and encounter "stuttering" it might be worth turning that off.

To turn it off press the windows start button -> in the search field type "services"
From the result list press on Services or press enter.

Look in that screen for superfetch and and double click on it to open a window
Set startup type to "Disabled" and below that click the "Stop" button.
After that press OK or Apply and close all windows.
Option 4: Turn off "Reduce Mouse lag"

The option reduce mouselag reduces the mouse lag you get when you have vsync enabled, however it eats loads of cpu cycles. So if you get stuttering or bad performance or even mouselag, its worth trying to turn this off.
Option 5: Use the DX 9 renderer (recommended), or perhaps try the OpenGL renderer (not recommended)

On most computers the DX9 rederer performs faster and loads better than the dx8 renderer, and its only advised using the DX8 renderer if the DX9 one gives issues. The OpenGL renderer is officially not supported afaik, but on some computers it can actually give the best speeds and performance so if you have issues with performance and loading just try it out on your own risk.

If you had previously enabled the dx8 renderer you can do the opposite of this thread to put it back to dx9 or to the openGL one.
http://forums.tripwireinteractive.com/showthread.php?t=30754
Option 6: Defragment your harddisc

Bad fragmentation of your harddisc can increase loading times and lower fps so keep your system drive and kf drive in good shape.

I personally recommend perfectdisk (their site got a free trial http://www.perfectdisk.com/). As they are the only company offering an offline defragmentation option with metadata defragmentation. Doing both a regular defragment as an offline defragment for the KF and Windows drives will definitely improve performance and loading speed.

If you dont wan't to try trial software you can of course use your favourite defragmentation software.
 
Last edited:
  • Like
Reactions: sah

HunnyPot

FNG / Fresh Meat
Aug 21, 2009
50
2
0
West Coast
I am still having problems going into the next map. Why should I have to change anything? It was fine before the update. I don't have any other load problems with any other game except for KF. I am quite annoyed at having to deal with long load times and not being able to continue onto the next map w/o being d/c. I have dealt with this issue all week, and the latest update has not helped...:mad:
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
well i just know that some things help, i dont know why some things stopped to work well.

Can you state your system specs?
 

loneless

FNG / Fresh Meat
May 18, 2009
20
2
0
I frequently have in-game freezes (that last anywhere from 5-10 seconds, which is enough to get you killed). I've had them for about 3 months, but noticed they started happening at least every wave, if not more than once per wave. After changing my cache size I have noticed a decrease in these freezes, however they still do happen. I will try option 2 to see if it eliminates the problem.

My system specs are (taken from DxDiag):
====================================================
Time of this report: 10/25/2009, 17:07:33
Machine name: LONELESS
Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.090803-2339)
Language: English (Regional Setting: English)
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz (2 CPUs), ~3.0GHz
Memory: 2558MB RAM
Page File: 1532MB used, 3803MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6001.18000 32bit Unicode

Card name: NVIDIA GeForce 9800 GTX/9800 GTX+

Display Memory: 1522 MB
Dedicated Memory: 499 MB
Shared Memory: 1023 MB

Driver Name: nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
Driver Version: 8.16.0011.9107 (English)

====================================================

If anyone see's anything wrong with my rig (i.e. bad display drivers, etc) let me know, or anything else I can try to stop this freezing. Thank you!!
 

Yomommassis

FNG / Fresh Meat
Sep 24, 2009
705
233
0
Palmdale, CA USA
I dont recommend disabling precaching

I tried this out, I didnt notice much speed difference in load times..not that i really needed a tweak to boost my performance or anything (my rig is really "good" and well maintained)

Although cutting down what is loaded initially can make it load faster this causes the files to just be loaded later when needed

I was playing with this tweak and I noticed occasional lock ups while the game loaded the new entity (mostly during the first few seconds of a wave)
 

EverDream

FNG / Fresh Meat
Nov 2, 2009
4
0
0
Same thing, Nothing helped.

Same thing, Nothing helped.

Intel core 2 duoE6600 3.0GHZ
SLI Nvidia 8800 512. Latest drivers
Patriot G-Series 1066 8GB Ram
Sata 250 GB Samsung HDD
IDE WDVR 10k 40 GB Drive
4GB Virtual Ram
MS Windows 7 RC edition (I know ill get official soon)


Was fine before the update, as I would hope a system with these specs could run KF fine. Tried lowest gfx settings to check, no effect. currently 1280x1024 max gfx 8x AA still loads slow, up to 3 minutes to join, most of the time i load in on wave 2 now, but im the first to load in.
 

Them

FNG / Fresh Meat
Jun 16, 2009
34
1
0
Florida
www.houseofamon.com
I tried this fix way back. It didnt work for me and created a lot of lag spikes and stuttering in game. But, yesterday I was sent this link again and told it fixed their issue. Having done this before, I did it quickly and didnt read the whole post. I only changed the "UsePreCache=True" settings to False and CacheSize=256. Missing the rest of the settings.

All maps loaded fine and didnt have any lag or stuttering. I came back to this post later and noticed I missed "UsePrecaching" and "bNeverPrecache" settings. I changed the "UsePrecaching=True" to False and the "bNeverPrecache=False" to True. Went into the game and it was stuttering and lagging on specimens. Then at map change I was again frozen on the map loading screen. Had to tab out and kill the process.

So I set the "UsePrecaching" sections back to True. I go into game and the stuttering and lag are gone. Runs great. Map change and again...Hang. Kill the process.

So I set the "bNeverPrecache=True" back to False. Game runs great, no stuttering or lagging. Map switches........loaded next map with no issues. Repeatedly loaded maps without the freezing.

So, the solution for me was to only change the "UsePrecache=True" settings to False and CacheSize=256

Leaving the "UsePrecaching=True" and bNeverPrecache=False" settings alone.

Try different settings, test them all. Maybe you will get lucky and find the right combination for your system.
 
Last edited:
  • Like
Reactions: Discoisntdead

IanTheM1

FNG / Fresh Meat
May 14, 2009
41
1
0
Woah, nice! Though I didn't test under ideal conditions, I did get a quick game in to check to see if Them's solution would work, and it seemingly did.

On the downside, load times are back to being a bit long (maybe it's just perception?). So on one hand, the crash bug appears to be fixed for me, but there still seems to be a problem all the same. I suppose I'll take stability over speed.
 
Last edited:

Them

FNG / Fresh Meat
Jun 16, 2009
34
1
0
Florida
www.houseofamon.com
My post above worked on my laptop but not on my desktop. My desktop used different settings.

Desktop Settings

CacheSize=256
bNeverPrecache=True

All the other settings were left alone due to lag, stutters or graphic issues
 
Last edited:

ANG3L

FNG / Fresh Meat
May 19, 2006
107
0
0
UK
My post above worked on my laptop but not on my desktop. My desktop used different settings.

Desktop Settings

CacheSize=256
bNeverPrecache=True

All the other settings were left alone due to lag, stutters or graphic issues

By this you mean the your desktop machine had to have these alternative settings to work?
 

ErikStirker

FNG / Fresh Meat
Nov 20, 2009
1
0
0
I have a Question what is meaned with the Option 1

Option1: Change Cache size
1) Find your KillingFloor.ini file located in the steam/steamapps/common/KillingFLoor/system folder (hint it looks like a notpad icon with a cog)
2) Change the cache size to better match your ram size
Listed under [Engine.GameEngine].

256 Megabytes of RAM or less
CacheSizeMegs=32

512 Megabytes of RAM
CacheSizeMegs=64

768 Megabytes of RAM
CacheSizeMegs=128

1 Gigabyte of RAM or more
CacheSizeMegs=256

Note: making CacheSizeMegs bigger than 256 is at your own risk as it can create your system to crash on some maps (createxture failed error), even if you have plenty of memory.

From what Ram is the Talk ? From the Ram on the mainboard or from the Ram of the graficcard?

My Pc :
Athlon xp 4400+ Dual Core
Windows 7 32Bit
Ram: 4 GB
Geforce 8600Gt Overclocked Edition with 512Mb

Hope someone can me answer :)



 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
those guidelines are roughly based on system memory. Recently someone had some issues with 256 so perhaps try it a bit lower or higher.
 

Joseph

FNG / Fresh Meat
Dec 30, 2009
60
0
0
Too long to Load the next Map(When Played Online)

Too long to Load the next Map(When Played Online)

About 80-90% of the times after i play a map on KF(played online), when it changes, it takes forever to load again. This keeps getting worse as long as I keep playing.
I always played in windowed mode: 800x600 with low display settings.

System Specs:
OS: Windows Vista 32bits
Processor: Intel Pentium Dual CPU T3200 2 GHz
RAM: 3 GB
Graphics Card: NVIDIA GeForce 9200 GE
Sound Card: Conexant High Definition SmartAudio 221
Hard Drive: 133 GB Free (with already game installed. so... ye...)
Recommended:
 
Last edited:

Joseph

FNG / Fresh Meat
Dec 30, 2009
60
0
0
Reporting Back

Reporting Back

Changing Map Loading Times (Online Gaming) & Note about General Performance during the Game

I have to Say that before i changed anything with PreCaches, CacheSizeMegs, and "Reduce Mouse Lag", also Defragment my Drive (Hard Disk), i had to wait like 2 minutes in average.
So thanks for this thread and all its support by any posts.

I decided to test the configuration with Precaching in the Option 2 given by “Zetsumei”, as “Them” said to test different settings. So remember this is with my own computer, which in this case is a laptop. So the configuration might be different for others.
My System Details:
OS: Windows Vista 32bits
Processor: Intel Pentium Dual CPU T3200 2 GHz
RAM: 3 GB
Graphics Card: NVIDIA GeForce 9200 GE
Sound Card: Conexant High Definition SmartAudio 221

(Does 400MHz in the processor make a difference, for the recommended specs?)

Anyway, I decided trying to help with some tests, as also, seeing what is the best configuration for me. I hope this info will be helpful for anyone having the same issues with loading maps, and it’s bothered/annoyed since they even have the recommended System Specifications.
Lastly I hope that this will help Tripwire to figure out what it causes, and what can be changed, so we won’t have these troubles with manually configuring.

Before I done this PreCache, CacheSizeMegs, "Reduce Mouse Lag", and Deframentation changes i had my Game Details at Low running in 800x600 windowed mode (remember that I had 2 minutes in average to load), and this tests were made after the Deframentation with: Game Details at High in 800x600 windowed mode.

-The experiences consists in changing the Precache settings as for each experience is told, with 6 times counting (in seconds) changing map in online servers, ALWAYS lower than 80 ping (the best i can get is a 30/40 ping server). With only me in the game (blowing myself or letting get eaten by the monsters) so it would be much faster.
Note: I close the game every time and then change the Precache settings before the next experience.
 
Last edited:

Joseph

FNG / Fresh Meat
Dec 30, 2009
60
0
0
Reporting Back (2)

Reporting Back (2)

Experience 1 ("Default")

Game Details=High
Resolution=800x600
Windowed mode
With Defragmentation done
CacheSizeMegs=32
Reduce Mouse Lag = On
All Precache Settings=True (Except bNeverPrecache=false)

In Seconds
1-12,5
2-12,5
3-18,3 (freeze by 1 second)
4-14,4
5-26,4 (freeze by 3 seconds)
6-12,1
Average=16,03

General Performance in-game Note:
No in-game lag spikes. No Crashing. Freezing at 3 and 5 attempt. Runs good.

By this one I would conclude now that the defragmentation did a lot of difference in the loading. It’s quiet normal that this would happen tough.
(Imagining a room and the stuff inside it, if you have your room cleaned and organized, you’ll find the stuff you need more quicker then with it as my room usually looks like: a mess! Lol. Same as the Hard Disk would be the room, the stuff would be the KF files, and you the processor.)

The files from time to time get “lost” in the drive, and so, when the processor tries to read the files it needs, it takes more time then if the files are all in their places.


The rest of the experiences were with:
Game Details=High
Resolution=800x600
Windowed mode
With Defragmentation done
CacheSizeMegs=256
Reduce Mouse Lagging = Off

Experience 2
-"UsePrecaching=True" to False, the "bNeverPrecache=false" to true and "UsePreCache=True" to False.
As the Option 2 says.

1 - 18,7
2 - 11,2
3 - 8,5
4 - 12,0
5 - 10,9
6 - 9,7
Average=11,83

General Performance in-game Note:
Some lag spikes during the game. No crashing or freezing. Runs ok.

Experience 3
-"bNeverPrecache=false" to true and "UsePreCache=True" to False.
Leaving the "UsePrecaching=True".

1-11,4
2-13,7
3-33,7
4-28,5
5-17,7
6-23,4
Average=21,4

General Performance in-game Note:
No in-game lag spikes. No crashing or freezing. Runs great.

Experience 4
-"UsePrecaching=True" to False and "UsePreCache=True" to False.
Leaving the "bNeverPrecache=false".

1-8
2-12,9
3-9,8
4-10,7
5-11,1
6-10,8
Average=10,55

General Performance in-game Note:
In-game lag spikes, during the game. No Crashing. No Freezing. Runs ok.

Experience 5
-"UsePrecaching=True" to False and "bNeverPrecache=false" to true.
Leaving the "UsePreCache=True".

1-9,1
2-11,8
3-8,1
4-9,9
5-9,3
6-11,9
Average=10,01

General Performance in-game Note:
No in-game spike lags. No crashing. No freezing. Runs good.

Experience 6
-"bNeverPrecache=false" to true.
Leaving the "UsePrecaching=True" and "UsePreCache=True".

1-17,8
2-13,2
3-25,0
4-18,4
5-15,6
6-19,9
Average=18,32

General Performance in-game Note:
No in-game lag spikes. No crashing. Freezing a bit in the 3 attempt. Runs good.

Experience 7
-"UsePrecaching=True" to False.
Leaving the "UsePreCache=True" and "bNeverPrecache=false".

1-8,9
2-10,7
3-12,7
4-11,2
5-25,0 (Not Responding for about 5 seconds)
6-14,1
7-11,1
Average=13,38

General Performance in-game Note:
Lag spikes at the beginning and during the game. No crashing. Freezing at the 5 attempt and 2 times during the game. Runs ok.

Experience 8
-"UsePreCache=True" to False.
Leaving the "bNeverPrecache=false" and "UsePrecaching=True".

1-12,1
2-12,5
3-12,1
4-39,9 (weird..)
5-26,4
6-10,8
7-8,2
8-10,5
Extended this one because of that 39,9 witch was weird since the 7 and 8 were a 8 and a 10.
Average=16,56

General Performance in-game Note:
No in-game lag spikes. No crashing. Freezing a bit in the 4, and 5 attempts. Runs ok, but i think not 100% smooth.


Conclusions:

Best Average Time Loading: Experience 5
Best In-Game evaluation: Experience 3

Best 3 Average Time Loading (Best to Worse): 5, 4, 2.
Best 3 In-Game Evaluation (Best to Worse): 3, 5, 6.

I guess I will use the settings for the fifth or third experiences. Even though the loading time wasn’t so good in the third experiment (21,4), I had a great in-game experience. Still, the best in general performance was the Fifth Experiment.

So it’s done.
Now I would be appreciated to know, opinions, ideas, self-experiences.
Was this worth for anything?
Were the conditions good enough?
What suits best for you? Telling what Specs you have. (in a quick view without all the details)
Am I wrong in something I said?

Thanks for your time reading this huge post. :p
Hope it helps somehow… :):)
 
Last edited:

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
It got to be usefull to atleast some others, so thank you for that contribution ^^. Ill make defragmentation a bit of a clearer option in my first post as well.
 
Last edited:

Skalli

FNG / Fresh Meat
Mar 2, 2010
225
54
0
Germany
Hm here's a problem.

Option2: Turn of PreCaching
1) Find your KillingFloor.ini file located in the steam/steamapps/common/KillingFLoor/system folder (hint it looks like a notpad icon with a cog)
2) Change the values listed below:

under [ALAudio.ALAudioSubsystem]
Change UsePrecache=True to UsePrecache=False

and under [Engine.LevelInfo]
Change bNeverPrecache=false to bNeverPrecache=true

and under [Engine.NullRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [D3DDrv.D3DRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [D3D9Drv.D3D9RenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [OpenGLDrv.OpenGLRenderDevice]
Change UsePrecaching=True to UsePrecaching=False

and under [PixoDrv.PixoRenderDevice]
Change UsePrecaching=True to UsePrecaching=False
This entries don't exist in my .ini file!
(ALAudio exists)
May someone upload his .ini file using a win7 64 bit system?
 
Last edited: