• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

[Crash] [Steam/Linux] Crash on launch (Kubuntu 15.10 64bit)

illuminati Repilians NWO

FNG / Fresh Meat
Dec 2, 2015
2
0
0
I tried to play RO:O on my machine and after clicking "Play" in steam app, it shows splash screen for few seconds and after that process is terminated.

System, hardware specs
Code:
Probook 4530s notebook

CPU i3-2310m
Switchable Intel SandyBridge + AMD Radeon 6490M graphics 
[LIST]
[*]I'm using open source drivers Mesa 11.0.2
[*]System by default uses Intel graphics. I can change it using DRI_PRIME=1 (radeon card) prefix
[/LIST]
8 GB ram

X-server:
X.Org X Server 1.17.2

System:
Kubuntu 15.10 64bit
Crash log from RedOrchestra.log (doesn't change if i launch it using DRI_PRIME=1 (to use radeon card) or not)
Code:
Log: Log file open, Wed Dec  2 13:25:06 2015
Init: Name subsystem initialized
Init: Version: 3339 (128.29)
Init: Compiled: Oct 29 2012 10:22:31
Init: Command line: 
Init: (This is Linux patch version 3339.0)
Init: Character set: Unicode
Init: Base directory: /home/illuminati-user/.local/share/Steam/steamapps/common/Red Orchestra/System/
Init: Ini:RedOrchestra.ini   UserIni:User.ini
Init: Build label:  Build RedOrchestra_Build_[2005-11-27_10.48]
Init: Object subsystem initialized
Log: STEAMAUTH : SteamAPI_Init failed
Warning: Missing Class Class Editor.TransBuffer
Log: Initializing OpenGLDrv...
Log: binding OpenGL library...
Log: Game class is 'GameInfo'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 1.882118...
ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Log: Browse: ROintro.rom?Name=ROPlayer?Class=Engine.Pawn?Character=G_Heer1?team=1?Sex=M
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 38720->38720; refs: 401801
Log: Game class is 'CinematicGame'
Log: Bringing Level ROintro.myLevel up for play (0) appSeconds: 2.135486...
ScriptLog: GameInfo::InitGame : bEnableStatLogging False
Log: Created and initialized a new SDL viewport.
ScriptLog: ROGUIController initialized 
Log: ALAudio: Using ALC_EXT_capture to record audio.
Log: 
Developer Backtrace:
Log: [ 1]  ./redorchestra-bin() [0x853ffab]
Log: [ 2]  [0xf7720b70]
Log: [ 3]  /lib/i386-linux-gnu/libc.so.6(+0x129f7f) [0xf73b9f7f]
Log: [ 4]  /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so(+0x2c5e) [0xf31e7c5e]
Log: [ 5]  /usr/lib/i386-linux-gnu/libasound.so.2(+0x88f6f) [0xf314ff6f]
Log: [ 6]  /usr/lib/i386-linux-gnu/libasound.so.2(+0x47c2f) [0xf310ec2f]
Log: [ 7]  /usr/lib/i386-linux-gnu/libasound.so.2(+0x8960a) [0xf315060a]
Log: [ 8]  /usr/lib/i386-linux-gnu/libasound.so.2(snd_pcm_readi+0x50) [0xf31084c0]
Log: [ 9]  /home/illuminati-user/.local/share/Steam/steamapps/common/Red Orchestra/System/openal.so(+0x2ab28) [0xf321eb28]
Log: [10]  [(nil)]
Log: Unreal Call Stack: FALSoundBuffer::Init <- UALAudioSubsystem::SetViewport <- UGameEngine::Init <- InitEngine
Exit: Exiting.
Log: FileManager: Reading 0 GByte 111 MByte 363 KByte 558 Bytes from HD took 0.148451 seconds (0.050871 reading, 0.097580 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Allocation checking disabled
Uninitialized: Log file closed, Wed Dec  2 13:25:09 2015
And log from console
Code:
illuminati-user@illuminati-comp:~/.local/share/Steam/steamapps/common/Red Orchestra/System$ ./redorchestra-bin
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/illuminati-user/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/illuminati-user/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/illuminati-user/.steam/bin32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Failed to send /home/illuminati-user/.redorchestra/System/crashlog-447454f213876e3512f57807a7835d7a.txt: server rejected report  (Will try to send next run.)
Failed to send /home/illuminati-user/.redorchestra/System/crashlog-73bec216a7c682e72e15fc3e2c975037.txt: server rejected report  (Will try to send next run.)
AL lib: sdl.c:228: No OpenAL capture support in the SDL backend at this time.
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
Segmentation fault (core dumped)
 

illuminati Repilians NWO

FNG / Fresh Meat
Dec 2, 2015
2
0
0
i don't know how the hell it was fixed, but after reinstall i was able to play. Unfortunately i discovered other bug. I'm using two monitors (in screen extend mode), and after launching game in fullscreen mode, game changes my screen setup and treats them like one. After exiting the game i must switch monitor settings to previous setup.