Spawning problem

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

SchutzeSepp

FNG / Fresh Meat
Sep 23, 2006
1,540
8
0
35
on the map i am working on i have come across a problem with the spawning, when i test the map weird things happen,
the germans have 3 spawn areas, and the allies have 2
in the beginning the germans spawn in in their first spawn (wich is good)
when the allies capture the first objective, the germans are forced to spawn in on their second spawnarea, but then it goes wrong because the germans start spawning in the first spawn and in the second spawn, some even spawn in on allied spawns.

i have followed every tutorial, been trough all the posts regarding similar problems but none work.

my usespawnarea is set on true
the allies spawn in correctly, when they capture the third objective they spawn in in their second spawn area, (as planned)

i have been working for 2 days on this problem only, could somebody give me a checklist of things to check?

here is what i want:

at beginning germans spawn in in "GermanSpawn1"
wich is to stay active untill the allies capture objective 1

then they have to spawn in in GermanSpawn2
untill allies capture objective 3

for some reason it goes wrong when allies capture objective 1, because the germans start spawning in in different spawn areas
 

Drecks

FNG / Fresh Meat
Nov 26, 2005
2,393
218
0
The Netherlands
Did you give the playerstart the correct teamnumber and tag
The same as you added in your RO spawnarea porperties ?

 

SchutzeSepp

FNG / Fresh Meat
Sep 23, 2006
1,540
8
0
35
i didn't, i will try this as soon as get some time!

i never heard of this in any tutorial though
 

SchutzeSepp

FNG / Fresh Meat
Sep 23, 2006
1,540
8
0
35
It works! almost lol, the germans now spawn in in 1 spawn at the time, but for some reason when they lose spawnarea1 they spawn in from spawnarea3!
and skip spawnarea2

spawnarea1 has precedence 0 and is initially active, spawnarea2 has precedence1 and is not initially active, and spawnarea3 has precedence2 and is not initially active.
 

SchutzeSepp

FNG / Fresh Meat
Sep 23, 2006
1,540
8
0
35
What needs to be changed? the precedence? i had already reversed them and otherwise.

added later*

problem fixed!, i reversed the precedence numbers of my spawnarea's and now the teams spawn in correctly

thank you Mr Drecks!!
 
Last edited: