Servers with custom maps cannot be joined

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

WB_Fire

FNG / Fresh Meat
Jul 15, 2020
2
1
3
I, and a few others, are having a weird issue that only seems to affect some people, but not everyone. With a dedicated server, if running a custom map, some players will not be able to join and given the message that the server needs to be updated. However, others will join just fine and begin downloading the map. And yes, the server is fully updated.

This is where the issue seems to lie - downloading the custom map. We have not been able to pinpoint any one setting that may help, nor has completely redownloading the game.

However, if the player downloads the map from the Steam Workshop themselves (Subscribes to it), and restarts their game, then they are able to join just fine. That is, until another custom map is voted and they don't have it already downloaded. So there is a bit of a workaround if you know what maps to get ahead of time.
 
  • Like
Reactions: Vina Loca

Kittenmittens

Tripwire Interactive Community Team
Staff member
Mar 11, 2016
1,452
353
83
Killing Floor Discord :)
Are you reporting that on the Steam version if there is a map or mod mismatch, the player is not getting an updated version of the mod or map from the server in able to join?
 
  • Like
Reactions: n1ouk

duk6046

Member
Jul 15, 2009
125
5
18
Exactly this issue, the error code is strange. please fix it quickly
 

WB_Fire

FNG / Fresh Meat
Jul 15, 2020
2
1
3
Are you reporting that on the Steam version if there is a map or mod mismatch, the player is not getting an updated version of the mod or map from the server in able to join?
This is the case, yes. I have not yet tried duk6046's suggestion.
 

mistawolf

FNG / Fresh Meat
Jul 15, 2020
2
0
1
Same issue here, trying to join a dedicated server with custom maps kicks me out with error "Update the game to latest version".

other players are able to join fine and load maps off server, however myself and a friends on epic are removed with that error.

from duk6046's link.

Same issue, on a Redirect server (and perhaps also on Workshop servers), players can't downloads mods files.

The defaut value is False and we can't join custom servers from Epic or Steam client unless we change the configuration of the file.

There are two error message that can occur : "Missing mod package" or "Update the game to latest version".

C:\Users\%USERNAME%\Documents\My Games\KillingFloor2\KFGame\Config\KFEngine.ini

Under [IpDrv.TcpNetDriver] change to AllowDownloads=True

By default it is on False =/

This change worked for me on steam, I will test with friend on epic once he is home.
please fix, players shouldn't need to go into .ini files to play the game.
 

Rosshambo

FNG / Fresh Meat
Jul 15, 2020
2
0
1
I am seeing the exact same thing. We have determined that the problem only lies with players who purchased the game on steam after the epic games version went on sale.
The players can access the server only after they download all of the maps through the workshop manually instead of allowing the client to download the map directly from the server.
 

Rosshambo

FNG / Fresh Meat
Jul 15, 2020
2
0
1
After reading more carefully the fix is client side. Have the players edit their configs to fix the bad AllowDownloads default boolean in KFEngine.ini: