Server Perks Mut Causes General Protection Fault Crash, Any Ideas?

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

Tsyolin

FNG / Fresh Meat
May 17, 2013
2
0
0
Okay so I've recently decided I wanted to dabble in modding my KF game and have a little more fun with custom weapons and other crap. I tried using Server Perks in conjunction with the SCRN Total Game Balance Mut, along with a few custom weps I programmed in. It worked the first time I tried it, now it just crashes whenever I load certain maps. It's not all the maps but it's pretty much every map I like to play on, including custom ones.

I honestly thought I would have found a solution but I don't see anything like this posted anywhere on the internet...

I get this error when I start a listen server or solo game on Mountain Pass.

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows NT 6.1 (Build: 7601)
CPU: GenuineIntel PentiumPro-class processor @ 3501 MHz with 4095MB RAM
Video: NVIDIA GeForce GTX 580 (1422)

General protection fault!

History: UInteractionMaster::MasterProcessTick <- ULevel::Tick <- (NetMode=0) <- TickLevel <- UGameEngine::Tick <- Level KF-MountainPass_Day <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 4C576C61 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free
It doesn't happen on all maps, Abusment Park and Moon Base for example worked absolutely fine.

I'll upload the .log as well.

I know it's not an issue with the Total Balance Mut since I tried it with only Server Perks installed and to no avail. I've tried almost of the fixes I could find but no luck, what's going on to cause this?
 

Attachments

  • KillingFloor.log
    14.7 KB · Views: 0

DMN666

Active member
Jun 14, 2012
2,569
12
38
Brooklyn, NY
I know it happends to me when i connect KF online but then disconnect. When i put Steam Offline it doesnt give me the error anymore.
 

Tsyolin

FNG / Fresh Meat
May 17, 2013
2
0
0
I know it happends to me when i connect KF online but then disconnect. When i put Steam Offline it doesnt give me the error anymore.

Hmm, didn't work for me. Still getting the same error as before. I've been able to go other routes to get custom weps in the shop but I'd still rather get this to work because it allows weapons to be discounted base on class.