[SDK] Global radius sounds issue

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

RoBoT

FNG / Fresh Meat
Mar 21, 2009
1,155
156
0
33
Syria
Lately I've been adding custom sounds in triggers & custom zed.
They're working fine, but the problem is that I can hear the sounds from long distance like they're next to me.

Could be something to do with my converted .wav files?
 

FluX

Grizzled Veteran
Oct 26, 2010
5,394
234
63
www.fluxiserver.co.uk
This is a setting I believe. I had this problem with weapon firing sounds and it turns out to be a CullDistance inside the animation file. Maybe this could be of some use?
 

RoBoT

FNG / Fresh Meat
Mar 21, 2009
1,155
156
0
33
Syria
This is a setting I believe. I had this problem with weapon firing sounds and it turns out to be a CullDistance inside the animation file. Maybe this could be of some use?

Didn't find anything says culldistance in animation file, but I think I managed to fix it, or atleast lowered the volume when you're far away.

I reduced the sampling rate of the wav file from 41kHz to 32kHz or 22kHz. It's kinda better now noticing the volume differences depends on the distance.
 

FluX

Grizzled Veteran
Oct 26, 2010
5,394
234
63
www.fluxiserver.co.uk
I doubt it'll fix, just isn't as "detailed" with that sample rate. I believe the engine supports 44.1k/41k (whatever it is) so there must be some sort of sound setting.
 

poosh

Grizzled Veteran
Jan 6, 2011
3,403
327
83
Are you using AmbientSound or scripted actions to play those sounds?
 

NumberZero

Member
May 14, 2013
70
0
6
28
I was having the same problem too. I was using AmbientSound actors, and I think it still had the problem if the sound originated from a ScriptedTrigger too. I got around it by not using either of those, and just place a mover that wouldn't move but get triggered, and have that play a sound.
 

poosh

Grizzled Veteran
Jan 6, 2011
3,403
327
83
If you are using ACTION_PlaySound, then it doesn't have sound radius option.
You can try ACTION_PlayAmbientSound.
 

poosh

Grizzled Veteran
Jan 6, 2011
3,403
327
83
Keep in mind that ACTION_PlayAmbientSound assigng ambient sound to scripted trigger itself. So it is important where do you place it on the map.