• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

ROEngine.ini Tweak Guide - confirmed improvement

FBX

FNG / Fresh Meat
Aug 17, 2006
238
42
0
This short guide will help get both your graphics and framerate up

ROEngine.ini is located in Documents\My Games\RedOrchestra2\ROGame\Config

[BACKUP]
1. Make a backup of ROEngine.ini by simply copying and pasting the file and renaming the new file (convention is normally a .bak extension)

[OPEN ROEngine.ini]
1. Right click and select Open or "Open with...". Choose a text editor of your choice, such as notepad. Nothing fancy. Remember when saving the file to make sure it saved with the correct extension and not a .txt extension. Since all .ini files are actually text files it is ok to make this a permanent change

[DELETE THE REDUNDANT GAME ENGINE ENTRY]
1. Search for ROGame.ROGameEngine
2. Delete everything but the server actors line, so it looks like this:

Code:
[ROGame.ROGameEngine]
ServerActors=IpDrv.WebServer

[IniVersion]
etc
This gets regenerated when you play the game so it is unnecessary and just creates more variables to change.

[ELIMINATE TEXTURE POP-IN]
1. Search for TextureStreaming
2. Change PoolSize line to equal your half of your GPU's video RAM. Note that increasing this value decreases fps slightly but reduces hitching and significantly improves video quality. There is a point where increasing this value does not help anything. I noticed very little difference beyond 512.
3. Note that it is possible to remove texturestreaming entirely but it is not recommended since it just increases hitching while the game loads textures
4. Setting this value too high may crash the game

[REDUCE SHADOW QUALITY]
- Note this reduces the shadow resolution without reducing WHAT shadows are rendered. Settings shadows to "medium" is in many cases an optimal setting.
1. Search for MinShadowResolution
2. Set shadow values as such (note that I am assuming every machine has the same default values I had. If you find yourself increasing values... Don't do it

Code:
MinShadowResolution=16
MinPreShadowResolution=8
MaxShadowResolution=512
MaxWholeSceneDominantShadowResolution=1024
ShadowFadeResolution=16
PreShadowFadeResolution=8
[INCREASE NETWORK BANDWIDTH ALLOWED]
1. Search for Engine.Player
2. Change ConfiguredInternetSpeed to 40000
3. Scroll down to IpDrv.TcpNetDriver
4. Change MaxClientRate and MaxInternetClientRate to 40000 (note that these may be server-side settings and may not do anything. I am not positive yet)
5. Change NetServerMaxTickRate to 22 (again, may be server-side only... Servers that lag out at 64 players may benefit by reducing this number from what they currently have it at)
6. Search for NetClientTicksPerSecond and change it to 22

[POSSIBLY IMPROVE HIT DETECTION]
1. Search for MaxDeltaTime and change it from 0 to 250
- No one knows what this does but I suspect it is a tolerance item of some sort

[DROP THE MINIMUM SMOOTH RATE]
1. Keep smooth FPS enabled but change MinSmoothedFrameRate to 15
2. Set MaxSmoothedFrameRate to whatever you wish
- Game supposedly tries to "undo" graphics when min smooth framerate is hit. This "undo" can cause hitching. Uncomfirmed (just speculation)

[DISABLE UNUSED PERF TRACKING JUST IN CASE]
1. Search for TaskPerfTracking
2. Set bUseTaskPerfTracking to FALSE
3. Scroll down to TaskPerfMemDatabase
4. Set bUseTaskPerfMemDatabase to FALSE

[REDUCE SOUND OVERHEAD]
1. Search for XAudio2.XAudio2Device
2. Change MaxChannels to 64 or greater... The game seems bugged if you have less channels. Set MaxChannels under Engine.AudioDevice to the same value as well.
3. Change MinCompressedDurationGame to 0.3 From 5
4. Change LowPassFilterResonance to 1.0 from 0.9
- This reduces the atmospheric effects and reverberation which eats up CPU useage

[MINOR TWEAKS]
1. Change PrimitiveProbablyVisibleTime to 0.5 or so. This number keeps an object as "visible" even when it is no longer visible. Reducing the number improves framerate response when you move from a busy area to a less busy area and can reduce the fps bottom that might be caused when you move from one busy room to the next. Default is 8 seconds.
2. TimeBetweenPurgingPendingKillObjects is a timer for garbage collection, and you will get a slight hitch everytime this happens. I set this to 600 so it is once per 10 minutes. Default is once per minute. You can try reducing this number to see if it reduces crashing or increase it to reduce hitching that once/minute hitch.

[OTHER ROEngine.ini TWEAKS]
1. Increasing TerrainTessellationCheckDistance may improve performance very slightly. Decreasing this value will ruin performance
2. UpscaleScreenPercentage may or may not do something. Mine was set to True and I changed it to False
3. bAllowHardwareShadowFiltering may do something
4. Under VoIP you can disable voice entirely by setting bHasVoiceEnabled to false.
5. Setting bEnableVSMShadows to true may yield a performance increase

[nVidia AA tweak]
1. In game, disable Anti-aliasing
2. In the nVidia control panel, add ROGame.exe by manually looking for it under Steam's Common folder
3. Set Antialiasing using the control panel
4. This should give good quality AA with good performance
 
Last edited:

FBX

FNG / Fresh Meat
Aug 17, 2006
238
42
0
Hmm? When I change it in the menu it asks to restart the game and then it shows up. When I change it in the ini file I have no issues having it stick...
 

LuaKT

FNG / Fresh Meat
Sep 13, 2011
5
0
0
I've tried the tweaks and it's made no difference, 100 FPS on menu, 40FPS ingame. =/
 

FBX

FNG / Fresh Meat
Aug 17, 2006
238
42
0
How are you measuring fps? I compared on the worst case maps with a full server and saw notable improvement. Single player may have a cpu bottleneck that this stuff wont address.
 

Oo.k.

FNG / Fresh Meat
Sep 1, 2011
74
15
0
Most of these tweaks don't work, your title said ''confirmed improvement'' and you're thread is filled with may or may not, maybe and not sure.

You'll just make people have more trouble than they already have. There's already a bunch of people in the support section spamming they have problem only to find out they have listened to some people tweaks fix and messed their game up.

Not saying it's not nice of you, but maybe you should test your tweaks more extensively before posting them.
 

LuaKT

FNG / Fresh Meat
Sep 13, 2011
5
0
0
How are you measuring fps? I compared on the worst case maps with a full server and saw notable improvement. Single player may have a cpu bottleneck that this stuff wont address.
On the menu open the console (Default F3 I think) and type stat fps.
 

Scrappa

FNG / Fresh Meat
May 1, 2011
217
54
0
25
England
Improved my performance. I'm playing on an HD5770XFX 1GB and the TextureStreaming was set at 128mb, moved it to 512mb and I get alot better FPS and alot more stable FPS.
 

dsa88

FNG / Fresh Meat
Aug 31, 2011
12
2
0
This worked beautifully for me. I set maxsmoothedframerate to 50. Btw, make sure to set the file to read only.
 

M55ikael

FNG / Fresh Meat
Aug 11, 2011
349
80
0
This has a lot of new tweaks and it drastically altered my performance. I am now playing the game everything maxed out with a stable 60-70 frame rate. That was not a worthy response. I used the texture streaming and hit detection tweaks.

However, my server browser is no longer working (except for favourites and recently played):(

Phenom II X4 965 3.8Ghz
HD6870
 
Last edited:

u-s-e-r

FNG / Fresh Meat
Nov 24, 2010
1,332
342
0
This has a lot of new tweaks and it drastically altered my performance. I am now playing the game everything maxed out with a stable 60-70 frame rate. That was not a worthy response. I used the texture streaming and hit detection tweaks.

However, my server browser is no longer working (except for favourites and recently played):(
It still couldve been posted to the right thread
 
  • Like
Reactions: Comrade Kaizer

MikkOwl

FNG / Fresh Meat
May 15, 2009
233
57
0
Sweden
Big improvement for me also (6970 2gb). Especially a heck of a lot less of that insane ultra-slowdown thing that appeared every time I'd change my direction of viewing, turn a corner etc. The actual FPS counter itself was probably about the same as before (it would show deceptively high numbers considering how stuttery it felt).

From own testing, the level of shadows makes a big difference on the 'ultra-stutter slowdown when viewing another direction'. The texture pool set to 1024mb from this tweak also probably helped.

First time I've been able to use automatic weapons at medium-close distances online without the FPS dropping to unplayable levels. Fun.
 

Maj.Faux-Pas

FNG / Fresh Meat
Mar 1, 2006
363
16
0
Portland, OR
OP, most of your settings are found in multiple places in the .ini and may cause confusion or problems if not entered in the proper section.

Be sure you're editing
Code:
[SystemSettings]
and not
Code:
[SystemSettingsEditor]
since those settings are for Unreal Editor viewports, which should be left alone. When you edit maps you want to see all the details and you want default settings.

Good tip with the video card memory setting. 512 is what I use also with a 1GB card.
[INCREASE NETWORK BANDWIDTH ALLOWED]
1. Search for Engine.Player
2. Change ConfiguredInternetSpeed to 40000
3. Scroll down to IpDrv.TcpNetDriver
4. Change MaxClientRate and MaxInternetClientRate to 40000 (note that these may be server-side settings and may not do anything. I am not positive yet)
5. Change NetServerMaxTickRate to 22 (again, may be server-side only... Servers that lag out at 64 players may benefit by reducing this number from what they currently have it at)
6. Search for NetClientTicksPerSecond and change it to 22
This is pure BS.

Tick rate is hard coded at 20. Always has been.

There is a formula for arriving at ConfiguredInternetSpeed which can improve responsiveness as far as "hits" are concerned. However, it only works if you set it to less than 10000, which can indeed improve your performance depending on your system.

Client net rate is capped by the server at 10000. The only reason you'd want this higher than 10000 is to set it to 20000 for a 64 player server. 10000 is the 7 year old, 32 player rate. The engine doesn't send any more data to each player than it did 7 years ago. It's a vector and some states like what team and what weapon... which is about half a page per tick worth of data which doubles with twice as many players. See my math there? ;)

[DROP THE MINIMUM SMOOTH RATE]
1. Keep smooth FPS enabled but change MinSmoothedFrameRate to 15
2. Set MaxSmoothedFrameRate to whatever you wish
If I haven't baked people's muffin yet....
You can't see more than what your monitor shows, so all the framerate over and above your monitor's refresh rate are invisible. Your monitor cannot physically display them, and therefore your eyes cannot physically see them.

60 Hz monitor = 60 fps maximum. Anything more and you're wasting electricity. Set MaxSmoothedFrameRate to your monitor's refresh rate.

MaxSmoothedFrameRate caps the framerate if bSmoothFrameRate is set to True. MinSmoothedFrameRate should be 22.
 
Last edited:

atomMan

FNG / Fresh Meat
Sep 1, 2011
209
34
0
Uhmmm yeah... that can actually screw things up for us with... crappy routers.

Most important thing - Textures poping in "fix" DOES NOT work at all.
 

Mercurial

FNG / Fresh Meat
Sep 17, 2011
4
0
0
This has a lot of new tweaks and it drastically altered my performance. I am now playing the game everything maxed out with a stable 60-70 frame rate. That was not a worthy response. I used the texture streaming and hit detection tweaks.

However, my server browser is no longer working (except for favourites and recently played):(

Phenom II X4 965 3.8Ghz
HD6870
Thats because you made the ROEngine.ini read only.