RO2 SDK content browser locks up pc when typing

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

SiC-Disaster

FNG / Fresh Meat
Dec 16, 2005
4,890
679
0
34
Netherlands
www.tangodown.nl
The title says it all really.
Whenever I open up the content browser and start typing to find something the SDK completely freezes up and almost completely locks down my computer.
Is anybody else having this issue?
 
  • Like
Reactions: Raneman

Titulus

FNG / Fresh Meat
Aug 11, 2011
42
5
0
Interesting. Mine locks up on startup only after a database update. However, I noticed every time on startup now that I have my previous search still typed into the content browser. Maybe that is causing the freeze? If only I could somehow remove the info in the search bar I could determine if that was causing the freeze.

Edit: Just did a little research and there must be some sort of memory leak as ROgame.exe quickly consumed over 6gb of memory in just a few seconds and caused a freeze again. Luckily, I was able to end the process before having to hard boot again.

http://youtu.be/O3KcBEQhR7g is a video I recorded clearly demonstrating my issue. I hope this helps fix the issue.

I fixed the issue by hitting the "clear" button on the content browser as soon as the SDK launched. The issue is clearly tied to searching in the content browser.
 
Last edited:

SiC-Disaster

FNG / Fresh Meat
Dec 16, 2005
4,890
679
0
34
Netherlands
www.tangodown.nl
Interesting yeah, I had a watch in the task manager and it consumes a lot of memory when running.
Didnt think too much of it though as I could create a terrain, add a dominant directional light through actor classes etc. fine.
But when I tried to find a material to apply to the terrain in the content browser (through typing grass or ground etc.) the lock-up occurred.
 

TheRafal

FNG / Fresh Meat
Sep 18, 2011
23
0
0
I have the same problem, but i've got 24Go of Ram and the Rogame.exe use all 24Go !!

TW must fix it !!
 

TheRafal

FNG / Fresh Meat
Sep 18, 2011
23
0
0
TW you must fix IT, we are only 3 maybe more i don't know be we can't use your SDK !!!
 

BOH-rekrut

FNG / Fresh Meat
Oct 20, 2011
556
112
0
germany
tip for this bug :
-don't select any item in the content browser when all asset is loaded
- tip: don't press the all asset button and select the materials
-search for the ENV-packages .there are the materials
 

Hptm. Jaadoo

FNG / Fresh Meat
Sep 15, 2011
74
7
0
I just had the same problem, that SDK uses all RAM and freezes.

Solution:
1. Take a ruler, piece of paper or something like that. and a pencil if necessary
2. start the SDK
3. when it's loaded use the materials above to mark the position of the 'Visible Levels' option in the Content Browser
4. close SDK and restart
6. bring the ruler and mouse cursor in position (mouse cursor right where the option will be)
5. get ready to click 'Visible Levels' as soon as SDK is loaded. you have to be quick

BUT TWI should definetly find a way to fix the problem. A simple reset of the textfield when the SDK is closed should do it.
 
Last edited:

operater

FNG / Fresh Meat
May 17, 2011
36
0
0
Can anyone post your editor config file? Both if you can.
roeditorkeybindings.ini
roeditorusersettings.ini

It is found in the: C:\Users\UserNameHere\Documents\my games\RedOrchestra2\ROGame\Config
 

Nightingale

FNG / Fresh Meat
Sep 15, 2010
872
64
0
Vancouver, Canada
I have the exact same problem. I can't upload .ini files, so I'll just paste them in here:

ROEditorKeyBindings.ini
Spoiler!


ROEditorUserSettings.ini
Spoiler!
 
Last edited:

shakenbake

FNG / Fresh Meat
Sep 22, 2011
310
89
0
USA
This problem has put my map project to a screeching halt....SDK crashes for me so frequently now I'm afraid to try and load any assets. Please fix so we can get full use of the SDK.

Thank you.