Red Orchestra won't start!

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

lebeaux

FNG / Fresh Meat
Mar 16, 2006
6
0
0
Red orchestra won't start, instead I get this error:

"
Build RedOrchestra_Build_[2005-11-27_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel Unknown processor @ 3018 MHz with 1023MB RAM
Video: No Video

Direct3DCreate8 failed.

History: CreateDirect3D <- UD3D9RenderDevice::Init <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free
"

What can this mean? I have the following system:

Processor Information:
Vendor: GenuineIntel
Speed: 3015 Mhz
HyperThreading: Supported
RDTSC: Supported
CMOV: Supported
FCMOV: Supported
SSE: Supported
SSE2: Supported
3DNOW: Unsupported

Windows Version:
XP (Build 2600) (32 bit)

Video Card:
Driver: NVIDIA GeForce FX 5500
DirectX Driver Name: nv4_disp.dll
DirectX Driver Version: 6.14.10.5655
DirectX Card: NVIDIA GeForce FX 5500
Primary Display Resolution: 1280 x 1024

I also have DirectX 9b.

Does anyone know what might be causing this?
 

daschewy

FNG / Fresh Meat
Jan 9, 2006
1,514
16
0
34
Yuppie
try upgrading to directx 9.0c, or you can go into your redorchestra.ini and try changing the rendering device from direct3d9.0 to either direct3d or openGL.

to change to a different rendering device:

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice

change it so that it looks like this:

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=D3DDrv.D3DRenderDevice
 

lebeaux

FNG / Fresh Meat
Mar 16, 2006
6
0
0
Worked like a charm! The game runs great now. Thanks dasChewy, you're a good guy.
 

Rom3

FNG / Fresh Meat
May 19, 2019
1
0
0
26
[h=2]Red Orchestra won't start!::: i got this message Build RedOrchestra_Build_[2005-11-27_10.48]

OS: Windows NT 6.2 (Build: 9200)
CPU: AuthenticAMD Unknown processor @ 3595 MHz with 2047MB RAM
Video: No Video

General protection fault!

History: UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Realloc <- E0660000 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free <- FMallocWindows::Free[/h] can some one HEPL please, i read a comment form daschewy: but i do not know where the r redorchestra.ini i dont understand what ini is??? i posted an attachment, it only does it with red orchestra.Osfront 41-45 when i opened for first time i wanted to change the video tried 3d, and tried one that said software and when i did the change got the error, now wont start