Problem with Hemoclobber

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

NightcrawlerD.A.R.24

FNG / Fresh Meat
May 26, 2019
2
0
1
30
The Hemoclobber dont selfheal in SOLO Mode in any types of map (official comunity and workshop maps) Please fix this problem thanks
 

GigaBowserX

Member
Jun 10, 2019
61
13
8
This is still happening, and I only just realized it myself. I've tried using Hemoclobber on both Berserker and Medic, as well as off-perks. I've played it on a bunch of different maps solo, and it never self-heals. This is kind of a big problem, because you often need that weapon as a primary for on-perks and as backup for its utility on off-perks.

I haven't noticed if it's self-healing or not on multiplayer. I'm pretty sure it's healing players around me, but I'd have to pay more attention now that I know this is an issue.
 

GigaBowserX

Member
Jun 10, 2019
61
13
8
This was first reported in June on PS4
hope they fix it
Yeah, I'm on PC (Steam) and same thing. It's a shame, because the Hemoclobber has been one of my bread-and-butter go-to weapons for Berserker and for self-healing utility on off-perks.

EDIT: I've done some testing, and the Hemoclobber does work for self-healing on multiplayer. I don't know why the singleplayer is broken. Since you mentioned this was first reported in June, I'm assuming the summer update was what broke it. Unfortunately, Tripwire only seems to fix things in their quarterly updates, so it will be a while before this is rectified, if they even decide to fix it at all.
 
Last edited:

GigaBowserX

Member
Jun 10, 2019
61
13
8
Okay, I don't know why, but it's suddenly healing again on singleplayer. Not sure if it's a freak accident that it's working, or if they actually fixed it, or whatever, but I'll keep an eye on it to see if it stops working again.

EDIT: It stopped working again, but I'm not really sure why. It's like no matter which map, mode, or difficulty I play on singleplayer, the Hemoclobber starts out healing me, but then it just stops for apparently no reason after several matches. What I do know is that quitting and then restarting the game seems to fix it, at least temporarily. It still stops working eventually, and then you have to restart again.
 
Last edited: