RO2 Problem joining servers

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

kpmh2001

FNG / Fresh Meat
Mar 27, 2017
1
0
0
35
whenever i join a server it loads normally, then i am put into a screen where i will see the map, grass will move and water will flow but there are no players, there is also no menu asking me what team to join and what class i want, there is also no map. when i try to exit through the menu it does not work, the only two keys that work are the console and shift+Tab to get to the steam overlay. I have tried console commands, allowing the game through my firewall, a fresh install, verifying the cache, and deleteing the non-steam red orchestra file. my specs are as follows.
Proccessor: AMD A8-5600K APU dual core 3.6 ghz overclocked to 3.9 ghz.
Graphics card: AMD rx480 with 8 gb video ram
Ram: 8 gm
OS: windows 10 64 bit
If you need any additional information just ask, any help would be welcome.