[Tuning] PPsh choppy firing

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

RobDollar

FNG / Fresh Meat
May 16, 2009
181
28
0
The PPsh for me is firing very odd, the best way to describe it is its firing so fast that the game / my pc can't keep up with it. The sound seems choppy and the firing is delayed slightly, and seems uncontrollable for a second or so.

The game runs perfect for me on high settings, a low of 43 fps, most of the time 55-60 fps. All other guns are fine and fire perfectly, notably the mp40 smg works fine.

Is this an issue for anyone else?

Specs are: amd quad, nvidia 9800, 4gb RAM, winxp 32

edit: this happens on all servers, most of the server I play on are sub 50 latency.
 
Last edited:

GanglarToronto

FNG / Fresh Meat
Aug 25, 2011
30
10
0
I was about to make a thread on this, but that awesome thread finder swatted my stupid finger from spamming with another.

I can confirm the OP. the game likes to microstutter when firing the ppsh. I have tried holding fire down, bursting, single shotting, all the same. The game clearly microstutters when you shoot this gun.
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
32
Falmouth UK
you could try setting your precache memory size for audio from 0 to something else. Its probably called audiopoolsize or something similar in the roengine.ini
 

GoddangGurnades

FNG / Fresh Meat
Sep 27, 2011
27
33
0
I have this too.

My case is that the gun generally causes a lag spike. I'd estimate it at 0.4 second spike after a 0.7 second burst, usually finding myself dead afterwords. Indeed, it seems that the gun is too much for the engine. This sometimes occurs with the DP28, but not the MG34, so it may or may not have any correlation to the weapons rate of fire.
 

Colt .45 killer

Grizzled Veteran
May 19, 2006
3,998
775
113
Sound is CPU based. Something that spams sound like a Papasha will do that to your rig if your CPU is already struggeling with the game.


For my Qcore cpu in the tests I did I went from 90 fps to 55 firing a ppsh drum.
 

Shepkoval

FNG / Fresh Meat
Apr 14, 2006
90
70
0
you could try setting your precache memory size for audio from 0 to something else. Its probably called audiopoolsize or something similar in the roengine.ini

I tried that with 256, didn't change a thing. I don't know what I'm doing so if that's not a reasonable value please give me a pointer.