• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Potential Fixes For Loading Issues

ffjason

FNG / Fresh Meat
Oct 23, 2009
205
0
0
I disabled the pagefile and all seemed good, though i only tested it for a limited amount of time because another game required me to have the pagefile enabled. So since then I haven't found a fix.
 

Mateos

FNG / Fresh Meat
Jan 10, 2010
92
3
0
27
France
www.harryhomers.org
Hello,

I've tested evything... Custom System folder, efit the INI file, windowed game, everything on Low or disabled... It takes 1/2 minutes to load ><"

Well, the instant lag on longer happen, or just 1/2 times...

Is it needed that I post my rig?

Thanks :)
 

Grimlock

FNG / Fresh Meat
Mar 20, 2009
8
0
0
Hi

I am also having some loading issues. First my pc specs:

AMD XP 3000+ (Core Barton)
Nvidia 7800 gs 512 mb with the WHQL drivers version 195.62
2GB of RAM
Windows XP SP3 fully updated
DirectX 9.0c fully updated
My harddisks are regularity defragmented with Mydefrag
I am running the game in window mode 1024x768 DirectX 9.
I have Avira antivirus installed but I have the steam folder in the exceptions of the
Avira guard.

Normally the levels load in less than a minute but when the problem happens it
takes about 4 minutes to load. (99% of the cpu time in task manager and about
350 MB of ram in use by the killingfloor.exe process)

And some times when I close the game, the killingfloor.exe process doesn't close
and it appears in the process tab in task manager using the 99% of the cpu and the
350 MB of ram.

While I am playing the game, it takes about 70%~80% of the cpu and about 600 MB of ram.

I have tried the following suggestion without succes:

http://forums.tripwireinteractive.com/showpost.php?p=522888&postcount=8[url]http://forums.tripwireinteractive.com/showpost.php?p=522888&postcount=8[/URL]

The options 1,2 and 4 from here

http://forums.tripwireinteractive.com/showpost.php?p=507585&postcount=1[url]http://forums.tripwireinteractive.com/showpost.php?p=507585&postcount=1[/URL]

and finally this

http://forums.tripwireinteractive.com/showpost.php?p=523092&postcount=26[url]http://forums.tripwireinteractive.com/showpost.php?p=523092&postcount=26[/URL]

I also tried to run the game without the pagefile but again the long load times still happens.

Hope this can help.
 

Grimlock

FNG / Fresh Meat
Mar 20, 2009
8
0
0
Hi Zetsumei

In the Killing floor settings configuration the only renders devices that I have available
are the following:

Direct3D 9
Direct3D
Software

So I have changed the render device in
 

Mateos

FNG / Fresh Meat
Jan 10, 2010
92
3
0
27
France
www.harryhomers.org
It seems that there's the same issue on Team Fortress 2, and it seems that it also happened after a update. The only link is Avast... I've set my whole Steam folder in the Exclude List, but it seems to do nothing. Grimlock, do you have Avast?
 

Grimlock

FNG / Fresh Meat
Mar 20, 2009
8
0
0
Hi Mateos.


No, I don't have Avast installed and I didn't had it installed in the past, only Avira antivirus.
 

Grimlock

FNG / Fresh Meat
Mar 20, 2009
8
0
0
I have changed to DirectX 8 and it seems to help a bit, when the long load time occurs, it now takes
about 2 ~ 3 minutes to load the new map.

Edit: After playing some games the game performance with DirectX 8 is worse than with DirectX 9 and the game tends to crash.
 
Last edited:

Sarkazmo

FNG / Fresh Meat
Feb 23, 2010
11
0
0
So... is this issue ever going to be fixed? FOUR months now that this issue's been known about and still there's no patch.

After every single map I have to quit KF, kill the process, restart, then try to find the same server again if a friend is not on there. ALMOST EVERY SINGLE TIME this is what I have to do! I LOVE THIS GAME! I really do, but this bug is pissing me off to the point where I just don't want the hassle and will play something else.

What have I tried?? Here's the list:
Deleted local content and re-downloaded the whole game
Deleted SYSTEM folder and downloaded from another Steam server
Changed cache size
Disabled caching
bnevercache true
DX9
DX8
OpenGL (Makes Stalkers look like they're made of liquid mercury all the time)
Different resolutions
White listed all of STEAM in Avast
Changed Sound Drivers
Changed Video Drivers

None of these have made the game work the way it should. I've had times when several maps in a row would load but then it would just start failing over and over again.

My Computer:
XP Pro SP2
MSI K9N2 Platinum
AMD 5000+ Retail
2Gigs of G.Skill RAM
Palit nVidia 9600GT w/1Gig of ram
All drivers are up to date. Using latest nVidia reference drivers (195.62)

Things I've noticed about this bug:
It doesn't always happen
If you leave a map before the end of the game you can load the next map on a different server without issue.
Sometimes Alt-Tabbing and going back into the game will make it connect.
Sometimes no matter how much you mash F10, Alt-Tab, or CTRL-ALT-DEL it will take several minutes before actually getting back to the desktop.

My partner's machine is similar to mine but ran the game flawlessly up until a couple days ago and now she's got the same issue!!!! This is frustrating us to no end. It's like a wonderful mean that leaves a bitter taste so bad that you wonder whether or not it's worth it.

Sark
 

Sarkazmo

FNG / Fresh Meat
Feb 23, 2010
11
0
0
I noticed something today when KF was changing maps.

I'd let KF go ahead and try to load at the map change but I'd tabbed out to Windows. It was stuck and not loading the map to get to the READY UP screen. So I was watching KF's process. It was using 50% cpu and only one core of the two. It was de-allocating RAM but it was going VERY slowly, like a few hundred K per refresh or so. When it got down to a little over 100 megs allocated it's memory usage jumped to 500+megs and KF loaded the READY UP screen!!! When I exit KF after end game KF will stay resident in memory for a long time. During this time KF's de-allocating RAM VERY slowly as well. It will get down to about 86megs then it suddenly dumps the rest and exits cleanly. Something is happening at end game. Whether or not the squad's successful or wiped out if I let KF get to end game without exiting it will have trouble loading the next map. If I disconnect before end game and select another server or wait til the server has cycled the map to reconnect it loads normally.

So what's happening in the engine when KF reaches end game that's hosing the loading of another map???

Sark
 

Dr_Quake

FNG / Fresh Meat
Jan 21, 2010
26
0
0
IMHO apply all fixes and it WILL NOT HELP with forever loading screen, but will help w/freezes => neccessary, so use f10/esc and connect twice/triple/etc times until connected...
 

Olivier

Grizzled Veteran
Jan 19, 2010
3,654
1,071
113
Running KF in a windowed mode works for me... but only like 3-4 times. I need to close KF and restart it to work again.
 

drakeaustin

FNG / Fresh Meat
Mar 31, 2010
1
0
0
I don't understand.

I don't understand.

I am having trouble understanding what is going on and i would be really grateful if someone could make a video to show me how to fix it. :confused:
 

Mateos

FNG / Fresh Meat
Jan 10, 2010
92
3
0
27
France
www.harryhomers.org
So:
- Loading never finish whne the second map is loading.
- Loading never finish when a custom map just been downloaded (Sometimes)

During this time, I look at my computer. It is like he does nothing: no noise. I think it's the same for Sarkazmo. It seems that the game does not want to load a second map... Can't he unload the one before? Do it try to unloading/loading in same time?

The most part of players leave the server when the map is ending. When I bought the game I didn't understand. On the 1st day playing I've understood ><"

Probably, it is needed to force the game to load the map? Why doesn't it do it?