• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Optimization hasn't changed anything!

Tagemandbagem

FNG / Fresh Meat
May 5, 2011
86
21
0
x64 here as well, and I'm getting, on some maps, 20-30FPS.

But it doesn't FEEL like that for some reason. It feels more like the 45-50FPS I get on other maps.

Maybe it's the Ultra settings/textures? I have noticed, at the start of every round, my character's texture loads in slow motion.
 

wazups2x

FNG / Fresh Meat
Jun 30, 2011
228
77
0
steamcommunity.com
i advise everyone who is getting bad performance to do the following..

1. download a driver cleaner (there is plenty out there)
2. uninstall your graphics drivers
3. run the driver cleaner to get the files the uninstaller missed
4. reboot
5. download latest drivers (ensure they are correct drivers)
6. install latest drivers
7. reboot if prompted
8. defrag. (do this at least once a week i also reccomend using defraggler)

its obviously client side now as the game pretty much runs perfect (needs a few minor tweaks to boost performance even more)

im running an AMD Phenom II x2 550 Black Edition @ 3.11ghz, 4gb ram and a HD6870 and im getting a framerate of 80-90..

it cannot be the game if somebody with a dual core is getting framerates higher than people with x4's and x6's... just doesn't make sense...

anyways, the above steps is what i always do when installing new drivers, it may be timely.. but it sure shows its worth it.

also as for my settings, im using a mix of high and ultra.
Yes, it is the game. I can run Bad Company 2 at max settings and it looks better than RO2. I have over 100 games on Steam and they all run perfectly fine, except RO2.

Also, AMD and Intel both recommend installing on top of the previous driver because they are designed to do that nowadays. We're no longer in the old Windows XP and 98 days. Plus, driver sweepers can cause more harm than good a lot of the time.
 
Last edited:

Apex.

FNG / Fresh Meat
Aug 22, 2011
378
162
0
AMD is teh fail, go get Intel CPU + Nvidia card :D

UT3 engine runs better on nvidia cards, and Intel CPUs are in general better than AMD.
such a clueless post, afaik, AMD still have the better video cards, yes the i7 sure is better, even though games such as black ops and RO2 bring it to its knees rofl, when me and my AMD duel core eat them alive.
 

Apex.

FNG / Fresh Meat
Aug 22, 2011
378
162
0
Yes, it is the game. I can run Bad Company 2 at max settings and it looks better than RO2. I have over 100 games on Steam and they all run perfectly fine, except RO2.

Also, AMD and Intel both recommend installing on top of the previous driver because they are designed to do that nowadays. We're no longer in the old Windows XP and 98 days. Plus, driver sweepers can cause more harm than good a lot of the time.
i can run BC2 at max too, and RO2.. how come im getting good performance on both and you only get good performance on one?

the game is fine now after the latest patch, TW have done the optimizing.. now people need to optimize there PC's (as the steps i posted)

AMD and Intel reccomend that? yet im talking about graphics drivers, not CPU drivers..... driver sweepers cause NO harm at all..
 

Cablespider

FNG / Fresh Meat
Mar 19, 2006
26
5
0
Occupied Chicago
Yes, it is the game. I can run Bad Company 2 at max settings and it looks better than RO2. I have over 100 games on Steam and they all run perfectly fine, except RO2.

Also, AMD and Intel both recommend installing on top of the previous driver because they are designed to do that nowadays. We're no longer in the old Windows XP and 98 days. Plus, driver sweepers can cause more harm than good a lot of the time.
And how long has BC2 been out now? BC2 did not run well out of the box. ATI users suffered for quite some time before that got ironed out.

Give TWI some time to work with the video card makers. Drivers are out of their control. This is nothing new.
 
Last edited:

Deek

FNG / Fresh Meat
May 28, 2008
218
12
0
The new maps run smooth as silk on my rig with shadows at low, AA at medium and everything else at ultra. Vsync enabled (I hate tearing), I rarely see it dip under 60. Both shadows and AA kick my ***, though.

... unlike the last build, where I was lucky to be mid 30 to low 40. This was with the majority of settings reduced to High or lower.

Granted, I have okay-ish hardware:

i7 920
285 GTX
6gb 1600mhz
Win 7 64-bit

I also keep my PC clean. I'm pretty OCD about running sweepers, cleaners, registry mechanics, keeping drivers up to date, all that good stuff.
 
Last edited:

Apex.

FNG / Fresh Meat
Aug 22, 2011
378
162
0
anyways, has anyone here installed UDK? did they install CPU drivers with it? whenever i've installed UDK, it installs "AMD CPU Drivers".

has anyone with an Intel installed it? does it say something along the lines of Intel CPU Drivers"?
 

wazups2x

FNG / Fresh Meat
Jun 30, 2011
228
77
0
steamcommunity.com
i can run BC2 at max too, and RO2.. how come im getting good performance on both and you only get good performance on one?

the game is fine now after the latest patch, TW have done the optimizing.. now people need to optimize there PC's (as the steps i posted)

AMD and Intel reccomend that? yet im talking about graphics drivers, not CPU drivers..... driver sweepers cause NO harm at all..
You are very lucky then. The game is NOT fine for many people. Seriously, read the forum!

I AM talking about GRAPHICS DRIVERS. It is recommended to install over the previous driver because both AMD and Intel's software is designed to correctly remove the old and install the new.

Driver cleaners can cause harm, they can remove the wrong things from the registry if you don't know what you are doing. They are just not needed, if they were AMD and Intel would recommend using them. And I used to use them all the time. Driver sweep, CCleaner, etc.. Now I've completely stopped and everythings been great.

The only time you would want to use them is under the rare circumstance when a graphics driver became corrupted and you have to completely uninstall and remove everything.
 
Last edited:

breadtruck

Active member
Nov 21, 2005
770
84
28
Wisconsin, USA
Processor: AMD Phenom II X6 1075T Processor 3 GHz
RAM: 4GB
System type: Windows 7 64 bit
Case: Cooler Master Elite 430
PSU: OCZ StealthXstreamII 500
GPU: MSI ATI Radeon HD 6950 OC Twin FrozR III Power Edition 2048MB GDDR5 PCI-Express
Motherboard: ASRock M3A770DE AM3

I still only get 15 fps at any settings on 64 players, and only 20-25 on 16 player games! I have tried that umbra thing without any gain. On every other game, my gpu usage is always 99%, on here it goes from 80 to 0 to 60 etc. It needs fixing!
Dude, I found your problem. You need to upgrade your case.
 

Full Frontal Yeti

FNG / Fresh Meat
Sep 7, 2011
44
11
0
AMD 965BE(3.4 Ghz)
4GB 1600
OC'd 580
Win 7 64

I probably avg. about 60-70 FPS
i do get more range in this game then most.
i can drop to 20 or so sometimes but it's just spikes from time to time never stays that way. just a quick 1/2-3 sec. drop. Mostly when entering new areas(buildings), or arty in my area.


Maybe a new vid card would help you a bit, but i have seen a lot of talk about this game being heavy on the CPU.
Temps. for me indicate this is true, as my vid card is generally a good 8-10c less then in other games.


In general though there has been a lot of FPS issues for many people regardless of CPU/Vid card.

I've seen posts from people with almost same rigs getting seriously different FPS in game.

I removed the frame smoothing option and got about 8-10 more fps.
I have all the settings on High
with bloom and ambi light turned off.
(ambi for fps, bloom so i can see uniforms better)


Also the other day(after latest update), in game i decided to drop my res to 1080 from 1200.
While in game.
My FPS went to poo, dropped to a range of 17-30 at best.
Put it back to 1200 and the fps went right back to the 60 range.
So obviously they are still working out some kinks.
i would wait until a month after game release to get any new hardware for this game. they make improvements that get your FPS up without new hardware.

If you do need hardware still at that time I'd look to the vid card first as the CPU you have is on par with mine(yours has some newer features/optimizations, mine has a higher clock speed).
But do wait it out, beta is not the thing to base your plans on.


Dude, I found your problem. You need to upgrade your case.
Oh and he may be right, but you should try painting some flames on the side first. Everyone knows flames make it go faster
 
  • Like
Reactions: 11_HARLEY_11

Fisher

FNG / Fresh Meat
Sep 4, 2011
489
73
0
Crawley, England
Old system, prolly needs to be upgraded.

lol
Shutup, you obviously know nothing about PC's, this is very new. It's not mine or anyone else's hardware (excluding those who don't meet minimum) that's causing the problems.
 

flavin420

FNG / Fresh Meat
Oct 2, 2009
308
49
0
Yep, game doesn't perform any better for me after patch.

CPU: AMD Phenom II X4 955 Black Ed
RAM: 4GB
OS: Windows 7 64 bit
GPU: Sapphire ATI Radeon HD 4890 OC

My brother also has terrible performance.

CPU: AMD Phenom II X4 940
RAM: 4GB
OS: Windows Vista 64 bit
GPU: Sapphire ATI Radeon HD 4850x2
Wish i had a brother, I havent played beta yet since i just comp parts in today and figure ill just wait to final release, hope most of this gets fixed up by the 13th, i have my faith that TWI will not let this lack of optimization be allowed, and fix it one way or another, b4 or after the 13th is the :confused:
 

Titulus

FNG / Fresh Meat
Aug 11, 2011
42
5
0
Before on 64 player servers (all I play really) I got ~40 fps on high/ultra with ~80% gpu utilization. Now I get ~50 fps, slightly more pop-in (depth of field turned off) and about 90% gpu utilization at 1080p with low level AA on. I'm not complaining.

Might be an AMD thing.
 

Apex.

FNG / Fresh Meat
Aug 22, 2011
378
162
0
I AM talking about GRAPHICS DRIVERS. It is recommended to install over the previous driver because both AMD and Intel's software is designed to correctly remove the old and install the new.

Driver cleaners can cause harm, they can remove the wrong things from the registry if you don't know what you are doing. They are just not needed, if they were AMD and Intel would recommend using them. And I used to use them all the time. Driver sweep, CCleaner, etc.. Now I've completely stopped and everythings been great.

The only time you would want to use them is under the rare circumstance when a graphics driver became corrupted and you have to completely uninstall and remove everything.
got a source? if not, i call bs, i've been using them for years and have 0 problems, however i've had a few problems just installing drivers over previous versions... and this is with the newer drivers.
 

Maizel

FNG / Fresh Meat
Jan 21, 2011
973
372
0
i5 2500k @ 4.2
Crossfired 6970 (which is really just a single since Crossifre doesn;t work, which just ilustrates how optimized it is)
16GB Ram

My fps varies from 20-90. While this should be much hire if only crossfire were working and the game has 100% GPU usage. My biggest gripe is that on some maps my gpy usage, fluctuates about 10 times a minute, giving very choppy framerates. On a system that should really be able to play at least 70+ at all times.

Slowdowns when turning a corner, when getting shot, artillery and pretty much looking down some traintracks bring my fps down to its knees.


This should really get fixed befpore release. I think RO2's shelflife and a part of the playerbase is at risk if they don;t.
 
Last edited:
  • Like
Reactions: Qweets

CrazyFingers

FNG / Fresh Meat
Aug 14, 2011
330
115
0
Canada
I also have a bad performance

Ga-Ep35-ds3p
E8500 3.8ghz
4gb DDR2 PC2-8500 Reaper HPC Edition
Evga Gtx 275
Onboard sound card RealTek ALC889a
Sata hardrive 7200 rpm

I get 40-50 fps on medium with 1920x1080
 

Apex.

FNG / Fresh Meat
Aug 22, 2011
378
162
0
to all these people blaming the game cause of performance with there crossfire/sli setups.. read below.. and stop being so arrogant..


Crossfire/Sli isn't working because nvidia/ati haven't done the drivers yet, it will most probably be supported in there next drivers
 

Sasha Fedorov

FNG / Fresh Meat
Aug 10, 2009
19
0
0
Sweden
I'm sure the problem is NOT in our PCs. How can I know it?
It is very simple. I can play games like Brink, BC2, Stalker CS, WoW, WoT, Arma2 with everything on high or with some AA off. But not this one, even if I put everything except textures and details on low and connect to a 40p server.
So the problem is somewhere in the game or most likely drivers.
I even reinstalled the OS, defragmented the hdd and updated all the drivers. Everything was useless.
BTW I'm using 280.26 , they crashed twice while I was playing RO beta. Which one the rest of you are using?