• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

KF No achievements with kill count mod

alter_schwede17

FNG / Fresh Meat
Oct 21, 2012
3
0
0
Ok, I've been having a weird problem. I often play on Mac OS 10.9 and cannot seem to get map achievements when playing on servers that have this mod activated where the kills pop up in green writing (although it's whitelisted).
None of the people I'm playing with (all Windows-users) have had this problem so I guess it's just Mac. I just get the survival-screen like I always do, nothing special.

It's pretty irritating when you just finished a map on HoE so I'd be glad if anyone could help me out here.
 

nd2spd

FNG / Fresh Meat
Aug 24, 2011
1,095
0
0
Vic Australia
www.facebook.com
It's something to do with mac clients downloading mutators to the wrong location I think.
I think you have to move (& rename) the files in a cache of sorts and install them properly into your KF install for them to work whitelisted.

There's some threads on here that explain the process better, do a google search for 'mac killing floor perk progress' or something and you should find it. Gl
 

alter_schwede17

FNG / Fresh Meat
Oct 21, 2012
3
0
0
Thanks for the answer.

I know where the mutators I downloaded myself are (.../KF/System) but I can't find any that were installed when I joined servers. Guess I'll keep looking.
And apparently there's a ~/.killingfloor folder under Linux but I can't find anything like that on Mac.

Curiously I can't find this mutator on a whitelist so far. Is there even a complete up-to-date whitelist atm?
 

nd2spd

FNG / Fresh Meat
Aug 24, 2011
1,095
0
0
Vic Australia
www.facebook.com
Oh I probably got the issue mixed up with linux users.
On windows, the stuff is in killingfloor\cache\ maybe it's same/similar for mac, the text file in there will tell you what is what. Maybe you could try deleting the whole cache folder.
And/or install version 2 & 3 of specimen kill messages manually so KF doesn't use cache versions.
 

alter_schwede17

FNG / Fresh Meat
Oct 21, 2012
3
0
0
No cache folder so far. Do you mean a text file in that cache folder?

I installed it manually and got no achievement but I didn't activate it in-game through solo mode. Would I have to do that for it to work?
 

vykuu

FNG / Fresh Meat
Jun 4, 2014
3
0
0
Fixed

Fixed

Hi, the process to fix it is almost the same as linux users:

1) go to "/Users/Owner/Library/Application Support/Killing Floor/cache"
2) In this folder, you will see a bunch of stuff with .uxx endings. You need to look at the cache.ini file (open it with a text editor, or if you know how just do "cat cache.ini" in terminal) to see what the files actually are.
3) Look for the files with .u in them in cache.ini, and look at the number before the filename. Move the corresponding file from the cache folder, to
/Users/Owner/Library/Application Support/Steam/SteamApps/common/KillingFloor/System

4) If you have python (which all macs do I believe) while I was learning to code I wrote this (really crummily written) program to help automate the process. You can run it from the cache folder. You can save the below script in the cache folder as kfscript.py, then run it with python kfscript.py. I'm not sure if pasting it here will mess up indentation or not

Code:
import subprocess
import shutil
import re
import os

output = subprocess.check_output(['cat','cache.ini'])



array = [w for w in re.split('=|\n|\.',output) if w]
junk = array.pop(0)


for i in xrange (0,len(array)/3):
    source =  array[3*i] + '.uxx'
    if array[3*i + 2] == 'rom':
        destination = os.sep + os.path.join('Users','Owner','Library','Application Support','Steam','SteamApps','common','KillingFloor','Maps') + os.sep + array[3*i + 1] + '.rom'
        shutil.move(source,destination)
        output =  subprocess.check_output(['grep','-v',array[3*i],'cache.ini'])
        os.remove('cache.ini')
        f = open('cache.ini','w')
        f.write(output)
        f.close()
      

    if array[3*i + 2] == 'u':
        destination = os.sep + str(os.path.join('Users','Owner','Library','Application Support','Steam','SteamApps','common','KillingFloor','System') + os.sep + array[3*i + 1] + '.u')
        
        shutil.move(source,destination)
        output =  subprocess.check_output(['grep','-v',array[3*i],'cache.ini'])
        os.remove('cache.ini')
        f = open('cache.ini','w')
        f.write(output)
        f.close()