List of possible bugs

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

i76

FNG / Fresh Meat
Dec 27, 2011
98
10
0
Australia
By the way, I have a question regarding the thread itself (META!) :

How can we know if the devs/QA chaps are reading this thread ? :)

I know most of the posts here are way too long :)D) and boring (some original reaction faces would help ?), but we're trying our best to help RO2 becoming the best WW2 game of 2011-2012

Knowing that the gentlemen at TWI are keeping an eye on "us" would greatly warm our little WW2-fans hearts and keep the hope alive :p

I agree.... if they appreciate our free bug testing then they could at least
show the same courtesy... or start up something like
Bohemia Interactive's 'Dev-Heaven'
 
Last edited:

kcbushn

FNG / Fresh Meat
Dec 30, 2011
1
0
0
Receive auto update and now receive error message

Receive auto update and now receive error message

"Failed to find default engine .ini file to retrieve My Documents subdirectory to use. Force quitting."
 

Timbuk

FNG / Fresh Meat
Dec 30, 2011
6
0
0
I cannot see any servers listed (consistent bug - I have checked filter etc)

Sometimes I don't spawn in the inital wave when a level starts and have to reselect my role
 

Gudenrath

FNG / Fresh Meat
Aug 23, 2011
2,135
313
0
At start of round, after having chosen team and role, if you happen to press TAB at the precise moment where the countdown begins (where the players are deployed but can't yet move), your choice of role is cancelled and you won't spawn until having chosen role once more. This seems to happen always.
 

i76

FNG / Fresh Meat
Dec 27, 2011
98
10
0
Australia
I've just notice when promoted and you 'accept' and pick your class you can
still miss first spawn, I think it maybe that another 'promoted' player who
selects his/her class after you've selected yours must steal it... not sure
though.

Only just noticed this in the last few days :S

Also is there any chance of toning down artillery, I feel there are too many
'salvos' or maybe make them more like mortor rounds (smaller)
On arty.... any chance of making it so it can't be dumped right outside of
main/last spawn... it basically causes a spawn lock (meaning you can't
leave spawn for 5 salvos) and can hold an entire team back.

cheers
 

LootFragg

FNG / Fresh Meat
May 28, 2012
30
0
0
That's a huge list of bugs. Didn't read all of them.

• When aiming a gun and switching to another, that other gun will be aimed as well. Weapon switching should disable aiming.
 

spanther

FNG / Fresh Meat
Aug 22, 2011
5
0
0
Annoying reload animation bug

Annoying reload animation bug

It's affecting the reload time too and so the gameplay itself...

If you fire a G41 or Kar98 or whatever rifle and then reload while not all bullets are out, you EVER reload one bullet more in than you had shot out before! o_O

Means you have 5 rounds in Kar98, then you fire 3 out so 2 are left. You press reload but then it reloads 4 (FOUR) rounds back in! And if you fire out 4 rounds, it reloads a whole clip!

I really hope this gets fixed, because it's very annoying and this extra reload time not only once was my dead in close combat...
 

r5cya

FNG / Fresh Meat
Jan 17, 2011
6,048
445
0
San Bruno, California
It's affecting the reload time too and so the gameplay itself...

If you fire a G41 or Kar98 or whatever rifle and then reload while not all bullets are out, you EVER reload one bullet more in than you had shot out before! o_O

Means you have 5 rounds in Kar98, then you fire 3 out so 2 are left. You press reload but then it reloads 4 (FOUR) rounds back in! And if you fire out 4 rounds, it reloads a whole clip!

I really hope this gets fixed, because it's very annoying and this extra reload time not only once was my dead in close combat...
you have auto bolting on, don't you? turn it off. then when you shoot a bolt gun, the avatar won't shove a new round into the chamber before you press "r" to reload. this isn't a bug. it's how rifles work. the g41 is doing it, because it's semi-auto. it loads a fresh round everytime you pull the trigger. then dumps that fresh round on the ground when you reload.
 
Last edited:

spanther

FNG / Fresh Meat
Aug 22, 2011
5
0
0
Oh sorry ^^'

Oh sorry ^^'

you have auto bolting on, don't you? turn it off. then when you shoot a bolt gun, the avatar won't shove a new round into the chamber before you press "r" to reload. this isn't a bug. it's how rifles work. the g41 is doing it, because it's semi-auto. it loads a fresh round everytime you pull the trigger. then dumps that fresh round on the ground when you reload.

Oh now I got it finally...

It was just irritating alot since "no" game before did it this way! So I didn't thought about the bullet chamber still holding one round. Yes, you are right then. But why did RO1 not have this?

In all other games, you ever had 5 total. so still with auto bolting (inside CoD as example) you fired one and reloaded one. Here, it was very confusing, that if you reload, it puts in two, after you only "fired" once! :)

But I now got the point. Since when you put the second in the chamber, it's not fired, but if you press reload, it gets released just like the empty first one too. So there are for real two free spaces now :)

Well, do I lose this one bullet I haven't shot then? xD

Or do I recollect this one? :)

Would be weird if my character wouldn't put it back to the ammo stack, thinking about reality, where he knew, that it wasn't fired empty yet. I can't check this so easily. Somebody knows maybe?
 

Temporary

FNG / Fresh Meat
Jan 26, 2010
211
30
0
Europe, France, Normandy
you have auto bolting on, don't you? turn it off. then when you shoot a bolt gun, the avatar won't shove a new round into the chamber before you press "r" to reload. this isn't a bug. it's how rifles work. the g41 is doing it, because it's semi-auto. it loads a fresh round everytime you pull the trigger. then dumps that fresh round on the ground when you reload.
Yes, but then checking the chamber (holding reload button) would (in real-life) drop that one bullet on the ground, no ?
 

Temporary

FNG / Fresh Meat
Jan 26, 2010
211
30
0
Europe, France, Normandy
Red Orchestra 2 is frequently corrupting the install of .Net Framework 4.0

(at least on Windows 7 based computers - might be the same with .Net Framework 3.0/3.5 for WinXP systems)

This is not the first time it happens, and now I'm sure it's caused by RO2.

Yesterday I launched RO2 (haven't launched it for a week or two), played a few maps, turned off the computer.
nb: I haven't installed, updated or launched any other game. The only softwares I launched were Steam and Firefox 15.0.1.
This afternoon, I launched Steam, then launched RO2, and it happened again: intro video are fine, but once I get to the menu => severe "lag", the cursor and the background animation is stuttering, menu entries take 1 to 2 seconds to respond.

- I tried to validate the cache : it re-downloaded 1 tiny file (less than 500 Kb). Not fixed.

- I ran the UE3Redist executable, it reinstalled everything. Not fixed.

- I "repaired" (bring the current installation back to the original install) Net Framework 4.0 using an installer downloaded on Microsoft official website: it worked again, flawlessly.

-

This bug is not one these "happened once" bug, it happened to me thrice, and several others users reported it, like in this thread.

It's quite a serious problem, as corrupting the .Net Framework install will impact many other softwares relying on it (one of them being Tribes: Ascend, it's not just weird unknown softwares, many other games use it) - now imagine the consequences if it impacts a vital business software...

I hope they'll look into it one day, or at least add it in the list of known-bugs and add a direct link to the Microsoft installer, as the biggest difficulty is knowing it's the .Net Framework that's going haywire.

nb: Developers aren't supposed to mess with the .Net Framework settings/files, they're only supposed to use it as a base for their own settings/files.
 
Last edited:

Temporary

FNG / Fresh Meat
Jan 26, 2010
211
30
0
Europe, France, Normandy
Can't play in single mode and havn't find the way to fix it:

You should create your own thread in the RO2:HOS Support category to have a better chance of finding a solution, here we're trying to list existing bugs (once we found the possible causes), not exactly "fixing" them.

...


Anyway, while we're here, have you tried:

1 - Clicking on the "new campaign" button rather than the "Continue campaign" one ?

...

2 - Going to " C:\Users\ **your Windows user name** \Documents\My Games\RedOrchestra2\ROGame\Config " and cut-and-pasting all the files inside to a backup folder (on your desktop), to force the game to recreate these files ?

nb: If you are using Windows XP, it will probably be in
"C:\Documents and Settings\ **user name** \My Documents\My Games\RedOrchestra2\ROGame\Config".

...

3 - Going to " C:\Program Files\Steam\steamapps\common\red orchestra 2\Binaries\Win32\Saves ", cut-and-pasting all the files inside a backup folder (on your desktop), to see if starting a brand new campaign (without any saves) fix that bug.

...

Good luck ! :)
 
Last edited:

Witchfinder

FNG / Fresh Meat
Nov 24, 2012
2
0
0
Anyone else having problem like this? It's kinda annoying, but it goes away when reconnecting to server.
 

Attachments

  • 2012-11-25_00001.jpg
    2012-11-25_00001.jpg
    50.6 KB · Views: 0

Zidious G

FNG / Fresh Meat
Nov 26, 2012
343
6
0
Sweden
List of bugs

List of bugs

I have got a couple of bugs.

First, the reloading of the SVT40, AVT and G41. Sometimes he replaces the clip from below, changing the entire clip at once, but sometimes he puts in bullets from the top, like a Kar98 rifle, which takes a longer time. Is it supposed to be like this?

Second, I became a Hero at Elite Assault before I was lvl 80. When my honor catched up, the ranking bugged. Sometimes it shows up as a hero, sometimes as highly decorated. Fix?

Third, the chat before a match begins. Only some servers has it. When you type something and hit the space button, it jumps back to class selection screen. Kind of annoying.

Fourth, the reloading of the mg34. Sometimes he puts in halv full or close to empty-magasines. Why?

Fifht, sometimes on some custom maps, the aim is off then aiming down the sight. I can cleary see the shots hitting to the left. At ranges of like 50 meters, the shots go about 1-2 meters to the left. Mostly occurs when zooming while aiming down the sight.
 

Carlestia

FNG / Fresh Meat
May 18, 2013
1
0
0
Every time I launch Rising Storm or Red Orchestra 2, there is no menu whatsoever, however, I can browse servers, start singleplayer, tweak graphics, and select roles. That's it.

It's so annoying too, I can't change weapons, upgrade them, or adjust sound or controls.

Hope you can help. Seriously game breaking.
 

sollitdude

FNG / Fresh Meat
May 22, 2013
3
0
0
there is a bug with the flamethrower, tho i dont know if anyone else has it.

sometimes, i press R and it says the tank feels close to empty, sometimes when its half full, but it wont work. it doesnt want to fire anymore with some gas left in the tank. a refill usually fix this.

i noticed it started happening once i unlocked weapon level 50 for it.