• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Known Issues and Fixes

Status
Not open for further replies.

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,216
3,430
113
First up some people are reporting flickering and a black screen on launch. Also if your system seems to be having graphical lag you will also want to try this.

To fix open up your killingfloor.ini file (located in steam/steamapps/common/killingfloor/system)

find

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice

and change it to

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=D3DDrv.D3DRenderDevice

You will also want to change your resolution to your desired. In the same ini file look for:

[WinDrv.WindowsClient]
WindowedViewportX=800
WindowedViewportY=600
FullscreenViewportX=800
FullscreenViewportY=600

And change the Full Screen and windowed to your desired resolution for full screen and windowed mode.

Save the file and launch KF again.


______________________________

Another options to try turning off if you have graphical lag is the "reduce mouse lag". Several users have reported with this off they greatly increase frames.

______________________________

For those seeing a message asking for UT stats login, the server admins of those servers need to turn that off.

bEnableStatLogging=False


___________________________________________________

Failed to connect to Killing Floor servers in multiplayer

Odds are your router/firewall is blocking Killing Floor connections. You might need to open some of or all of the ports listed here: http://forums.tripwireinteractive.com/showthread.php?t=30727

Also users are reporting that unchecking Dynamic Net Speed in options has fixed a connection failed issue.


________________________________________________

Behind a router/firewall with ports open and forwarded but still having problems:

You might want to switch the following setting in your killingfloor.ini:

ServerBehindNAT=False

To: =True


_______________________________________________

You've had your game update but you still don't see servers or have connection issues?

Try going to your killingfloor/system folder and deleting the entire system folder and letting steam regenerate it from the new build. Some configuration settings might not have been reset which are keeping you from receiving changes in the update.
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,216
3,430
113
Updated and reserved post slot
 
Status
Not open for further replies.