• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Killing Floor refuses to see my RAM. 2GB=261MB? And kills my FPS accordingly?

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
Killing Floor recently has been reluctant to notice that my PC has 2GB of RAM and insists that I only have 261MB of RAM. The error messages say it, memstat says it and Task Manager says KF uses no more than it. Ever since this has occured, my FPS have been dropping whenever I encounter 15+ Zeds. I am stumped. I am able to play, but the lag is becoming unbearable amongst the hoards.

I have tried resetting my RAM overclock, I have tried deleting the KF .ini and I have tried changing the KF cache from 32MB to 256MB (also further evidence it doesn't read the additional RAM, as it used to be 256MB by default). None of these worked and the problem seems to be getting worse as more of my regular buddies are playing more.

Ever since the first day of enjoying Killing Floor, my FPS has been locked at a solid 75FPS regardless of Zed count (even when I had 70+ Gorefasts on the screen). The hardware isn't lagging behind so it appears.

These are the specs of my PC:
ASUS P7P55D PRO [QPI@3612Mhz]
Intel Core i5 Quad-Core @ 3800Mhz [200x19]
OCZ XTC 2Gb DDR3 PC3-16000 @2000Mhz 8-9-9-27-79 [1Gbx2]
Sapphire Radeon 5850 1Gb GDDR5 1.287vCore @ 870Mhz/1100Mhz

Thanks,
Sheepy.
 

Olivier

Grizzled Veteran
Jan 19, 2010
3,654
1,071
113
Dont think it could help, but you could always try to switch your RAM sticks. And that's the first time i see a quad-core with a 1Gb GPU with a total of 2Gb DDR3.
 

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
I was considering that, I'll try that tonight.

Yes, it seems an odd combination at the moment, but there was a time where I had 4Gb of the stuff in a 4x1Gb arrangement, but 2 of the sticks proved faulty, so now I am down to 2Gb. A new kit shall be around by the end of the year nonetheless. I know it's not faulty RAM that's bringing this error to light because it has passed numerous stress tests and what not and has proved 110% reliable along with every other application I've used being able to fill the things.

The error did only start occuring after the update, which I think may be something to do with it. Specifically the update with the MAC10 (excuse me not knowing the version number :rolleyes:) I have deleted and reinstalled twice and the problem keeps re-appearing.

Thanks,
Sheepy.
 

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
Okay, resitting the RAM didn't work. But disabling the paging file stop KF from running at all. If I disable it, KF crashes upon trying to render an image. It is clearly depending upon the pagefile for memory. Any ideas?
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
If you're certain that it wasn't present before the update I'd suggest you browse to your killingfloor directory in steam/steamapps/common and delete the system directory. Launch KF and it will download these files again. If you uninstalled KF through Steam then it leaves some files there, deleting the system folder will make sure that everything is reset to defaults.
 

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
Well, after: deleting the local cache, then deleting everything in the KF folder, then redownloading KF and reinstalling, the problem still remains. :/
 

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
Okay, I set my virtual memory to 10Gb on my RAID0 drive (1tb, but short striped to 200GB). It ran fine, although the FPS only seems to drop when on Manor, when outside the front door, with zeds on the screen.

My KF just crashed with this error also if this makes any difference.

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows 98 4.10 (Build: 67766446)
CPU: GenuineIntel PentiumPro-class processor @ 3813 MHz with 255MB RAM
Video: ATI Radeon HD 5800 Series (1047)

Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.

History: FMallocWindows::Malloc <- FMallocWindows::Realloc <- 00000000 4194304 FArray <- FArray::Realloc <- 4194304*1 <- TArray<< <- TLazyArray::Load <- FStaticTexture::GetTextureData <- KillingFloorOfficeTextures.Statics.Broken_Wall <- FD3D9Texture::Cache <- FD3D9RenderInterface::CacheTexture <- FD3D9RenderInterface::HandleCombinedMaterial <- FD3D9RenderInterface::HandleCombinedMaterial <- FD3D9RenderInterface::HandleCombinedMaterial <- FD3D9RenderInterface::HandleCombinedMaterial <- FD3D9RenderInterface::SetShaderMaterial <- FD3D9RenderInterface::SetMaterial <- FBspDrawList::Render <- RenderLevel <- KF-WestLondon.myLevel <- FLevelSceneNode::Render <- RenderLevel <- KF-WestLondon.myLevel <- FLevelSceneNode::Render <- RenderLevel <- KF-WestLondon.myLevel <- FLevelSceneNode::Render <- RenderLevel <- KF-WestLondon.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level KF-WestLondon <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 4C576C61 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free
 

Nekomancer

FNG / Fresh Meat
Oct 23, 2009
459
22
0
I don't think he's running Win98, but maybe he's using compatibility options, possibly doesn't even know about that. There are no working Win98 drivers for that videocard.

@Sheepy Go into \Steam\steamapps\common\killingfloor\system\ and do Rightclick --> Properties on the Killingfloor.exe, look into the compatibility tab.
 
Last edited:

Sheepy

FNG / Fresh Meat
Oct 15, 2010
164
41
0
KF-Shropshire
You're right Nekomancer, I'm not running 98. I'm on 7 Ultimate x64.

Removing the compatibility mode seems to have gotten rid of the problem. Cannot think of why on Earth it was on 98, or anything for that matter. I think I recall fixing a GUI controller spawning error with it, but it seems to work fine now. :rolleyes:

Nobody on this forum (apart from Yosh, *hint, beta, hint*) could fathom the facepalms I shall be giving myself over the next few days. Thanks guys for all your' time. :D

Thanks,
Sheepy
 

Nekomancer

FNG / Fresh Meat
Oct 23, 2009
459
22
0
All is well that ends well. Good to hear you fixed your problem. Thanks for posting that crash error, that was very helpful. Have fun playing.