• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

KF Killing Floor crashes to desktop after server changes map

yonyz

FNG / Fresh Meat
Oct 24, 2009
37
0
0
Hi,

I'm playing kf on OS X Mavericks and, when playing multiplayer, after the server loads a new map after a vote, the game begins, I spawn but after a few seconds it get a black window and the game crashes to desktop.
 

swizzinex

FNG / Fresh Meat
Jan 3, 2014
7
0
0
I experience the same issue with Mavericks 10.9.1

I experience the same issue with Mavericks 10.9.1

I can approve this issue - experiencing the exact same behaviour with KF on OS X Mavericks (10.9.1).

Whenever a Map is finished and either the Server is loading a new Map, after a few seconds when the game starts (AFTER the initial Perk Selection!) the game quits without any error message. The same happened to me when I choose "Disconnect" at the end of a Map in order to return to the menu - after a few seconds in the Menu also an unexpected quit.

Here's an extract from my Console.log for the time just before the unexpected Quit:
Code:
04.01.14 03:10:56.552 WindowServer[88]: MPAccessSurfaceForDisplayDevice: Set up page flip mode on display 0x04280300 device: 0x7fe145306290  isBackBuffered: 1 numComp: 3 numDisp: 3
04.01.14 03:10:56.856 WindowServer[88]: Display 0x4280300 released by conn 0x2235f
04.01.14 03:10:56.932 com.apple.launchd.peruser.501[163]: (com.tripwireinteractive.killingfloor.52304[2739]) Exited with code: 1
Hope you can fix this soon, as it is quite annoying to have to restart KF everytime after a map :(
 

yonyz

FNG / Fresh Meat
Oct 24, 2009
37
0
0
swizzinex, KF never crash in the menu for me. It' always in-game after loading a second map (and sometime even on the first game).

Since yesterday, however, KF will not launch - it crashes after the splash screen is shown. I validated file, removed ClientRegistry.blob, restarted the computer 2 times, added the -window startup option - nothing helped.
 

Hirosaga

FNG / Fresh Meat
Jan 12, 2014
2
0
0
KF does not launch on Mavericks Mac OS X 10.9.1

KF does not launch on Mavericks Mac OS X 10.9.1

The game does simply not start. It shows the splash image and then quits.

I verified the game cache: ok
I cleaned the steam application folder: didn't help
I deleted killingfloor.ini: didn't help
I deleted the whole Killing Floor Application Support Folder: didn't help

Here is the killingfloor.log file contents, something seems to be 'NULL':

Log: Log file open, Sun Jan 12 16:45:16 2014
Init: Name subsystem initialized
Init: Version: 3339 (128.29)
Init: RO_VERSION: 1092
Init: KF_VERSION: 1058
Init: Compiled: Jan 2 2014 14:17:30
Init: Command line:
Init: (This is Mac OS X patch version 3339.0)
Init: Character set: Unicode
Init: Base directory: /Users/macfrank/Library/Application Support/Steam/SteamApps/common/killingfloor/System/
Init: Ini:KillingFloor.ini UserIni:User.ini
Init: Build label: Build UT2004_Build_[2004-11-11_10.48]
Init: Object subsystem initialized
Log: Your ini had WinDrv...Forcing use of SDLDrv instead.
Log: Your ini had D3DDrv...Forcing use of OpenGLDrv instead.
Warning: Missing Class Class Editor.TransBuffer
Log: Initializing OpenGLDrv...
Log: binding OpenGL library...
Log: Game class is 'KFCinematicGame'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 2.893638...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Falsch
Log: Browse: KFIntro.rom?Class=Engine.Pawn?Character=Corporal_Lewis?team=1?Sex=M?Name=Hirosaga
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 39477->39477; refs: 418866
Log: Game class is 'KFCinematicGame'
Log: Bringing Level KFIntro.myLevel up for play (0) appSeconds: 3.186742...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Falsch
Log: Created and initialized a new SDL viewport.
Log: ALAudio: Using ALC_EXT_capture to record audio.
Warning: Konnte 'NULL':  nicht laden
Log: Unreal Call Stack: UObject::StaticLoadObject <- UObject::processEvent <- ULevel::SpawnActor <- UObject::processEvent <- ULevel::SpawnPlayActor <- UGameEngine::Init <- InitEngine
Exit: Exiting.
Log: FileManager: Reading 0 GByte 199 MByte 8 KByte 383 Bytes from HD took 0.407835 seconds (0.134292 reading, 0.273543 seeking).
Log: FileManager: 0.000000 seconds spent with misc. duties
Uninitialized: Name subsystem shut down
Uninitialized: Allocation checking disabled
Uninitialized: Log file closed, Sun Jan 12 16:45:23 2014
 

GEORGzer

FNG / Fresh Meat
Feb 8, 2012
7
0
1
Anything new on the map-change crash problem?
I'm experiencing it frequently when hosting and playing with my friends.

Would be nice to get rid of it.
 

yonyz

FNG / Fresh Meat
Oct 24, 2009
37
0
0
Problem still persists for me as well. Also - it won't save perk progress.
 

KweliTX

FNG / Fresh Meat
Dec 10, 2014
3
0
0
Killing Floor crashes to desktop after server changes map

This is still going on... :(
I've followed all of the steps on the instructions in the link below as well as disabling the Steam Interface in-game;
http://steamcommunity.com/sharedfiles/filedetails/?id=125107851

Did anyone come close to achieving a fix yet?
I'm running Mavericks 10.9.5/3.3GHz/4GB/nVidia GeForce GT 740

I'm going to go ahead and start including my Crash Logs going forward.
 

KweliTX

FNG / Fresh Meat
Dec 10, 2014
3
0
0
Killing Floor crashes to desktop after server changes map too

Killing Floor crashes to desktop after server changes map too

This is still going on... :(
I've followed all of the steps on the instructions in the link below as well as disabling the Steam Interface in-game;
http://steamcommunity.com/sharedfiles/filedetails/?id=125107851

Did anyone come close to achieving a fix yet?
I'm running Mavericks 10.9.5/3.3GHz/4GB/nVidia GeForce GT 740

I'm going to go ahead and start including my Crash Logs going forward.
 

KweliTX

FNG / Fresh Meat
Dec 10, 2014
3
0
0
Here are 2 Crashlogs as promised;

Code:
3339 (128.29).1094.1064
0
Dec  2 2014 10:10:24

2836.770996

UALAudioSubsystem::Update <- UGameEngine::Draw <- USDLViewport::Repaint <- USDLClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop
____________________________________________________________
Code:
3339 (128.29).1094.1064
0
Dec  2 2014 10:10:24

2394.144531

UCanvas::DrawTile <- UCanvas::WrappedPrint <- UCanvas::execDrawText <- UObject::ProcessEvent <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UpdateWorld <- USDLClient::Tick <- ClientTick <- UGameEngine::Tick <- UpdateWorld <- MainLoop
 

Lexthilian

FNG / Fresh Meat
May 29, 2016
2
0
0
Apparently nothing has been fixed regarding this problem. Everything folks are stating is also happening to me. It would be nice for me to further support this game through DLC but until they fix this issue I will not waste my money on any further projects from this company.