Killing Floor 2 PC Hotfix - Build 1100

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice
Notes:
  • Players may wish to delete their old launch logs as they may have become quite large due to excessive notifications. Logs are located in: ...Users\...\Documents\My Games\KillingFloor2\KFGame\Logs

Bug fixes included
  • Server browser filter issues have been improved (full/empty filter still may work incorrectly in certain situations)
    • Use the default filters to reset and make sure you can see servers or matchmake.
  • EGS server browser now shows servers with correct matchmaking version only
  • EGS Server browser log spam notifications have been removed
  • EGS certain edge case server names could cause problems on client (this was the log spam origin)

As always, thank you for your continued support!
 
Last edited:
this helped me able to join custom maps in my server! but i am still unable to join a buddies custom server. any idea why this could be?
 
  • Like
Reactions: Kaiyoto
We've been tracking reports on this, but haven't been able to reproduce it yet. We would recommend your friend tries a clean install on his server and make sure it is on the updated build.
 
Last edited:
I cant still see the servers, I delete the logs and install the hotfix on epic games. Me and my friend still having the same problem.
 
  • Like
Reactions: Kaiyoto
I apreciate u patching the game but i still cant create a custom match. It just keeps searching for a server with the same filters.
 
no logs folder in my kfgame folder. also since the hotfix my controller is no longer working on KF2. ive tested it on other games and it still works fine.
 
This may be because the kf folder here is write protected. Try deleting your mydocs/mygames/kf folder and let it regenerate on next game launch. Then make sure that that it is not write protected.
 
Hello! I tried too everything firewall port adaptations, antivirus disabled, and still can't see any servers. And yes I refreshed the filters :(
 
  • Like
Reactions: Kaiyoto
Can you try deleting your mydocs/mygames/killing floor 2 folder and see what happens? If this doesn't work, can you join the conversation in the bug forums with details about what software is on your machine and running.
 
Currently not all filters are working, please try with default filters and see if that works for you for now.
 
My game still crashes when I try to launch the game. Is there anything that I can do to fix this launch issue?