[Tuning] If you hang/crash at the splash screen!

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

PUTZ

FNG / Fresh Meat
Nov 21, 2005
4,564
634
0
Baltimore, MD, USA
I know a lot of you are experiencing a freeze/hang/lockup soon after the RO2 splash screen appears. We need to know more about why it's stopping.

The first step is to enable your log.

To do this, go to Steam > Library > Right-click on RO2 > Properties > Set Launch Options

In the launch options window add "-log" without the quotes. Close and move on to part 2.

We also want you to unsuppress some logging information. If your game actually launches, it probably won't run very well. Again, this is mainly for people who actually get stuck at the screen all the time.

Navigate to documents\mygames\redorchestra2\rogame\config and open ROEngine.ini.

Scroll down and you'll find a section with a lot of Suppress lines like so:

Code:
Suppress=Dev
Suppress=DevAbsorbFuncs
Suppress=DevAnim
Suppress=DevAssetDataBase
Please add a semi-colon in front of every Suppress line so it looks like this:

Code:
;Suppress=Dev
;Suppress=DevAbsorbFuncs
;Suppress=DevAnim
;Suppress=DevAssetDataBase
Once that is done, save the file and launch the game.

You should see a ton of logspam. This is normal. If it hard locks again or just sits there, please navigate to the log window itself and hit Ctrl+C to close it down gently.

Once that is done, please attach your .log and any .dmp files that are created in a post down below. Do not cut and paste.

Log & dump files can be found here:
documents\mygames\redorchestra2\rogame\logs
 
Last edited:

Timpie

FNG / Fresh Meat
Sep 21, 2011
1
0
0
I hope you can find the problem.
 

Attachments

  • Launch.log
    4 KB · Views: 0
  • unreal-v7258-2011.09.21-21.38.24.dmp
    228.1 KB · Views: 0

Spootnik

FNG / Fresh Meat
Sep 17, 2011
6
0
0
I just followed this guide step by step but the only thing i get is an empty launch.log... no .dmp file.
So what am i supposed to do?

I suppose i could copy/paste in a .txt file what appears in the log window when i launch RO2 but i'm not sure
if it would be of any use to you guys?
 
Last edited:

Lethall

FNG / Fresh Meat
Aug 11, 2011
173
42
0
Florida, U.S.A
Where do I find the log files after running the game after using the method above?
All files are listed on screen with a path leading to ROgame.exe, but can't find the files.

Is this saved as a regular txt file or some other format?
 

snooper12

FNG / Fresh Meat
Sep 21, 2011
3
0
0
I just followed this guide step by step but the only thing i get is an empty launch.log... no .dmp file.
So what am i supposed to do?

I suppose i could copy/paste in a .txt file what appears in the log window when i launch RO2 but i'm not sure
if it would be of any use to you guys?

same :(
 

Pinion

FNG / Fresh Meat
Sep 22, 2011
3
0
0
Hope it helps. I want to play. :(
 

Attachments

  • unreal-v7258-2011.09.22-11.01.05.dmp
    279.8 KB · Views: 0
  • Launch-backup-2011.09.22-11.32.36.log
    779.9 KB · Views: 0

Pinion

FNG / Fresh Meat
Sep 22, 2011
3
0
0
I hope this helps. I get stuck when I choose a server, I just hang there. I want to play. :\
 

Attachments

  • unreal-v7258-2011.09.22-11.01.05.dmp
    279.8 KB · Views: 0
  • Launch-backup-2011.09.22-11.32.36.log
    779.9 KB · Views: 0

PUTZ

FNG / Fresh Meat
Nov 21, 2005
4,564
634
0
Baltimore, MD, USA
For the people not getting files at all, or blank files, please rerun the ue3redist located here:

\Steam\steamapps\common\red orchestra 2\Binaries\windows\ue3redist.exe

After that, report back with your findings!
 
Last edited:

Hawk5

FNG / Fresh Meat
Sep 22, 2011
1
0
0
Have been playing with little problem since day 2 post release. Just updated via Steam to latest version and game and now won't load. Initial splash screen visible for 15 sec or so before crashing every time.
 

Attachments

  • unreal-v7258-2011.09.23-00.56.34.dmp
    311.5 KB · Views: 0
  • Launch.log
    7.2 KB · Views: 0

Hugo_Stiglitz |PL|

FNG / Fresh Meat
Sep 21, 2011
2
0
0
please help me

please help me

in attachment i send .log and .dmp file, i hope you help me selving the problem (rogame.exe crash and sound off)
 

Attachments

  • unreal-v7258-2011.09.22-08.44.03.dmp
    335.9 KB · Views: 0
  • Launch.log
    35.6 KB · Views: 0

Hugo_Stiglitz |PL|

FNG / Fresh Meat
Sep 21, 2011
2
0
0
Game crashes and sound don`t work

Game crashes and sound don`t work

rogame.exe crashes and sound off in multiplayer, please help.
 

Attachments

  • unreal-v7258-2011.09.22-08.44.03.dmp
    335.9 KB · Views: 0
  • Launch.log
    35.6 KB · Views: 0

XDC nOm

FNG / Fresh Meat
Jan 29, 2011
96
32
0
Heres another, getting frustrating to say the least, ahh well, good luck:cool:
 

Attachments

  • Launch.log
    4 KB · Views: 0
  • Launch-backup-2011.09.22-18.36.08.log
    4 KB · Views: 0

Lethall

FNG / Fresh Meat
Aug 11, 2011
173
42
0
Florida, U.S.A
Followed the instructions above .. get a DOS type window when I run RO2 but the launch log file is empty.(I ran this several times)
The splash screen displays on screen while the log is running but goes no farther once the log is finished.
Just to make sure I did this correctly .. I found 55 lines that started with suppress.
Instructions said to add a semi-colon in front of EVER suppress line, so that is what I did.

Why am I getting nothing in my log file???

Before I made the changes as instructed, I allowed the spash screen to run for a full 12 minutes as someone had stated the game would start if allowed to run for 4 minutes.

Don't know if this will help, but on one try, my hard drive started running almost continuously after about 3 minutes as if it was trying to load, then I noticed the DVD drive with the retail RO2 DVD was also running. I allowed this to run for probably another 7-8 minutes, then decided to remove the DVD.
The HD then went back to it's normal cycle but nothing happened over the next few minutes, so I finally shut down the game.exe.
 
  • Like
Reactions: jawdpw

loNgH0p

FNG / Fresh Meat
Sep 21, 2011
2
0
0
Followed your instructions but like others here there is no log file. However on the DOS like log screen it only gets to:

[0002.30] DevShaders: Verifying Global Shaders for PC-D3D-SM3

Thats it! it just stops at that point.

Hope this might be of some use as I really want to play this game
 

Spootnik

FNG / Fresh Meat
Sep 17, 2011
6
0
0
I've been wondering about something:
What if i copy/pasted the log screen content into the blank launch.log then link it in a next post?

Could it be of any use?