• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

How to change to Direct X 8 mode by ini file

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,162
3,395
113
To fix open up your killingfloor.ini file (located in steam/steamapps/common/killingfloor/system)

find

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice

and change it to read as

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=D3DDrv.D3DRenderDevice

Save the .ini and relaunch the game.
 

Unzen

FNG / Fresh Meat
Aug 2, 2009
1
0
0
Thanks Yoshiro,

I reformatted my PC with Windows 7 64-bit yesterday and Killing Floor was the only game so far that failed to work.

I amended the ini file as shown above and it works perfectly!

Thanks for the info. :)
 

OFBulletMagnet

FNG / Fresh Meat
Aug 14, 2009
41
0
0
Yoshi, i just noticed that this were my default settings in the KF.ini file.

is this where the error [or at least mine] could lie?

[Engine.Engine]
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice
AudioDevice=ALAudio.ALAudioSubsystem

edit: ignore me, adding a 9 gives a critical error for me
 
Last edited:

robdude19

FNG / Fresh Meat
Sep 1, 2009
348
0
0
To fix open up your killingfloor.ini file (located in steam/steamapps/common/killingfloor/system)

find

[Engine.Engine]
RenderDevice=D3D9Drv.D3D9RenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice

and change it to read as

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=D3DDrv.D3DRenderDevice

Save the .ini and relaunch the game.
Why use DX8, is it mostly a frame rate boost? Does it help with load times? What do you lose visually besides AA?
 

bonetoad

FNG / Fresh Meat
Dec 31, 2009
5
0
0
hey yoshiro

hey yoshiro

im looking in my killing floor files in \system) and all i see is killing floor.int is that the same thing as ini??
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,162
3,395
113
No, a .ini will look like a text document with a cog.
 

bonetoad

FNG / Fresh Meat
Dec 31, 2009
5
0
0
k found it

k found it

k well i found the ini and it looks like this,
[Engine.Engine]
RenderDevice=PixoDrv.PixoRenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

what should i change so that it is at default settings, i got this problem becuase i changed my direct 3d to software in the display settings
 

Xienen

Tripwire Alumni and Break Blocks Owner
Mar 26, 2007
1,678
431
0
www.greatergoodgames.org
k well i found the ini and it looks like this,
[Engine.Engine]
RenderDevice=PixoDrv.PixoRenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice

what should i change so that it is at default settings, i got this problem becuase i changed my direct 3d to software in the display settings
For DirectX8 mode, this should be changed to look like this:

[Engine.Engine]
;RenderDevice=PixoDrv.PixoRenderDevice
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice


For DirectX9 mode, this should be changed to look like this:

[Engine.Engine]
RenderDevice=D3DDrv9.D3DRenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice
 

grex413

FNG / Fresh Meat
May 3, 2009
134
1
0
canada ontraio
For DirectX8 mode, this should be changed to look like this:

[Engine.Engine]
;RenderDevice=PixoDrv.PixoRenderDevice
RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice


For DirectX9 mode, this should be changed to look like this:

[Engine.Engine]
RenderDevice=D3DDrv9.D3DRenderDevice
;RenderDevice=D3DDrv.D3DRenderDevice
;RenderDevice=Engine.NullRenderDevice
;RenderDevice=OpenGLDrv.OpenGLRenderDevice
;RenderDevice=PixoDrv.PixoRenderDevice
I like to get the boosted fps for the hell of it thanks man!:rolleyes:
 

Skalli

FNG / Fresh Meat
Mar 2, 2010
225
54
0
Germany
This couldn't help me. Using Win7 64 Bit (edit: and a HD5770) and always getting damn 10-12 fps while "playing". Tried this DX8 mode and different graphic settings. Any ideas how to solve this problem?

Solved a month ago. Was an ATI Problem.
 
Last edited:

boxingfan1019

FNG / Fresh Meat
Dec 14, 2011
4
0
0
same problem no solution

same problem no solution

I had switched my video to "software" as well. I've tried deleting the .ini file, validating the software, uninstalling and reinstalling and then validating the software, all my video cards are up to date and changing over the text in the .ini file as show in the above posts. no luck so far though. here's what it said after i changed the text in the .ini file

----------------

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows NT 6.1 (Build: 7601)
CPU: GenuineIntel PentiumPro-class processor @ 3325 MHz with 4095MB RAM
Video: No Video

Can't find file for package 'D3DDrv9'

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

----------------

I have an ATI Radeon HD 4800 Series and DirectX 11 and before I switched over the text in the .ini file, it would read "Video: ATI Radeon HD 4800 Series" and below it the error was "Can't find 'DEFAULT'" or something like that.

I got KF to work once, and that was when I opened it from the system folder, clicking on the .exe file above the .ini file. But that's a pain and I don't want to have to tinker with the .ini file everytime I want to play, gnome sane?

Thanks for the help!
 

boxingfan1019

FNG / Fresh Meat
Dec 14, 2011
4
0
0
Hi,
I did the same dumb thing with my video setting as everyone else. I've tried removing the .ini file, editing it as shown here, reinstalling it and validating the files and nothing works. My video card is up to date too.
I managed to get the game to work ONCE, when I opened it from the .exe file right above the .ini file in the /system folder. I adjusted the video settings too but when I exited and tried to start it this time from Steam, no luck.
My most recent attempt was editing the .ini file, so what I post below will probably show symptoms of that. I have Windows 7 64-bit.

Anything you can do to help? Thanks!

---------------------


Build UT2004_Build_[2004-11-11_10.48]

OS: Windows NT 6.1 (Build: 7601)
CPU: GenuineIntel PentiumPro-class processor @ 3325 MHz with 4095MB RAM
Video: No Video

Can't find file for package 'D3DDrv9'

History: UObject::SafeLoadError <- UObject::StaticLoadClass <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Free

---------------------------------

P.S. Just in case it's relevant: Before I'd edited the .ini file, it was showing under "Video: [my video card]" and below that it would say it "could not find DEFAULT" or something along those lines.
 

phixxion

FNG / Fresh Meat
Dec 15, 2011
109
1
0
Mtl
Hey TWI coder's, i might have a potentiel fix for the Direct X9 issue + Crossfire "FREEZE OF DEATH". B4 i make a move id like to have an opinion about that, is that a scam or it would work for real,

Here is the Post thread Found HERE !!!

Quote:
UPDATE: 11.11 has fixed both Killing Floor and Red Orchestra. This fix is not needed anymore.
Looks like Catalyst 11.10 has extremely high gpu usage in Killing Floor, so it struggles to maintain a solid framerate when there
 

EpharGy

FNG / Fresh Meat
Jan 3, 2011
1,352
63
0
Australia
www.sykosis.co.uk
Hey TWI coder's, i might have a potentiel fix for the Direct X9 issue + Crossfire "FREEZE OF DEATH". B4 i make a move id like to have an opinion about that, is that a scam or it would work for real,

Here is the Post thread Found HERE !!!

Quote:
UPDATE: 11.11 has fixed both Killing Floor and Red Orchestra. This fix is not needed anymore.
Looks like Catalyst 11.10 has extremely high gpu usage in Killing Floor, so it struggles to maintain a solid framerate when there
 

phixxion

FNG / Fresh Meat
Dec 15, 2011
109
1
0
Mtl
havent tryed yet. But is there any way to test the file or know if it has any risk trying this ?