Help! KF crashes at startup!

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

Nikobu02Gamer

FNG / Fresh Meat
Jan 10, 2022
6
0
1
19
Bulgaria
(Have to add this is a copy-paste from Steam, since no one's been responding for hours)

Hello, the game started crashing for me out of nowhere randomly every time I boot it up with the following displayed :



Build UT2004_Build_[2004-11-11_10.48]



OS: Windows NT 6.2 (Build: 9200)


CPU: GenuineIntel PentiumPro-class processor @ 2598 MHz with 4095MB RAM


Video: NVIDIA GeForce GTX 1060 6GB (9729)



Error setting display mode: No acceptable display modes found (D3D_OK). Please delete your KillingFloor.ini file if this error prevents you from starting the game.



History: UD3D9RenderDevice::UnSetRes <- FindBestMatchingMode <- UD3D9RenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine <- FMallocWindows::Free <- FMallocWindows::Realloc <- 004E004C 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free <- FMallocWindows::Free



I was subscribed to 2 workshop mods - Uncensored Stalker and Siren, and a mod from the main composer restoring unused sountrack on one of the maps.


What I've tried so far :



1) Unsub from the mods ;


2) Verifying the files afterwards which resulted in the same, so I ended up deleting the System folder and verification afterwards, which allowed the game to start.


I changed the settings to max just like before, together with a few tweaks regarding the mouse and audio, and I exited the game in order for the changes to apply.


And the game refuses to launch again.



CPU -> Intel Core i5-11400F ;


GPU -> Gainward GeForce GTX 1060 6GBs (reused from old PC) ;


RAM -> Crucial Ballistix DDR4 16GB (2x8) 3200 MHz ;


SSD -> 2 TB Intel 660p, NVMe, M.2 ;



GPU drivers were updated 2-3 days ago, so they should be the newest rn.



Please help!



(Side questions :


1) Is it possible to increase the corpse/limbs limit or make them stay on the ground for longer without breaking the game ? ;


2) Any recommendations regarding better surround sound in the game - I'm using RAZER BlackShark V2 ?)
 

Nikobu02Gamer

FNG / Fresh Meat
Jan 10, 2022
6
0
1
19
Bulgaria
Excuse me, but we're talking about KF1, the problem is related to KF1 not 2. Secondly, the directory provided above does not contain any KF related folders, which means my problem is still ongoing unfortunately.
 

dimitrifrom31

Member
May 14, 2009
182
2
18
Had the same issue and ended up here looking for help. Reading your post rang a bell. I updated my gfx card drivers yesterday...
So I just uninstalled the nvidia drivers I installed and was able to run the game again.
 
  • Like
Reactions: Nikobu02Gamer

Nikobu02Gamer

FNG / Fresh Meat
Jan 10, 2022
6
0
1
19
Bulgaria
Had the same issue and ended up here looking for help. Reading your post rang a bell. I updated my gfx card drivers yesterday...
So I just uninstalled the nvidia drivers I installed and was able to run the game again.

I uninstalled every single NVidia related driver using the "Add or remove programs" built in Windows 10, and then cleaned up with CCleaner. I restarted my PC as well, and now I got this upon launch :
 

Attachments

  • Screenshot 2022-01-11 224247.png
    Screenshot 2022-01-11 224247.png
    285.8 KB · Views: 2