• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

[Error] Game wont start (Linux)

jo3fis

FNG / Fresh Meat
Nov 23, 2013
2
0
0
Hi

I have a fully updated Ubuntu Gnome 17.04, specs below.

Core i5 750
8GB RAM
NVIDIA Geforce 580 3GB
Gigabyte GA-P55A Mobo
Nvidia Proprietary Driver 378.13

Installed Dwarfs!? and attempted to run and steam tells me it is running but nothing was displayed (I have to manually kill the Dwarfs_Bundle.exe. I discovered after running it from the command line it was failing due to a missing library i.e. libtier0_s.so.

So I copied the file from ".local/share/Steam/ubuntu12_32" into the appriate directory "/lib/i386-linux-gnu". Now I am sure that after fixing this library I got the game to run once but then I closed it to finish doing the missing libraries on my system as per below.

I determined missing libraries using I ran the following command --> "ldd ~/.local/share/Steam/ubuntu12_32/steamclient.so" that I was missing that library and a few more.

libudev0:i386, libnm-glib4:i386, libdbus-glib-1-2:i386.

However after installing these the game would no longer run and that puzzled me so I removed all of them and started from the beginning by copying the libtier file from the steam directory. This time it failed on the remaining libraries which I am sure it didn't the first time.

Now when I run the game I get the following attached output.

If anyone could help that would be appreciated.
 

Attachments

Last edited: