• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Game won't launch on Ubuntu.

sandworm354

FNG / Fresh Meat
Feb 17, 2013
1
0
0
I recently got Dwarfs!? off of steam during the linux sale and after i installed the game when i click play it won't launch. It doesn't even give an error report. Does anyone know how to fix this problem?
 

Axis

FNG / Fresh Meat
Jul 13, 2013
6
0
0
yea, same error here. It wont launch, ill try to get some crash log.. if any.

EDIT:

Here's the log:

ExecSteamURL: "steam://rungameid/213650"
Game update: AppID 213650 "Dwarfs F2P", ProcID 3479, IP 0.0.0.0:0
Stacktrace:

at (wrapper managed-to-native) Dwarves.xSteamWrapper.InitializeSteam (intptr) <0xffffffff>
at DwarfsWindows.Program.Main (string[]) <0x00047>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

./libmono-2.0.so.1(+0xaa2c0) [0xb74ec2c0]
./libmono-2.0.so.1(+0xec830) [0xb752e830]
./libmono-2.0.so.1(+0x1fc38) [0xb7461c38]
[0xb779e40c]
/lib/i386-linux-gnu/libc.so.6(+0x8d77f) [0xb731277f]
/home/vinyl/.local/share/Steam/ubuntu12_32/libtier0_s.so(ThreadSetDebugName+0x30) [0xb6169996]
./libtier0_s.so(+0x14ac1) [0xb613bac1]
./libtier0_s.so(+0x1d8fa) [0xb61448fa]
./libtier0_s.so(+0x6dcf) [0xb612ddcf]
/lib/ld-linux.so.2(+0xee49) [0xb77ade49]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operaci
 
Last edited: