For the love of Gaming HELP!

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Comrade Kaizer

Grizzled Veteran
May 21, 2009
1,116
124
63
Followed everything down to the letter and my game still takes like 5 minutes to deploy and lags horribly even in the menus... I just got this game through Steam and it should have worked fine yet I can't enjoy it whatsoever with the horrendous problem, I posted about this before and received no help, I even PM a couple people and no replies? Can SOMEONE for the love of God help me so I can finally play this damn game already? Seriously I've spent hours trying to research stuff on the web and most of it refers to other websites that have been shut down ages ago, this is my last line of hope and I haven't got a reply in the past 4 days? Is anyone ever on here?

My system specs are:

AMD Turion 64 X2 (Dual Processor) Mobile Technology TL - 50 (RO's minium is Pentium III/Athlon or better)

1.60 GHz Performance rated at 3.11 GHz (RO's minium is 1.2 GHz)

System RAM of 894 MB (RO'S minium is 512 MB)

Operating System: Microsoft Windows Vista Basic Home Edition, 32-bit (build 6000) (RO's minium is Windows 2000/XP)

Video Card: ATI Radeon X1270 ( ) (RO's minium is DirectX
 
Last edited:

=GG= Mr Moe

FNG / Fresh Meat
Mar 16, 2006
9,797
890
0
55
Newton, NJ
Looking at those specs, I would say you would possibly have a hard time running the game. Maybe at low settings or medium low at best.

Also, if you only have 13GB free space left on your disk, which is very little in my opinion, you should perhaps perform some disk cleaning/optimizing tasks such as disk cleanup, get rid of all those extra system restore points, defrag the disk, etc. Any little thing that could help. Also, how many useless and unecessary background tasks do you have running in the background? They could be eating up your cpu and slowing the game down immensely. I have fixed and cleaned up peoples desktops and laptops before, so I can tell you that just by doing some of these things, you can get your computer/game running from an absolute crawl to quite a bit smoother...

There could also be a problem with your mouse settings in game, not sure where to find the help there with that

Good luck :)

PS: Also you are running Vista, which is more of a drag on your computer than say, XP. Might not be a problem on a higher spec computer than what you have, but on yours, I imagine that would interfere with games a bit.
 
Last edited:

Comrade Kaizer

Grizzled Veteran
May 21, 2009
1,116
124
63
Thanks but I did all that prior to buying and installing the game... I know of people who run this game fine with less power then I have. So I don't know what is going on, I guess I'll try running the game on low settings but I doubt thats the problem... if my specs aren't enough (unlike what others have told me) tell me what exactly I need to upgrade here so I can get working on it as soon as possible... I want to play this game already its driving me completely insane!
 

Comrade Kaizer

Grizzled Veteran
May 21, 2009
1,116
124
63
Did you look at this.

[URL="http://forums.tripwireinteractive.com/showthread.php?t=11052"][URL]http://forums.tripwireinteractive.com/showthread.php?t=11052[/URL][/URL]

Your system is close to the limit.
Set your Vista to best performance values in the options.

Hope that helps.

Yeah I followed and completed this tweak, it was slightly faster but still very lengthy load times (3-5 minutes) and I still have lag to deal with.

EDIT: Well I preformed some other tweaks and reduce my deployment time to about 1 min 30 secs to 2 minutes yet the lag is my biggest for now... how can I beat this lag? Better Servers? Because I seem to be connecting with alot of foriegn dudes...
 
Last edited:

=GG= Mr Moe

FNG / Fresh Meat
Mar 16, 2006
9,797
890
0
55
Newton, NJ
Yeah I followed and completed this tweak, it was slightly faster but still very lengthy load times (3-5 minutes) and I still have lag to deal with.

EDIT: Well I preformed some other tweaks and reduce my deployment time to about 1 min 30 secs to 2 minutes yet the lag is my biggest for now... how can I beat this lag? Better Servers? Because I seem to be connecting with alot of foriegn dudes...

Finding more local servers may help. Are you using any sort of wireless router setup?
 

Comrade Kaizer

Grizzled Veteran
May 21, 2009
1,116
124
63
No router, direct modem... I believe your right about the local server though, this morning on was on TWB East coast pub server and it was the smoothest game I've playe so far, basically the way the game should be. No lag, just the minimal hiccups due to setting precaching false though (nothing big), a 2 minute deployment window but unfortunately the next map Pavlov's house (the take on the old CO1 map I notice) was back to some bad lag so I'm not completely sure if a localized server solves my problems completely.

Well I finally manage to get rid of the menu lag I had before, its completely gone. I defragged about 80% of my HD (finish defragging the rest tonight), update all my drivers, tweaked RO as the guide implied in areas of need, turned off all background apps, and plan on buying another gig of RAM (which will hopefully help me a bit), and if that doesn't do it then I'll buy an updated video card (rather save up for a new PC for HOS imo).

Question: Does running AMD dual core optimizer effect this game in a bad way or good? And how can I dedicate one of my processors solely for RO when I play it?