• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Fix for BT HomeHub / Thomson / BeBox etc routers disconnecting - walking into walls

kritikern

FNG / Fresh Meat
Jul 26, 2011
7
0
0
My router is Thomson TG874 and my ISP is Glocalnet (I'm in Sweden). I've had this problem for a long time now in both Killing Floor and Left 4 Dead (1 & 2), and none of the fixes I've tried have worked.

That applies to:

1. Replacing masterservers.vdf and masterservers2.vdf, and yes I've checked read-me.

2. The telnet fix. I can't even connect to the router whatsoever. It simply tells me "Could not open connection to the host, on port 23: Connection failed". I have tried multiple ports, too. I'm positive this is the internal ip address of my router.

Please help me out.
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
My router is Thomson TG874 and my ISP is Glocalnet (I'm in Sweden). I've had this problem for a long time now in both Killing Floor and Left 4 Dead (1 & 2), and none of the fixes I've tried have worked.

That applies to:

1. Replacing masterservers.vdf and masterservers2.vdf, and yes I've checked read-me.

2. The telnet fix. I can't even connect to the router whatsoever. It simply tells me "Could not open connection to the host, on port 23: Connection failed". I have tried multiple ports, too. I'm positive this is the internal ip address of my router.

Please help me out.
Replacing the masterserver2.vdf file should work, if it doesn't for some reason and the router has telnet disabled then your only options are to use the workarounds.
 

Glitchboy

FNG / Fresh Meat
Jul 30, 2011
1
0
0
It works!

It works!

My problem was when searching for internet games it would just query the master server and never give me any error message or anything. If I had a friend in a server I could see it and join him with no problems. I ended up favoring one of the servers and from there on out I could see that server in my favorites again with no problems.

I added the MasterServers.vdf file as instructed and I HAVE TEH MULTIPLAYER! :-D

(For the record I have had this problem since downloading the game during the summer sale 2011)

Thank you so much!!
 

Blockbot

FNG / Fresh Meat
Jun 25, 2011
1,594
661
0
I've done this over at my friends place. and they are all 6computers work fine now with KF. but remember to completly turn off steam. even in the lower corner and you should go and close it here aswell in the task manager to be completly sure its totally shut downed:

 

Spyder638

FNG / Fresh Meat
Aug 31, 2011
3
0
0
Hey, sorry to bump the thread, but I want to confirm that this works with Red Orchestra 2.

I was having the issue all day until I did this, and it fixed it right away. I also had this issue with many other games so thank you for posting this. This has made my online gaming experience much less frustrating.
 

[DAF] Annihilation

FNG / Fresh Meat
Sep 4, 2011
30
12
0
27
Scotland
I can tell anyone who uses BT that BT are without a doubt, the ****tiest ISP that has ever been used. Ok it may have it's good peak times but for online it's pretty horrible
 

Pauline 88

FNG / Fresh Meat
Oct 2, 2011
7
0
0
I can tell anyone who uses BT that BT are without a doubt, the ****tiest ISP that has ever been used. Ok it may have it's good peak times but for online it's pretty horrible
 

fabius173

FNG / Fresh Meat
Oct 15, 2011
2
0
0
Hello everyone, I have a router thomson tg-784, I replaced the zipped file in c: / program files / config / and I put on "read only", but the game does not work the same.
please help
thanks
 

PEZPKC

FNG / Fresh Meat
Nov 6, 2011
3
0
0
ive done all this stuff but i dont have this folder C:\Program Files\Steam\config\
soo idk what to do
 

alpha172

FNG / Fresh Meat
Oct 11, 2011
1
0
0
OP's fix does not work with Killing Floor. It works with Red Orchestra 2 However.

I am using a Thomson TG782T (a really **** modem for gaming) and every 15-20 seconds I get disconnected from a multiplayer game; creatures and players running into walls.

I've also tried defraging and verifying KF but to no avail.

What's weird is that, when I installed KF yesterday I managed to play multiplayer for hours without problems. This problem hapenned today - must have been some sort of update.
 

Morello

Administrator
Mar 17, 2006
1,277
79
48
It would work for all games that use the Steam servers, but it appears that Valve have updated things on their end and this no longer functions.
 

HuNteR-

FNG / Fresh Meat
Apr 11, 2011
682
439
0
Up there, in the trees...
OP's fix does not work with Killing Floor. It works with Red Orchestra 2 However.

I am using a Thomson TG782T (a really **** modem for gaming) and every 15-20 seconds I get disconnected from a multiplayer game; creatures and players running into walls.

I've also tried defraging and verifying KF but to no avail.

What's weird is that, when I installed KF yesterday I managed to play multiplayer for hours without problems. This problem hapenned today - must have been some sort of update.
My favourite work around, favourite the server you want to join, then go to your favourites, join the server from there, I never freeze doing that.
 

fabius173

FNG / Fresh Meat
Oct 15, 2011
2
0
0
Hello guys, I have a thomson tg784 and even if I replace the zipped file does not change anything. someone has a real solution?
 

The Beast (nl)

FNG / Fresh Meat
Jul 2, 2006
3,160
486
0
The Netherlands
I couldn`t connect with my thomson router/modem. I have also called the
company but they say to me, it isn`t allowed...:(

An half hour ago i deleted both masterfiles from my steam folder and
started RO2 again......

AND IT DOES WORK, I SEE ALL RANKED SERVERS NOW.

I hope that i have helped other players.
 

Kornas

FNG / Fresh Meat
Aug 28, 2012
17
0
0
did everything as demonstrated and i have thomson router, watch this tutorial: Killing Floor / Monday Night Combat / Homefront BT Home Hub and Thomson router telnet fix tutorial - YouTube but again no help, again when im in server is only empty map: http://www35.zippyshare.com/v/80541588/file.html and in console i see this: http://www35.zippyshare.com/v/37087672/file.html and i cant reconnect, disconnect and etc from server and i was tryed to do like here: https://support.steampowered.com/kb_article.php?ref=1452-HCVB-6984 but.. again no changes
 

KFrohman

FNG / Fresh Meat
Aug 9, 2013
2
0
0
England
Okay, I've seen this issue many times before and whilst the posted method works sometimes, it's very hit and miss. On my previous ISP's forums, they posted a fix for these kinds of routers and it always worked. It doesn't require messing with master server files at all. It's entirely router based.

NOTE: Neither I or the person who originally posted this guide are responsible if you break or otherwise hinder/render your router inoperable by following this guide.

This fix should correct the following issues:

* Servers in Steam/in Steam games suffer ping 'spikes'
* Difficulty/Inability to connect to servers
* Use of Steam/Steam games causes the BeBox to freeze/stall/restart (crash)
* Loss of connection to servers, or timeouts
* Poor performance ('lag') in servers


This fix involves editing the user.ini file to change configuration of the router.

1. Follow this link to the router configuartion page:
http://192.168.1.254/cgi/b/bandr/?ce=1&be=0&l0=0&l1=1&tid=BACKUP_RESTORE
*NOTE* This may be different for your router. You should be looking for a page which allows the saving (backing up) and uploading of config files.

2.Enter username & password (default is Administrator, with the password left blank or the S/N from the bottom of the router - without the bit in () )

3. Select Backup Configuration Now.... Don't close this window

You should now have a user.ini file containing your router configuration options.

4. Open it in Notepad. Go to Edit , Find and search for appconfig application=GAME(UDP)

You should see three entries regarding UDP. You need to change them to:

appconfig application=GAME(UDP) trace=enabled timeout=3
appconfig application=CONE(UDP) trace=enabled timeout=3
appconfig application=LOOSE(UDP) trace=enabled timeout=3

Now again, go to Edit , Find and this time search for timerconfig timer=udpidle

You should change this entry to:

timerconfig timer=udpidle value=3

5. Save that user.ini file to the desktop. Switch back to the router page and select Restore Configuration Now (or the equivalent "Upload Configuration" button)....

6. Use the router dialog to locate and select the user.ini file that you have modified. The router should upload the file.

7. Once configuration is uploaded, restart your router and all 'Connection Problem' or Server list crashes or Restarting of the router due to UDP flooding in CSS and other games should be FIXED.

This fixes the steam games issue as posted here, as well as issues in Killing Floor, etc.

Mods: I know this a monumental bump, but this is for the betterment of everyone who has this issue.

Users: Please try this out and let me know if it works.