• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Custom meshes textures become super low quality?

Auggy

FNG / Fresh Meat
Apr 15, 2019
3
0
0
22
Hi, i'm new to KF2 map editing and i've added a custom mesh/fbx, in 3DS max and Blender the textures look perfectly fine, even when scaled to 6x ( which is what i'm using in KF2 ) but no matter the size the texture quality get destroyed. Here's what it looks like.

In Blender:
https://gyazo.com/61b1aa680babfad75081707201dfdf7a

In KF2 SDK:
https://gyazo.com/a84b0c937988415f39ce1f483ead06fd

Would really REALLY appreciate a reply. I've tried different meshes and i still get the same issue. Thanks!
 

Auggy

FNG / Fresh Meat
Apr 15, 2019
3
0
0
22
Last post before i lay down i figured out the problem..! I think? When i go to the texture 2D version of the texture file and set mip gen settings to No mip maps instead of from texture group it goes back to normal quality! Now is there a way i can change this globally to all textures imported or do i have to do this one by one.. i don't think mip mapping settings are changed within the 3d modeling software right?
 

Delta69er

Active member
Sep 13, 2017
164
62
28
Im not sure what could be happening here. However are you importing the material directly into the SDK from the FBX/3DSoftware? If so I would try first creating a MIC based on one of the base Materials TWI have and then setting it up for your texture with a fresh texture

I have encountered an issue with mipmapping once with large meshes - I was able to work around it by changing the compression settings within the Texture Properties to TC_Displacementmap, so that might be worth giving a go as well.