• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

custom map start -> No menu / No ESC / No UI .... I Can't do anything!

MiniAlbum

FNG / Fresh Meat
Aug 13, 2019
3
0
0
23
I am bad at English. Please understand.
Speak in Google translation.
I created a custom map server.

<<I applied the map List>>
------------------No problem----------------------------------------
KF-Mario_64_Remastered
KF-Zedoland-2
KF-ToiletMap_Clean_Edition
KF-KF1_West_London
KF-KF1-Manor-Snow
KF-TRON-VR
KF-ZedsDiner
KF-MillTown-BurgerKing
---------------------------------------------------------------------------
------------------No UI / No ESC / No menu------------------
KF-IceArena
KF-IceBound
KF-BridgeHoldout
KF-Defence_Thyself_Day_Fin3
KF-DUST2Classic
KF-BurningParis day/night
KF-Random_Holdout
KF-Quandary
---------------------------------------------------------------------------

Why not working just a specific map? I don't understand

This log indicates when this is setting bat.
start .\Binaries\win64\kfserver KF-iceArena?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786

-SHOW log-
Log: Log file open, 08/14/19 00:49:37
Init: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
DevConfig: GConfig::LoadFile associated file: ..\..\KFGame\Config\kfserverC1\KFLightmass.ini
DevConfig: GConfig::LoadFile associated file: ..\..\KFGame\Config\kfserverC1\PCServer-KFUI.ini
DevConfig: GConfig::LoadFile associated file: ..\..\KFGame\Config\kfserverC1\PCServer-KFBenchmarking.ini
DevConfig: GConfig::Find has loaded file: ..\..\Engine\Config\ConsoleVariables.ini
Init: Version: 10897
Init: Epic Internal: 0
Init: Compiled (64-bit): Jun 17 2019 15:57:08
Init: Changelist: 1532151
Init: Command line: SERVER KF-iceArena?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786
Init: Base directory: D:\steam\steamapps\common\killingfloor2\Server\kfserver\Binaries\win64\
[0000.24] Init: Computer: UNKYR
[0000.24] Init: User: user
[0000.24] Init: CPU Page size=4096, Processors=12
[0000.24] Init: High frequency timer resolution =10.000000 MHz
[0000.24] Init: Memory total: Physical=15.9GB (16GB approx) Pagefile=22.7GB Virtual=131072.0GB
[0000.24] Log: Steam Client API not initialized (not required for servers)
[0000.24] Log: Steam query port set to invalid value 77786, ignoring.
[0000.24] Log: Automatically setting Steam query port to 27024 (server port is 7786)
[0000.24] Log: Automatically setting Steam port to 20569 (server port is 7786)
[0000.31] Log: Steam Game Server API initialized 1
[0000.31] DevOnline: appSteamInit: Steam Game Server UID: 0
[0000.31] Init: Presizing for 179220 objects not considered by GC, pre-allocating 0 bytes.
[0000.31] Init: Object subsystem initialized
[0000.31] Warning: Warning, Unknown language extension . Defaulting to INT
[0000.36] Log: CachePaths() took 0.05 Seconds
[0000.36] Log: Shader platform (RHI): PC-D3D-SM5
[0000.41] Log: PhysXLevel : 0
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.IIS
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.Menu_Winter
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.MenuBG
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.MenuBG_Cyberpunk
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.MenuBG_Halloween
[0001.12] Warning: Invalid movie stream data for TextureMovie UI_Managers.SummerSideShowBGMovie
[0001.14] Init: Finished loading startup packages in 0.73 seconds
[0001.18] Log: 111186 objects as part of root set at end of initial load.
[0001.18] Log: 0 out of 0 bytes used by permanent object pool.
[0001.23] Init: Version: 10897
[0001.23] Init: Epic Internal: 0
[0001.23] Init: Compiled (64-bit): Jun 17 2019 15:55:46
[0001.24] Init: Command line: KF-iceArena?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786
[0001.24] Init: Base directory: D:\steam\steamapps\common\killingfloor2\Server\kfserver\Binaries\win64\
[0001.24] Init: Character set: Unicode
[0001.24] Init: Process ID: 18700
[0001.24] Log: Executing Class Engine.ServerCommandlet
[0001.24] Log: Initializing Game Engine...
[0001.24] Log: [FSocketWin::Bind] Binding to 216.239.35.12:123
[0001.30] Log: *** Updating timed game events
[0001.30] Log: **** Current Time: 2019 8 12 15 49 38
[0001.30] Log: **** World start in seconds: 1492441200
[0001.30] Log: **** Current time in seconds: 1565592578
[0001.30] Log: **** Intended weekly index: 120
[0001.32] Warning: Warning, Failed to load 'Texture2D FX_GORE_TEX.FX_Gore_Blend_All_D': Failed to find object 'Texture2D FX_GORE_TEX.FX_Gore_Blend_All_D'
[0001.32] Warning: Warning, The Outer object (Package ENG_EngineResources_TEX.Dither) for 'ENG_EngineResources_TEX.Dither.dither_pattern' couldn't be loaded [while loading package ENG_EngineResources_TEX]: Invalid linker index [couldn't load Package ENG_EngineResources_TEX.Dither]?
[0001.32] Warning: Warning, Failed to load 'Texture2D ENG_EngineResources_TEX.Dither.dither_pattern': Failed to find object 'Texture2D ENG_EngineResources_TEX.Dither.dither_pattern'
[0001.34] Init: UEngine initialized
[0001.34] DevOnline: Created named interface (RecentPlayersList) of type (Engine.OnlineRecentPlayersList)
[0001.35] Log: Steam Client API is unavailable (not required for servers)
[0001.37] DevOnline: Signing into the local profile
[0001.37] Log: [TWAnalytics::requestInventoryItem] Requesting Item Id: 0 but NULL steamuser
[0001.37] Log: AllocateAPIEndpoint is
[0001.37] Log: DeallocateAPIEndpoint is
[0001.37] DevNet: Browse: KF-iceArena?Name=Player?Team=255?-configsubdir=kfserverC1
[0001.38] Log: LoadMap: KF-iceArena?Name=Player?Team=255?-configsubdir=kfserverC1
[0001.47] Warning: Warning, Failed to load 'Class None.game-ini:Engine.GameInfo.DefaultServerGame': Can't find 'game-ini:Engine.GameInfo.DefaultServerGame' in configuration file section=Engine.GameInfo key=DefaultServerGame ..\..\KFGame\Config\kfserverC1\PCServer-KFGame.ini
[0001.47] Warning: Warning, Can't find 'game-ini:Engine.GameInfo.DefaultServerGame' in configuration file section=Engine.GameInfo key=DefaultServerGame ..\..\KFGame\Config\kfserverC1\PCServer-KFGame.ini
[0001.47] Log: Game class is 'GameInfo'
[0001.47] Init: WinSock: Socket queue 131072 / 131072
[0001.47] Init: WinSock: I am UnkyR (xxx.xxx.xxx.xx)
[0001.47] Log: [FSocketWin::Bind] Binding to 0.0.0.0:7786
[0001.47] DevNet: IpNetDriverSteamworks_0 TcpNetDriver listening on port 7786
[0001.49] DevNet: Spawning: IpDrv.WebServer
[0001.49] Log: NetMode is now 1
[0001.50] Log: Bringing World kf-icearena.TheWorld up for play (30) at 2019.08.14-00.49.38
[0001.50] ScriptWarning: No game settings to register with the online service. Game won't be advertised
GameInfo kf-icearena.TheWorld:persistentLevel.GameInfo_0
Function Engine.GameInfo:RegisterServer:02CC
[0001.52] Log: [FSocketWin::Bind] Binding to 0.0.0.0:8084
[0001.52] ScriptLog: Web Server Created http://xxx.xxx.xxx.xx:8084 Port: 8084 MaxCo




plz.... HELP I've been doing this for 10 hours. T.T
 

®omano

Grizzled Veteran
May 14, 2009
4,014
174
63
France
www.hellsoldiers.tk
First your startup command line is wrong. you're missing a space before the config sub dir parameter, and you are using a non existent port for query:
start .\Binaries\win64\kfserver KF-iceArena?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786
Second you have more error with your config files and maybe a consequence of this issue:
[0001.47] Warning: Warning, Can't find 'game-ini:Engine.GameInfo.DefaultServerGame' in configuration file section=Engine.GameInfo key=DefaultServerGame ..\..\KFGame\Config\kfserverC1\PCServer-KFGame.ini
[0001.50] ScriptWarning: No game settings to register with the online service. Game won't be advertised
GameInfo kf-icearena.TheWorld:persistentLevel.GameInfo_0
So fix these issues first, most simple way to restart fresh would be to download a fresh server in another folder, then configure it, install custom content by following properly the WIKI.
 
Last edited:

MiniAlbum

FNG / Fresh Meat
Aug 13, 2019
3
0
0
23
first, Thank you for your answer.

I running a total 5 server. last 1 server is Custom map server. (All survival mod)
5 serverr all running is no ploblem

Already, multiple new folders were created and the server was created again. I knew didn't matter is query port, because server is running

start .\Binaries\win64\kfserver KF-iceArena?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786 <-- running .bat There is a problem

start .\Binaries\win64\kfserver KF-zedsdiner?-configsubdir=kfserverC1 -Port=7786 -QueryPort=77786 <-- No problem.

so... as mentioned above NO UI / No ESC / No menu MAP is iceArena // and no problem MAP zedsdiner. wtf!!

And I found an interesting fact.

I change the map to webadmin. iceArena MAP is Running!!!

I start the zedsdiner MAP game. And then change map iceArena. NO UI / No ESC / No menu MAP

and i saw a webadmin. IceArena game Type is Endless mod what happening!

I am so embarrassed now.

If you know this problem, please help me!
 

MiniAlbum

FNG / Fresh Meat
Aug 13, 2019
3
0
0
23
omano;n2333965 said:
Show the config you added for the maps. As mentioned but you don't want to check it, you have issue with your config files.
NONO!

I I solved it. I'm not sure. but Change the drive(G) -->drive(C). and I upgraded to the latest Nvidia driver.
Thank you for answering so far !!