• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Custom Map Install Issue

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
Here's the deal......... all our KF2 servers, hosted through NFO, were working just fine. Stock and Custom Maps, NO Mutators. I just discovered that certain maps will not download from the Steam Workshop to our Servers. Yes........ I edited the proper files correctly. I tried repeatedly with a few maps to no avail. I contacted NFO and they began running tests. The file IDs I gave them they also could not get to download to a our test server. Could not get them to download to a VDS. The also tried a fresh, clean install of KF2.............. still no luck. They did find that some maps will download to server as they are suppose to, but others won't.

They only error given is, "Warning, Warning, map failed to download from Steam Workshop." Duh, no kidding.

They have submitted a ticket to TWI, but I am not going to hold my breath. I have two questions:

1] I have heard that when there is an Open Beta going on, it can wreak havoc with the Workshop. Is this true? If so, maybe just waiting until the Beta is over, things will straighten up and the sun will come out again! ;-)

2] Can I manually upload maps to our servers and if so, exactly where to put them and any other editing needed to make this workaround viable?

Thx in advance for any advice or help.
 

Aurien

Member
May 16, 2009
124
22
18
I would take a look through the official wiki here and see if anything there helps with your issues. It does explain how to local host custom maps on your server so that clients can download them from there.

Also to help with the troubleshooting, post a fully copy of your server logs here. Might be something in there that you missed and someone catches.
 

®omano

Grizzled Veteran
May 14, 2009
4,015
174
63
France
www.hellsoldiers.tk
Hey, you maybe are victim of the outdated game file for the steam API the game uses. If this is your problem, you can fix it by copying your server /linux64/steamclient.so (the Steam SDK original official Steam file shipped with the server but apparently just not used in server files) to /Binaries/Win64/lib64/steamclient.so (replace it).

edit: problem reported since a few weeks now (the issue is like a month old at least), they just needed a hotfix to update that single file on server, I think they never did it.. With some luck we'll get the fix in one or two years.
 
Last edited:
  • Like
Reactions: fwfdf1reman

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
Thx Romano, will have a look at that. Have gone over log file and found nothing other than the no info "Warning" about map did not download. What is funny is that some maps download and others won't, it's hit and miss as to which maps will work and they are all from the Steam Workshop. However, the support guy at NFO, where we host our servers, tried adding maps on a VDS and a fresh vanilla install of KF2, again, some would download and some wouldn't.
 
Last edited:

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
I quoted your post here and Cody, as soon as his co-worker comes in is going to test your info. If it works, then NFO is going to fix our KF2 servers and send out a Client Side Update to all their KF2 servers. I hope it works too, very frustrating as the whole Steam Workshop concept was a big pitch point for TWI .......... you would think that they would pay attention to any issues involving this, and yet, so many map makers STILL have issues with that whole thing working right. I might just steer away from any future TWI products in the future.

Anyhow, rant over, thx again for your info. Wished I had half your know how on how all this stuff works. :)
 

®omano

Grizzled Veteran
May 14, 2009
4,015
174
63
France
www.hellsoldiers.tk
By the way, the tip was for LINUX servers obviously. For Windows servers I would suggest to use SteamCMD to grab the files (because there are 3 for Windows if I'm not wrong) back from Steam, download the app with AppID 1007 to download the Steamworks Shared library. In SteamCMD after login as anonymous, and optionally set a download folder, type

app_update 1007 validate
It should download the Steam latest files in the folder you specified before, or in a subfolder steamapps/common/Steamworks SDK Redist/ inside the SteamCMD folder.

Then copy steamclient64.dll tier0_s64.dll vstdlib_s64.dll and replace the ones in /Binaries/Win64/ in theory that should do the trick.

Most simple would be to bug TWI (and AMG by the way) to be super up to date on this thing, make sure they have notification when these files need to be pdated and send hotfix to avoid potential issues due to outdated files.
 
Last edited:

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
No, seems NFO has not gotten a response from TWI on the issue as of yet. Now that the open beta is over, I will do some testing on my own. Thanks for all your advice, I passed it along to NFO support and they are looking in to it.
 

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
I have access but I don't want to get in to something I am not familiar with. Support performed this on our #1 server and it worked, test map that would not download ............ now downloads. Saw all new Steam .dlls in the files. Now I am requesting him to perform this fix to all of our servers to be sure. Thanks again for all your help.

NFO never got a response to the ticket they put in and I never got any response here or on Steam. So again, thank you for your input and help.
 
Last edited:

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
Well, long story and time has passed, but, the file transfer somehow really messed up our KF2 servers............ all of a sudden we had an issue of extremely high disc usage. NFO support showed that the constant re-checking of Workshop maps was the cause. Wiped all servers to start from scratch. All running fine with stock maps.

This morning, I took 5 custom maps and added them to one of our servers by editing the appropriate files with the appropriate code to get them to download to that server from Steam Workshop. So far, NONE of the 5 maps has downloaded. Rechecked entries........... all looks good. Can't seem to find the problem.
 

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
After much searching, it appears this is a common problem. From what I read in numerous forums, THIS issue is fairly common anymore. So, what I am understanding is that basically, Steam Workshop for custom maps is broke. The only "FIX" for this is to have Steam running on the box then maps will download, but this is a workaround frought with issues. Many say lag, I say high HD usage.

It also appears to me that Tripwire has no impetus to fix it! Shame, since they pushed the whole Steam Workshop idea as a big part of KF2. Guess I will be looking in to the possibility of setting up a re-direct, even though IT has issues too.
 

®omano

Grizzled Veteran
May 14, 2009
4,015
174
63
France
www.hellsoldiers.tk
OK I checked and I needed to, again, replace the steamclient64.so file for the Workshop to download again. Good thing is you can do the above procedure again and see if it works properly then (in short update manually again the 3 workshop dlls).
Kittenmittens
Yoshiro
[TW]Ramm-Jaeger

HELLO THE WORKSHOP FOR SERVER IS BROKEN BECAUSE IT'S BEEN MONTHS THAT YOU ARE OUT OF DATE FOR THE FILES steamclient64.so FOR LINUX AND THE FILES steamclient64.dll tier0_s64.dll vstdlib_s64.dll FOR WINDOWS!

WHAT THE HELL IS GOING ON YOUR COMPANY IS BECOMING PURE GARBAGE HONNESTLY. YOU IGNORE US ON PURPOSE BUT NOW IT'S BECOMING REALLY PROBLEMATIC!

edit: see the bug report here https://forums.tripwireinteractive.c...49#post2332749
 
Last edited:
  • Like
Reactions: Pharrahnox

fwfdf1reman

Member
Aug 11, 2016
144
8
18
66
Joshua, TX.
Thx for the info. So you had to AGAIN............... update those files yourself? It seems from what I read on the link you provided and by other sources, this FIX has to repeated often. That's B.S.!

Think I will leave the servers stock for now. All this has only convinced me to stay away from future Tripwire games! It is sad too as we have always enjoyed the Killing Floor games. Custom content is what keeps games alive for a long time; evidently Tripwire doesn't understand this.
 
  • Like
Reactions: ®omano

deckardblade

Member
Jan 16, 2011
168
4
18
Chicago, US
Even if I replace those files on my Linux servers while I can download new content, it spikes my CPU pretty heavily afterwards. I don't remember what error code it throws, too fed up to care really. Basically if I want a new map added I just download it with my Windows box and then manually upload to the Linux server while replicating both file locations/paths and editing the respective .ini's. I'm rather fed up with how this has not been addressed at all, but that's what alcohol and drugs are for!
 

Yoshiro

In Soviet Russia, Yoshiro is a cake
Staff member
Oct 10, 2005
12,284
3,455
113
This item is in our internal list and is something the team is working on.