Codec problem? Corrupt files?

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

OrLoK

FNG / Fresh Meat
Apr 29, 2006
20
0
0
I am having some problems exporting RO sound files to .wav format. When I have the .wav file, usually I can't reproduce it with any program, as if it was corrupt. But it doesn't occur always, and some sound files are exported without problems and I can use them.

So... what is happening?
 

Moz

FNG / Fresh Meat
Nov 21, 2005
1,773
1
0
I don't know, but are you exported them too directorys with spaces in the file name?

C:/blah/folder with spaces/sound/bbah/

because the ued will refuse to import them if the directory has a space in the name, so maybe it doesn't like exporting them either.
 

OrLoK

FNG / Fresh Meat
Apr 29, 2006
20
0
0
I don't know, but are you exported them too directorys with spaces in the file name?

C:/blah/folder with spaces/sound/bbah/

because the ued will refuse to import them if the directory has a space in the name, so maybe it doesn't like exporting them either.

I tried to export files to C:/ but it didn't work. It's very weird, because the file is correctly exported (I see the icon of the new .wav file) but I can't open him with my media players (including Adobe Audition).
 

Moz

FNG / Fresh Meat
Nov 21, 2005
1,773
1
0
they should be uncompressed pcm wav files.

I might look into this the next change I get.
 

Xancerman

FNG / Fresh Meat
Oct 17, 2005
304
1
0
Lule
make sure you dont try to expor the soundgroups.. the ones with * "stars" in front of them..

soundgroups are normally named with the suffix 01, 02, 03 etc.. while the actual sounds are named 011, 021, 031 etc.

other than that i cant really see any wrong here.. post how you are proceeding when you are about to export a sound.

click the sound. alt+f, + e, file -> export
 

OrLoK

FNG / Fresh Meat
Apr 29, 2006
20
0
0
make sure you dont try to expor the soundgroups.. the ones with * "stars" in front of them..

That was the problem! Thanks :D !

But now there is another problem that I think is a bug of the SDK:

- When I export a sound of the voice_sov_infantry directory and I open it... the voices that I listen are of the germans! Yes: for example, if you export gogogo04 of the voice_sov_infantry you will listen the gogogo04 of the voice_german_infantry directory. This bug doesn't occurs with the vehicle voices, that are exported correctly.
 
Last edited:

Xancerman

FNG / Fresh Meat
Oct 17, 2005
304
1
0
Lule
its simply UED acting up for some reason.. try renaming the packages, or moving the ones in your sound dir temporarily so that UED cant fetch sounds from the other packs.. always make sure you file->open the package you are going to work on, just picking the package in the dropdown can lead to sounds missing etc.

UED is a pain sometimes ;D