• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Can't Connect To Any Servers

Crunkalunk

FNG / Fresh Meat
Jun 19, 2010
5
0
0
This problem seems to happen at random, starting last night, lasting hours at a time.

Basically I try to join ANY server, even those with people in them, and it stays on the black "Connecting (Press F10 to cancel) KillingFloor:\\x.x.x.x\Index.rom" screen.

I've made no changes to my network settings and even went ahead and forwarded the ports even though I'm not running a server, to no avail. Deleted my KillingFloor.ini so it would generate a new one and even reinstalled the game, without any luck.

Any ideas?
 

Zetsumei

FNG / Fresh Meat
Nov 22, 2005
12,459
1,433
0
31
Falmouth UK
Try manually deleting your killingfloor system folder and then verifying the game cache. Steam delete doesn't delete all the files.
 

Crunkalunk

FNG / Fresh Meat
Jun 19, 2010
5
0
0
I don't wanna speak too soon, because the problem with intermitent problems is that you don't really know if you fixed it or if it's temporarily working... but here's what I did and what finally worked.

What didn't work:
  • Restarting computer
  • Putting router back to factory default settings
  • Toggling the NAT setting in KillingFloor.ini
  • Trashing KillingFloor.ini
  • Trashing System folder & using Steam to check local files
  • Using Steam to delete local files & reinstall
  • Trashing system folder & switching download locations & checking local files
  • This thread -> http://forums.tripwireinteractive.com/showthread.php?t=38803

What finally worked:
  1. Went to Steam library & uninstalled Killing Floor
  2. Manually delete entire killingfloor folder located in C:\Program Files\Steam\steamapps\common\ (If you're on x64 windows, it's C:\Program Files (x86)\...)
  3. Reinstall KillingFloor using Steam

In a couple hours I'll try it again to make sure it's still working, but that's what worked for me.
 

Misfire

FNG / Fresh Meat
Jun 25, 2010
3
0
0
I have the same problem, just bough tit, downloaded and can't connect to any servers.......

have uninstalled, delete and reinstalling now to see if it will fix it.
 

Misfire

FNG / Fresh Meat
Jun 25, 2010
3
0
0
this fixed it! must have had left over files from a free weekend or something, because when I launched it before it already had settings maxed out. Now after uninstalling it and reinstalling, its completely fresh and I had to set up settings again, but I can connect to servers fine now.