[Crash] Audio dies occasionally when server changes maps

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

SnowyOak

FNG / Fresh Meat
Jun 17, 2011
444
145
0
Chicago, USA
I don't mean the game audio, I mean my system stops making ANY sounds. The game doesn't have any audio anymore, my music won't play and when looking at the device properties in windows volume mixer it shows absolutely no signal.

I'm reporting this as a RO2 bug because after closing the game out, my audio restores completely. I've never experienced this with any other game, ever.

Let me know if you folks at TWI need ANYTHING I can provide to help give more info :)
 

kevee

FNG / Fresh Meat
Sep 18, 2011
1
0
0
I'm having almost similar problems, only that my audio gets totally f***d up after loading a new map. All the games sounds disappear and all I can hear is loud buzzing sound, almost like some interference from microphone. The thing is I don't have plugged anything into mic port. Checking Windows audio panel it shows that RO2 is making that sound. Buzzing sound disappears when I restart the game. :confused:
 

GloGi

FNG / Fresh Meat
Mar 6, 2006
21
37
0
Started happen to me too after the last two patch. Before that (even in beta) this never happened.
 

BlackGyver

FNG / Fresh Meat
Sep 18, 2011
8
1
0
Had the same problem, a couple times, and haven't found any way to restore the audio other than restarting the game, either.
 

atomMan

FNG / Fresh Meat
Sep 1, 2011
209
34
0
It's mostly on a map change.

Although sound was hardly ever perfect,
I never experienced or heard of THIS issue before the last patch.
 

NME

FNG / Fresh Meat
Aug 9, 2011
40
2
0
+1, map change means no audio 80% of the time. You can hear a clicking on the earphones every once in a while. Exiting and restarting is the only solution.
 

WAR10CK

FNG / Fresh Meat
Sep 17, 2011
3
0
0
Gotham City
Problems with sound

Problems with sound

The audio randomly stops working, and theres no sound. Then i have to close the game or wait for map change, and then it works again.
 

SnowyOak

FNG / Fresh Meat
Jun 17, 2011
444
145
0
Chicago, USA
So as far as reproducibility goes, we know this happens when a server switches maps upon load in.

It sounds like everyone experiences it a bit differently, though. I get audio loss, as do some others, while some get tremendous feedback and static.
 

dazman76

FNG / Fresh Meat
Aug 23, 2011
672
176
0
UK / Stalingrad
I've had this problem since beta, and it does still occasionally happen. I get a "static pop" from the sound system when it happens, and everything is then silent. On exiting the game, I get a second pop and all is well again - RO2 seems to be disabling and enabling the Windows audio system, or the sound card, or something :) It is then re-initialised/restored when the game exits.
 

un_fumeta

FNG / Fresh Meat
Apr 30, 2011
112
10
0
I had this in the BETA, like 2 or 3 times in 2 weeks. Now, I have had this 4 times in 3 or 4 hours of gaming. Unbelievable, but it has gotten worse... :(
 

DarkHunt3r

FNG / Fresh Meat
Jun 24, 2011
124
93
0
I get this, but I do not lose all sound, just game sound. My TS still works, and other sounds on my system, I have to exit the game and rejoin to get it to work again.

I have a creative Xfi music extreme soundcard just in case that is relevant
 

Raquel

FNG / Fresh Meat
Jul 27, 2011
383
194
0
Portugal
2 days ago it would happen EVERY time a server changed map, yesterday it didnt happen a single time, kinda weird <.<
 

un_fumeta

FNG / Fresh Meat
Apr 30, 2011
112
10
0
It's good to know you consider it a "beast" of a bug too, as it is not fun restarting the game every time a server changes map. Thanks!
 

DoktorFrost

FNG / Fresh Meat
Sep 15, 2011
89
13
0
its the first and only bug i hate...

is there sth we can do?

maybe interesting fact: when the sound dies (i Alt tab to desktop), my windows sound is lowered! (but not in the mixer section - cant see lowered fader, all is maximum normal) - and when i close the game - the windows sound is back to normal.

maybe this helps?

--

my guess: it has something to do with the microphone talk setting stuff..

if we could completely disable in game talking for testing purposes it will show if its the reason!
 
Last edited: